Forum Visual Studio


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Debugger doesn't work, "Frame not in module"?


I'm hitting Debug - (Start Debugging) on my app in Visual Studio with my Android device connected. If it hits an error I see a page with this message:

"Frame not in module" - "The current stack frame was not found in a loaded module. Source cannot be shown for this location"

This doesn't let me step through my code and use the debugger properly. How can I get this to work?



  • This is probably not the same issue - but FYI I see this kind of problem debugging on iOS when I have breakpoints in async methods. I have to set a breakpoint a line above what I actually want to break on and then do a step over. Then the debugger usually finds the context.

  • WitekRadomskiWitekRadomski SGMember ✭✭

    Do you only get this issue on iOS, but Android works for you? I am having the problem when debugging on my Android device

  • WitekRadomskiWitekRadomski SGMember ✭✭

    I've tested on an iOS device and if an unhandled exception is thrown, the debugger highlights the line of code. Why is this working on iOS yet not Android?

  • PaulFitzpatrickPaulFitzpatrick GBMember ✭✭

    I get this all the time it is very frustrating as I cannot debug. is there an exception setting that needs changing in visual studio? Any advice here is greatly received even if it is to use console.writeline..

  • DaneCasserly.3718DaneCasserly.3718 AUMember, University

    Yeah I would agree I also have this problem!!

  • MichaelReadMichaelRead GBMember

    I have this problem too. I am using Xamarin Forms.

  • DanielSoto.9046DanielSoto.9046 USMember

    Im also having this issue in Xamarin Forms, I cant debug PCL code from my android app, when i put breakpoints on the Android Code it works, but on PCL, it doesnt. I put Debugger.Break in PCL code and the message is "debugger doesnt work, frame not in module"

  • Please Xamarin Team, how to fix this problem

  • DanieleDaviDanieleDavi USMember

    Are you calling any .Dismiss(); in your code?

  • JeremyKolbJeremyKolb USMember ✭✭✭

    Report this via bugzilla otherwise the Xamarin team will miss it.

  • AneeshAneesh USMember

    This issue has always been there on and off with different versions and there are a bunch of threads/bugzilla items associated with it. Try the following, some of them has worked for me in the past

    1. Change linking options->Clean->build
    2. Change fast deployment -> build
    3. Make sure mdb files are been generated and switch debug info generation to all/pdb files and rebuild

    Good luck

  • MatheusGuimaraesMatheusGuimaraes GBMember, University ✭✭

    I keep getting the same error as well. I'm also using Xamarin.Forms and trying to debug an Android app. My Linking is set to None and I get the same error whether I have the Fast Deployment ticked or unticked. I asked some Xamarin University teachers and they don't know either so been asked to raise a ticket with support. I'll update you guys here if I hear anything or get this resolved.

  • LucasPallaresLucasPallares USMember

    Same problem, any solution?

  • Clear content from bin\Debug for PCL and Platform specific projects (droid or IOS).This will resolve your debug issue.

  • MatheusGuimaraesMatheusGuimaraes GBMember, University ✭✭

    Just an update : I've contacted xamarin university and they started looking at this for me, but so far they just said they are not able to reproduce it and asked me to do a reinstall, apply all updates and try again.

    I'm going to try this but not too hopeful. In my case, it only happens with Android and it's not specific to Xamarin.Forms, even the simplest of Android apps gives me the Frame not in module error.


  • I worked, now tells me exactly where my mistake ... because I'll fix it

  • I've just tried your solution Matheus, but unfortunately it doesn't work:(
    Could you tell use your theory please? :smile:

  • Arun90Arun90 USMember

    @Aneesh said:
    This issue has always been there on and off with different versions and there are a bunch of threads/bugzilla items associated with it. Try the following, some of them has worked for me in the past

    1. Change linking options->Clean->build
    2. Change fast deployment -> build
    3. Make sure mdb files are been generated and switch debug info generation to all/pdb files and rebuild

    Good luck

    Thanks Aneesh, that fixed the Problem.

  • YananaYanana USMember

    @MatheusGuimaraes said:
    Can whoever still has this problem check if on Exception Settings you have "Common Language Runtime Exceptions" ticked? Just make sure it's ticked on the parent level so all options below it are ticked too, then try again and see if it works. Please see attached screenshot. You can get to that screen by going to "DEBUG -> Exceptions..."

    This worked for me, but in Visual Studio 2015 you find this option under : Debug -> Windows -> Exception settings

  • xCyborgxCyborg USMember ✭✭

    Still having this problem, anything definitive yet?

  • alaylwintalaylwint MMMember


    I am also facing this problem. My API is working in C# MVC Application well. Now I would like to use Xamarin to consume that api service.
    When I call from my xamarin project as following, Error message replied that Frame not in Module.

    I used Both
    var response = await Client.GetAsync(actualResourceUri).ConfigureAwait(false);
    var response = await Client.GetAsync(actualResourceUri);

    How can I solve it ? Thanks...

  • hi Guys,
    after upgrade to the last version - the debugger stop working,., downgrade to previous version doesn't help...
    any idea how to solve it?

  • ArvindrajaArvindraja INMember ✭✭✭

    I'm also facing the same issue in VS2015. instead starting to another activity it showing the "Frame not in module message".
    if anyone have solution please post that and you can see the screenshots of Visual Studio.thank you

  • SAIBIMajdiSAIBIMajdi TNMember

    The same problem here, I am trying to consume my ASP.NET Web API !!

  • sqltsqlt USMember

    Same here. PCL in Xamarin Forms. Still experiencing the issue connecting to a Web API. It works flawlessly (no errors) in Windows, but keep getting the "frame not in module" message in Android.

  • sqltsqlt USMember

    For those of you looking for Android debugging, this article shows how to pull up some device logs. It's not perfect, but it helps. Essentially, go to View > Other Windows > Android Device Logging. Text mode makes it a little easier to read the stack.

    Some of you have mentioned that you're experiencing issues connecting to a WebAPI with an Android project, this article got me connected immediately. The main issue is WiFi connectivity on the device, so through the device/emulator, go to Settings > WiFi > long click on Wired eth1 > Modify Network > Show Advanced Options > Change "IP Settings" to Static

  • pramodkpramodk INMember
    edited May 2016

    Facing the same issue. Just started working on Xamarin. Any help/update on this?
    Tried everything mentioned above. Nothing helped.

  • xCyborgxCyborg USMember ✭✭

    That's still happening as of the latest update ( whether on Forms or blank android apps.

  • pramodkpramodk INMember

    Xamarin, Are you guys still on this planet?

  • AnaxAnax GRMember
    edited June 2016

    Same issue with me here but I have noticed that it only occurs inside async functions. If the code error is outside any async then the debugger correctly points to that line. I'm developing on Android.

  • PubuduGayanPubuduGayan NZMember ✭✭✭

    Tried all the methods that mentioned on above but no result yet. please Xamarin save us. guys please let me know if you found any solution for this awful headache.

  • ChrisApersChrisApers USMember

    Same problem for all my team using VS2015.
    Still no news on this?

    It is really weird to see that there are no official answers/tips from Xamarin.
    This issue has been reported here in Nov 2014 and we are mid-2016 now!!!


  • Hayden_HancockHayden_Hancock USMember ✭✭

    I am also having this issue.

    Visual Studio Professional 2015 Version 14.0.25123 Update 2

    Any help would be greatly appreciated. It's causing a huge issue in my workflow because I can't easily debug.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    Yes - same problem VS2015 Update 3 RC, ,forms shared 23.0.107 -> debug Android project ti device!

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @WitekRadomski, @StephenWilkinson, @PaulFitzpatrick, @DaneCasserly.3718, @MichaelRead, @DanielSoto.9046, @SyedMuhammadAhmad, @DanieleDavi, @JeremyKolb, @Aneesh, @MatheusGuimaraes, @AndresCRGrecia21, @GeorgescuCatalin, @Arun90, @Yanana, @xCyborg, @alaylwint, @YosiNardea.6416, @Arvindraja, @SAIBIMajdi, @sqlt, @pramodk, @Anax, @PubuduGayan, @ChrisApers, @Hayden_Hancock (puhh... never had to "generate" such a long mention list :smirk:):

    I have investigated the problem a bit more in detail...

    The error-messages “frame not in module” appears every time, if VS try to investigate “foreign” code.
    This, although I have set the option “Enable Just My Code” in the options to the debugger.
    So... for me it’s a bug.

    However, a simple workaround works for me:
    In debug mode simply click on the button step over (F10) instead of “step into”
    (note: this is the button on the right of the button "step over" in the upper icon bar of VS)

    Hope this helps somebody... :sunglasses:

  • sqltsqlt USMember



  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    You're welcome...

  • BobJJBobJJ RUMember ✭✭

    Only this worked for me on VS 2015:

    1. open "DEBUG -> Windows -> Exception Settings"

    2. tick the parent option "Common Language Runtime Exceptions" so all its children are ticked.

    (same works with VS 2013 but on step 1. open "DEBUG -> Exceptions)

  • Jan-DavidStrkJan-DavidStrk USMember ✭✭

    Same problem here (VS 2015 Enterprise) :(

Sign In or Register to comment.