What else can I do to have my iPhoneSimulator to work?

PerDahlPerDahl SEMember

This is obviously not a new failure and I have tried the solutions I found on this forum earlier. I am new with development on Xamarin and running Visual Studio 2013 inside Parallels since VS is the only way for easy true cross-platform development (using trial license).

I got it working for Windows Phone (of course) and also for Android but I really tried many hours now to get it working for iOS as well but no. I do have paired my build host in my mac to my visual studio.

I get the following error when I try to run the iPhoneSimulator (iPhone 4s iOS 8.3) (debug/release)

Failed to start application on the target simulator

Server returned an error. The remote server returned an error: (401) Unauthorized.
Server error code: 401
You are not authorized to run this command

Solutions already tried;
Made sure build host and visual studio are using latest stable version of Xamarin - No
Paired, unpaired and paired again... multiple times - No
Emptied Xamarin cache in my Parallels instance and unpaired and paired again - No
Tried cleaning solution, changing info.plist to copy always, doing release build and then a debug build - No
Tried to remove the dot '.' in assembly name - No
Tried multiple restarts of both parallels as well as my Mac host - No
Made sure my App is building for iOS 8.3 - No



  • JohnErikssonJohnEriksson USUniversity ✭✭

    Did you find a solution to this problem?

  • JohnErikssonJohnEriksson USUniversity ✭✭

    I had this problem and spent many hours trying to figure it out. I thought I found a solution when it all started to work after I turned off the diskencryption on my mac. But today, after a reinstallation of my virtual machine and an update of Xamarin on both platforms the problem has returned. :-(

    My collegue has the same set up as me, using the same versions and he hasn't got this problem. My next step will be to test a separate windows computer to see if that can make the build host behave.

    I have no problem connecting to the build host and I think it also builds the code, the only thing that doesn't work is the actual launching of the simulator (reporting 401 in the log and back to VS).

  • PerDahlPerDahl SEMember

    No, I have had no luck to solve this issue. I spent many hours as well to just get started. I wanted to try out Xamarin but now half the time has gone. Wasted on trying to resolve just to get started on each platform. Not especially good PR for Xamarin. Also as much I have read on forums that others spending hours and hours again solving tool issues instead of adding business value for clients.

Sign In or Register to comment.