TaskyAndroid is crashing.

Galaxy S6. I deploy in debug mode and get this immediately (the UI pops up on my phone, but then immediately dissapears the moment I continue the debugger):

Forwarding debugger port 8830
Detecting existing process
Loaded assembly: /storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/TaskyAndroid.dll
Loaded assembly: /storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/Tasky.Core.Anroid.dll
Loaded assembly: Mono.Android.dll [External]
[Zygote] MountEmulatedStorage()
[Zygote] v2
[SELinux] Function: selinux_compare_spd_ram , priority [2] , priority version is VE=SEPF_SM-G920V_5.0.2_0009
[SELinux] [DEBUG] get_category: variable seinfo: default sensitivity: NULL, cateogry: NULL
[art] Late-enabling -Xcheck:jni
[libpersona] KNOX_SDCARD checking this for 10247
[libpersona] KNOX_SDCARD not a persona
[TimaKeyStoreProvider] TimaSignature is unavailable
[InjectionManager] Inside getClassLibPath + mLibMap{0=, 1=}
[AssetManager] addAssetPath path =/data/app/com.xamarin.samples.taskyandroid-1/base.apkmapset is 0
[AssetManager] addAssetPath path =/data/app/com.xamarin.samples.taskyandroid-1/base.apk, mapOffset =0
[AssetManager] addAssetPath path =/data/app/com.xamarin.samples.taskyandroid-1/base.apk,elasticAppCookieOffset ={3=0}
[LoadedApk] getClassLoader :null
[InjectionManager] Inside getClassLibPath caller
[LoadedApk] classLibPath :, mActivityThread.mCoreFeatureClassLoader :null
[LoadedApk] getClassLoader :dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/com.xamarin.samples.taskyandroid-1/base.apk"],nativeLibraryDirectories=[/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64, /vendor/lib64, /system/lib64]]]
[LoadedApk] getClassLoader :dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/com.xamarin.samples.taskyandroid-1/base.apk"],nativeLibraryDirectories=[/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64, /vendor/lib64, /system/lib64]]]
[monodroid] Using override path: /data/data/com.xamarin.samples.taskyandroid/files/.override
[monodroid] Using override path: /storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override
[monodroid] Trying to load sgen from: /data/data/com.xamarin.samples.taskyandroid/files/.override/libmonosgen-2.0.so
[monodroid] Trying to load sgen from: /storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/libmonosgen-2.0.so
[monodroid] Trying to load sgen from: /data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libmonosgen-2.0.so
[monodroid] Trying to load sgen from: /data/data/com.xamarin.samples.taskyandroid/files/.override/links/libmonosgen-2.0.so
[monodroid-debug] Trying to initialize the debugger with options: --debugger-agent=transport=dt_socket,loglevel=0,address=127.0.0.1:8830,server=y,embedding=1
[Mono] AOT module 'mscorlib.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-mscorlib.dll.so" not found
[Mono] AOT module '/Users/builder/data/lanes/monodroid-mavericks-monodroid-5.1-series/d23da369/source/monodroid/builds/install/mono-aarch64/lib/mono/aot-cache/arm64/mscorlib.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-mscorlib.dll.so" not found
[Mono] Assembly mscorlib[0x7f95509b80] added to domain RootDomain, ref_count=1
[Mono] Assembly Loader probing location: '/storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/TaskyAndroid.dll'.
[Mono] Assembly TaskyAndroid[0x7f955ce380] added to domain RootDomain, ref_count=1
[Mono] AOT module '/storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/TaskyAndroid.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-TaskyAndroid.dll.so" not found
[Mono] AOT module '/Users/builder/data/lanes/monodroid-mavericks-monodroid-5.1-series/d23da369/source/monodroid/builds/install/mono-aarch64/lib/mono/aot-cache/arm64/TaskyAndroid.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-TaskyAndroid.dll.so" not found
[Mono] Assembly Loader loaded assembly from location: '/storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/TaskyAndroid.dll'.
[Mono] Config attempting to parse: '/storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/TaskyAndroid.dll.config'.
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mavericks-monodroid-5.1-series/d23da369/source/monodroid/builds/install/mono-aarch64/etc/mono/assemblies/TaskyAndroid/TaskyAndroid.config'.
[Mono] Assembly Loader probing location: '/storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/Tasky.Core.Anroid.dll'.
[Mono] Assembly Tasky.Core.Anroid[0x7f955ce500] added to domain RootDomain, ref_count=1
[Mono] AOT module '/storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/Tasky.Core.Anroid.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-Tasky.Core.Anroid.dll.so" not found
[Mono] AOT module '/Users/builder/data/lanes/monodroid-mavericks-monodroid-5.1-series/d23da369/source/monodroid/builds/install/mono-aarch64/lib/mono/aot-cache/arm64/Tasky.Core.Anroid.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-Tasky.Core.Anroid.dll.so" not found
[Mono] Assembly Loader loaded assembly from location: '/storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/Tasky.Core.Anroid.dll'.
[Mono] Config attempting to parse: '/storage/emulated/0/Android/data/com.xamarin.samples.taskyandroid/files/.override/Tasky.Core.Anroid.dll.config'.
[Mono] Config attempting to parse: '/Users/builder/data/lanes/monodroid-mavericks-monodroid-5.1-series/d23da369/source/monodroid/builds/install/mono-aarch64/etc/mono/assemblies/Tasky.Core.Anroid/Tasky.Core.Anroid.config'.
[monodroid-gc] GREF GC Threshold: 46080
[Mono] Assembly Mono.Android[0x7f955ce580] added to domain RootDomain, ref_count=1
[Mono] AOT module 'Mono.Android.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-Mono.Android.dll.so" not found
[Mono] AOT module '/Users/builder/data/lanes/monodroid-mavericks-monodroid-5.1-series/d23da369/source/monodroid/builds/install/mono-aarch64/lib/mono/aot-cache/arm64/Mono.Android.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-Mono.Android.dll.so" not found
[Mono] DllImport attempting to load: '__Internal'.
[Mono] DllImport loaded library '(null)'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_lref_log_new'.
[Mono] Probing '_monodroid_lref_log_new'.
[Mono] Found as '_monodroid_lref_log_new'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_lref_log_delete'.
[Mono] Probing '_monodroid_lref_log_delete'.
[Mono] Found as '_monodroid_lref_log_delete'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gref_log_new'.
[Mono] Probing '_monodroid_gref_log_new'.
[Mono] Found as '_monodroid_gref_log_new'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_get_identity_hash_code'.
[Mono] Probing '_monodroid_get_identity_hash_code'.
[Mono] Found as '_monodroid_get_identity_hash_code'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gref_log'.
[Mono] Probing '_monodroid_gref_log'.
[Mono] Found as '_monodroid_gref_log'.
[Mono] Assembly System.Core[0x7f87bb8c80] added to domain RootDomain, ref_count=1
[Mono] AOT module 'System.Core.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-System.Core.dll.so" not found
[Mono] AOT module '/Users/builder/data/lanes/monodroid-mavericks-monodroid-5.1-series/d23da369/source/monodroid/builds/install/mono-aarch64/lib/mono/aot-cache/arm64/System.Core.dll.so' not found: dlopen failed: library "/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64/libaot-System.Core.dll.so" not found
Loaded assembly: System.Core.dll [External]
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gref_log_delete'.
[Mono] Probing '_monodroid_gref_log_delete'.
[Mono] Found as '_monodroid_gref_log_delete'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gc_wait_for_bridge_processing'.
[Mono] Probing '_monodroid_gc_wait_for_bridge_processing'.
[Mono] Found as '_monodroid_gc_wait_for_bridge_processing'.
[InjectionManager] InjectionManager
[InjectionManager] fillFeatureStoreMap com.xamarin.samples.taskyandroid
[InjectionManager] Constructor com.xamarin.samples.taskyandroid, Feature store :{}
[InjectionManager] featureStore :{}
[LoadedApk] getClassLoader :dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/com.xamarin.samples.taskyandroid-1/base.apk"],nativeLibraryDirectories=[/data/app/com.xamarin.samples.taskyandroid-1/lib/arm64, /vendor/lib64, /system/lib64]]]
Loaded assembly: MonoDroidConstructors [External]
[mono]
[mono] Unhandled Exception:
[mono] System.ExecutionEngineException: SIGILL
[mono-rt] [ERROR] FATAL UNHANDLED EXCEPTION: System.ExecutionEngineException: SIGILL

Answers

  • ysteinHeimarkysteinHeimark NOMember

    +1

    Facing the same issue when running my Android app in debug mode on Galaxy S6 edge

  • UrsinBrunnerUrsinBrunner CHMember ✭✭
    edited May 2015

    The same here, also with Samsung Galaxy S6 (API 21). Happens with every app I create.

    Changing to another test-device (Samsung S4, API 19) the exact same code shows no issue.

    Is there a solution for this problem out there? (asking because the thread is marked as "Answered")

  • BenjaminRushBenjaminRush USMember

    No, no answer has been found. Not sure why it's marked as answered.

    Xamarin? Anybody out there know what's going on?

  • ErikArenhillErikArenhill SEMember ✭✭

    Same problem here. Can't run any Android application at all, not even the default boilerplate application from starting a new project. Tried both Stable and Alpha channel releases. I'm running Samsung S6 Edge with Android 5.0.2.

    They have a verified bug for it, but seems to take forever before it is fixed...

    "Non-public Bug 28995 - [Android] On certain devices apps crash rarely due to "System.ExecutionEngineException: SIGILL""
    source: http://forums.xamarin.com/discussion/40279/alpha-service-release-xamarin-android-5-1-1-bug-fixes-for-5-1-0

  • ScottAdamsScottAdams GEMember

    Removing x64 from the build targeting options fixed this for me.

  • TeoTeo DKMember ✭✭

    I'm having the same issue on Galaxy S6 edge as well, Android version 5.0.2

  • These settings worked for me

  • MihaMarkicMihaMarkic SI ✭✭✭✭

    @BenjaminRush The forums works like this. When a question gets a reply, it is automatically marked as answered and when a reply is marked as "correct answer", the "answered" tag gets a checkmark. Bizzare, if you ask me.
    But if you guys have these kind of problems it might be better to post them to bugzilla or notify the support via an e-mail.

  • BenjaminRushBenjaminRush USMember

    @MihaMarkic Thanks. I'll remember that for the future.

  • ErikArenhillErikArenhill SEMember ✭✭

    @ScottAdams @ChristianChristiansen Thanks that worked for me too, saved my day, havn't been able to debug on Android for several weeks

  • UrsinBrunnerUrsinBrunner CHMember ✭✭

    Many thanks to @ScottAdams @ChristianChristiansen! It's not a perfect solution (because can not use shared mono runtime anymore), but at least I can use my device again.

  • MarkFredricksonMarkFredrickson USMember ✭✭

    Same problem with the new LG G4 and VS 2013. I can't debug with any of the above suggested settings. With 'Use Shared Runtime' checked the app starts and after about 4 seconds terminates. Unchecking 'Use Shared Runtime' and using @ScottAdams suggestion the app runs but the debugger does not start. Similar behavior using XS. No problems with the G3. The difference between the two is the G3 is a 32 bit processor running Android 5.01 and the G4 is a 64 bit processor running Android 5.1. I'm guessing the issue has something to do with the 64 bit processor. I've tried about every combination I can think of with no luck. Any other suggestions?

  • ad0ranad0ran USMember ✭✭

    I'm also have the exact same problem.
    I built a Xamarin.Forms application using a Samsung Galaxy S3 as a test device. Deploys and runs just fine on Android KitKat, but I get this exception trying to run the application on a Samsung Galaxy S6:

    07-06 11:00:47.211 E/mono ( 658): Unhandled Exception:
    07-06 11:00:47.211 E/mono ( 658): System.ExecutionEngineException: SIGILL
    07-06 11:00:47.211 E/mono ( 658): at (wrapper managed-to-native) object:wrapper_native_0x7f79b5cca4 (intptr,intptr)
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.AllocObject (IntPtr jclass) [0x00020] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.g.cs:114
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.AllocObject (System.Type type) [0x00007] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:281
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.StartCreateInstance (System.Type type, System.String jniCtorSignature, Android.Runtime.JValue* constructorParameters) [0x0000a] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:318
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.StartCreateInstance (System.Type type, System.String jniCtorSignature, Android.Runtime.JValue[] constructorParameters) [0x0001d] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:326
    07-06 11:00:47.211 E/mono ( 658): at Java.Lang.Object..ctor () [0x0001c] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Java.Lang/Object.cs:72
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.UncaughtExceptionHandler..ctor (IUncaughtExceptionHandler defaultHandler) [0x00000] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/UncaughtExceptionHandler.cs:28
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.Initialize (Android.Runtime.JnienvInitializeArgs* args) [0x002f4] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:245
    07-06 11:00:47.211 D/Mono ( 658): DllImport searching in: '__Internal' ('(null)').
    07-06 11:00:47.211 D/Mono ( 658): Searching for '_monodroid_gref_log_delete'.
    07-06 11:00:47.211 D/Mono ( 658): Probing '_monodroid_gref_log_delete'.
    07-06 11:00:47.211 D/Mono ( 658): Found as '_monodroid_gref_log_delete'.
    07-06 11:00:47.211 E/mono-rt ( 658): [ERROR] FATAL UNHANDLED EXCEPTION: System.ExecutionEngineException: SIGILL
    07-06 11:00:47.211 E/mono-rt ( 658): at (wrapper managed-to-native) object:wrapper_native_0x7f79b5cca4 (intptr,intptr)
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.AllocObject (IntPtr jclass) [0x00020] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.g.cs:114
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.AllocObject (System.Type type) [0x00007] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:281
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.StartCreateInstance (System.Type type, System.String jniCtorSignature, Android.Runtime.JValue* constructorParameters) [0x0000a] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:318
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.StartCreateInstance (System.Type type, System.String jniCtorSignature, Android.Runtime.JValue[] constructorParameters) [0x0001d] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:326
    07-06 11:00:47.211 E/mono-rt ( 658): at Java.Lang.Object..ctor () [0x0001c] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Java.Lang/Object.cs:72
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.UncaughtExceptionHandler..ctor (IUncaughtExceptionHandler defaultHandler) [0x00000] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/UncaughtExceptionHandler.cs:28
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.Initialize (Android.Runtime.JnienvInitializeArgs* args) [0x002f4] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:245

  • ad0ranad0ran USMember ✭✭

    I'm also have the exact same problem.
    I built a Xamarin.Forms application using a Samsung Galaxy S3 as a test device. Deploys and runs just fine on Android KitKat, but I get this exception trying to run the application on a Samsung Galaxy S6:

    07-06 11:00:47.211 E/mono ( 658): Unhandled Exception:
    07-06 11:00:47.211 E/mono ( 658): System.ExecutionEngineException: SIGILL
    07-06 11:00:47.211 E/mono ( 658): at (wrapper managed-to-native) object:wrapper_native_0x7f79b5cca4 (intptr,intptr)
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.AllocObject (IntPtr jclass) [0x00020] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.g.cs:114
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.AllocObject (System.Type type) [0x00007] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:281
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.StartCreateInstance (System.Type type, System.String jniCtorSignature, Android.Runtime.JValue* constructorParameters) [0x0000a] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:318
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.StartCreateInstance (System.Type type, System.String jniCtorSignature, Android.Runtime.JValue[] constructorParameters) [0x0001d] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:326
    07-06 11:00:47.211 E/mono ( 658): at Java.Lang.Object..ctor () [0x0001c] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Java.Lang/Object.cs:72
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.UncaughtExceptionHandler..ctor (IUncaughtExceptionHandler defaultHandler) [0x00000] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/UncaughtExceptionHandler.cs:28
    07-06 11:00:47.211 E/mono ( 658): at Android.Runtime.JNIEnv.Initialize (Android.Runtime.JnienvInitializeArgs* args) [0x002f4] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:245
    07-06 11:00:47.211 D/Mono ( 658): DllImport searching in: '__Internal' ('(null)').
    07-06 11:00:47.211 D/Mono ( 658): Searching for '_monodroid_gref_log_delete'.
    07-06 11:00:47.211 D/Mono ( 658): Probing '_monodroid_gref_log_delete'.
    07-06 11:00:47.211 D/Mono ( 658): Found as '_monodroid_gref_log_delete'.
    07-06 11:00:47.211 E/mono-rt ( 658): [ERROR] FATAL UNHANDLED EXCEPTION: System.ExecutionEngineException: SIGILL
    07-06 11:00:47.211 E/mono-rt ( 658): at (wrapper managed-to-native) object:wrapper_native_0x7f79b5cca4 (intptr,intptr)
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.AllocObject (IntPtr jclass) [0x00020] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.g.cs:114
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.AllocObject (System.Type type) [0x00007] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:281
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.StartCreateInstance (System.Type type, System.String jniCtorSignature, Android.Runtime.JValue* constructorParameters) [0x0000a] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:318
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.StartCreateInstance (System.Type type, System.String jniCtorSignature, Android.Runtime.JValue[] constructorParameters) [0x0001d] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:326
    07-06 11:00:47.211 E/mono-rt ( 658): at Java.Lang.Object..ctor () [0x0001c] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Java.Lang/Object.cs:72
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.UncaughtExceptionHandler..ctor (IUncaughtExceptionHandler defaultHandler) [0x00000] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/UncaughtExceptionHandler.cs:28
    07-06 11:00:47.211 E/mono-rt ( 658): at Android.Runtime.JNIEnv.Initialize (Android.Runtime.JnienvInitializeArgs* args) [0x002f4] in /Users/builder/data/lanes/1780/3518c4ce/source/monodroid/src/Mono.Android/src/Runtime/JNIEnv.cs:245

  • LinusNeumanLinusNeuman SEMember

    I'm getting reports from my game artist that the game crashes on his Galaxy S6. Black screen, music is still running in the background, but the whole screen is black and sometimes fades to green and all kinds of weird stuff. I've set the linker to only link SDK Assemblies, I don't use shared runtime, and I've deselected arm64-v8a and x86_64. He still can't play it. It's really hard debugging this since I don't have a S6 myself.

  • b1b1882b1b1882 CAMember

    @ChristianChristiansen do you have a bigger image ? i cant seem to see it

Sign In or Register to comment.