No option to publish in version control?

I've been trying for a few days now to get my project up on my github, following every step from many different sites. All of them say click the menu button (or right-click) the project, go to Version Control and select the "Publish" option... but when I do, there is no publish option. The only options I have are Push Changes, Merge Branch, Remove, Review and Commit, Create Patch, and Log. Nowhere is there an option to "Publish" and none of the other options lead my to entering my github information. One website mentioned that this might be a problem and suggests to open and close the menu a few times and it should show up, but it never does and I've done that MANY times.

I've tried reloading Xamarin Studio, even recreating the project from scratch, but nothing seems to work. Is there any way to get around this at this time or am I completely stuck?

Best Answer

Answers

  • renzskarenzska USMember ✭✭

    I'm experiencing the same issue. I cannot get my solution from Xamarin Studio on my Mac into my Visual Studio online account. The "Publish" option does not exist. When I go to push changes after doing a "checkout", nothing is available to push. Any help would be appreciated.

  • FilipTodorovicFilipTodorovic USMember

    This actually worked! But it seems that my authentication failed since I have two-factor authentication enabled in github. Is there any way to allow it to work with Xamarin Studio?

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    Yes. Go to settings on GitHub -> Generate a new token and use that instead of the password when authenticating. It's the same as when using commandline.

Sign In or Register to comment.