Forum Visual Studio

Xamarin Studio and mono 3.x

Hi to all!

I now that iOS Designer in Xamarin Studio is not, for now, compatible with Xcode 4.2 so i will have to downgrade Xcode to a previous version to be able to work with that. But i read somewhere that i need to have mono 3.x and i see that i have the v. 2.10.

Should i wait for Xamarin Studio Updater to fetch 3.x version of mono, is there i should download a stable version of it or i must do something else for this to work ?

Thanks a lot for any help on this!

Posts

  • StephaneCordonnierStephaneCordonnier FRMember ✭✭

    Xamarin Studio is compatible with Xcode 4.6.2 since few days/weeks.

    You need to download XS 4.0.4 from Beta channel or XS 4.1.1 from Alpha channel.

  • AnthonyBoudouvasAnthonyBoudouvas GRMember ✭✭

    Thanks for the fast reply!

    If i download 4.04 from Beta channel, will it fetch mono 3.x for me ? And then, what i need to do when all this stuff become non-beta ? Switch to "stable" channel from the IDE ?

    Thank you again!

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Actually, 4.0.4 should already be in the stable channel.

    You don't need Mono v3.0.x unless you want to try out the async stuff.

  • AnthonyBoudouvasAnthonyBoudouvas GRMember ✭✭

    Hey jstedfast, thans for the help!

    Wiered...it seems that i already have 4.0.4 but when i double click on a .storyboard file, Xcode opens. Should the XS iOS designer handle it ?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    oh, I totally misunderstood your question.

    The iOS Designer that was demoed at Evolve in the keynote is in Xamarin Studio 4.1.1 (in the Alpha channel). 4.0.4 still uses Xcode's UI designer.

    4.1.1 should be safe to use with Xcode 4.6.2.

  • AnthonyBoudouvasAnthonyBoudouvas GRMember ✭✭

    Ok!

    Then, i have to download 4.1.1 from alpha channel, even if i generally do not like installing alpha software...

    Are there any issues with 4.1.1 that you can tell me so i be carefull about ?

    Thanks a lot for your help!

Sign In or Register to comment.