Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

iOS archive submissions failed with errors - Disallowed paths ("iTunesMetadata.plist")

khickskhicks USUniversity ✭✭
edited May 2015 in Xamarin.iOS

I am trying to submit an app update to iTunes Connect to release on TestFlight, and I am encountering an error on submission:

Archive submission failed due to the issues listed below.
ERROR ITMS-90047: "Disallowed paths ("iTunesMetadata.plist") found at: Payload/MyAppName.app"

Since my last submission, a single source code file changed, so I don't know where the iTunesMetadata.plist file comes into play.

I am running the latest stable build of Xamarin Studio.

Are there any suggestions as to what I can try to get this app submission to go through?

«1

Posts

  • JrgAckermannJrgAckermann DEMember, University

    Some Problem here...

  • AveeanAveean USMember

    Also having this issue. Not sure how to solve it. Most solved answered involved images instead - and I tried their solutions with no results.

  • ThomasElgaardThomasElgaard USMember

    I am getting this error too, I was looking forward to push a new build :( Hopefully there will be a solution soon

  • BhimaniBhimani INMember
    edited May 2015

    same problem here as well... in fact I do not have iTunesMetadata.plist file in my project.

  • HipolytoObesoHipolytoObeso MXMember, University

    Same problem, any solution?

    Thanks

  • JoeJupinJoeJupin USMember

    Same problem - released a build for Prerelease yesterday - no problems - submitting a different build to change servers today generates this error.

  • LuckyDayLuckyDay USMember ✭✭✭

    I also just ran into this, on my mac build host I opened the xarchive (right click, show package contents), navigated to Payload/.app and opened that (again using show package contents) and deleted itunesmetadata.plist. Upload is still processing but it got me past that submission error.

  • AveeanAveean USMember

    Please let us know if it caused any other problems. If not I'll do this as well.

  • CodyBCodyB USXamarin Team Xamurai

    Hello everyone!

    This should not occur if you use the Publishing Workflow in Xamarin Studio: http://developer.xamarin.com/releases/studio/xamarin.studio_5.9/xamarin.studio_5.9/#Publishing_Workflow

    and

    http://developer.xamarin.com/guides/ios/deployment,_testing,_and_metrics/app_distribution_overview/publishing_to_the_app_store/#Building_the_Distributable

    You will need to ensure that you sign the app bundle within that workflow, and you do not want to choose the option to use the existing signature.

    If the error continues to occur after using the Publishing Workflow in Xamarin Studio, please let me know and we will work to get the issue resolved.

    Thanks!

  • JoeJupinJoeJupin USMember

    Not for nothing - but it's obvious we've been using the correct procedure if we've done this before. So, implying that everyone is suddenly not following the correct workflow is patently wrong.

    Instead, the proper response is to check what's changed for us. Either in how Xamarin generates the builds, or if iTunes changed the way they want the app bundles created. Either way, this is a problem with the way Xamarin generates the builds - not with us, the developer incorrectly following the steps.

    Wouldn't you agree?

  • JoeJupinJoeJupin USMember

    to JonRuskin: could you be more specific about how you "opened the archive". Did you navigate to it in the Finder, or what?

    I tried right-clicking on the Archive panel in Xamarin Studio - and there's no option to Show Package contents. The only options are

    1) Sign and Distribute
    2) Delete Archive

    More details would be fantastic.

    Joe...

  • DWestyDWesty USMember ✭✭

    the odd thing about this is I havent updated Xamarin...at all this month out of fear of it breaking things(cause it happens a lot)... Is it possible that this is an iTunes issue?

  • JoeJupinJoeJupin USMember

    I agree that this is probably an iTunes issue - maybe they've changed how they look at the apps during submission - either way, it means Xamarin Studio has to adjust how the builds are generated.

    As I mentioned previously - I created and submitted a build yesterday - and it went up just fine. The only change for today's build was which server the build pointed to (merely a switch in our code) - so the generation of the build should be exactly the same in Xamarin...

  • MatteoMonizzaMatteoMonizza ITBeta ✭✭

    Same here

  • DWestyDWesty USMember ✭✭
    edited May 2015

    yeah I have the same issue I've been doing daily builds for the past two weeks because we are in crunch... and then boom this.... luckily for me I guess my client wants Android first...

  • deckertron9000deckertron9000 USUniversity ✭✭✭

    @byrc

    Following the "Publishing Workflow" to the letter results in an Application Loader message that references iTunesMetadata.plist that everyone else has mentioned. This issue began occurring this afternoon. My previous, successfully uploaded build also contains the iTunesMetadata.plist. This leads me to believe something changed on Apple's side.

    With that in mind, it would be nice to receive three things from Xamarin in the next few days:

    1) an update/confirmation of this issue.
    2) a workaround (if one exists).
    3) an ETA on an expected fix.

    I think it goes without saying but this is a BIG deal. It renders us unable to create new iOS applications or even provide updates to existing ones.

    Thank you in advance for your time.

  • DWestyDWesty USMember ✭✭
    edited May 2015

    a

  • CodyBCodyB USXamarin Team Xamurai

    @deckertron9000 et al.

    Thank you for the feedback. I am working with the team here, and we will provide more info as we investigate further.

    Thanks again!

  • RenatoTodorovRenatoTodorov BRMember

    Also happening to me, I need to send my app NOW and I can't because of this!

    Yesterday night was fine.....

  • FetbiFetbi USUniversity
    edited May 2015

    Same thing is happening here. It was fine yesterday.

  • DWestyDWesty USMember ✭✭

    @JonRuskin thanks you the update...that last step .... of using Xcode to sign rather than Xamarin Studio allowed me to update after removing the file. If I modified the xarchive and then tried to sign it with Xamarin Studio I would get a signing error.

  • ahmedkhanahmedkhan USUniversity ✭✭

    @JonRuskin -Thanks!!- your workaround also worked for me - I was stuck till i followed the XCode upload and removed the offending plist file manually from the app store archive build

    this appears to be an Issue with the latest build of Xamarin Studio..as I wasnt getting this error till I updated today

  • CodyBCodyB USXamarin Team Xamurai

    @ahmedkhan

    Which channel are you? Are you able to provide the version information by:

    Open Xamarin Studio, Click Xamarin Studio > About Xamarin Studio > Show Details

    Thanks!

  • JoeJupinJoeJupin USMember

    @JonRuskin

    This worked. For us Mac OS X - centric folks () - when Jon mentions "Payload/.app" - he means

    "Product/Applications/.app

    (At least on my machine - I assume for others on MacOS X it's the same.)

    When you right click and "Show Package Contents" on your app bundle, that offending file should be either below or right near the iTunesArtwork files.

    Thanks for the explanation, Jon!

    For the record, I followed the steps, and submitted for PreRelease - and it was accepted. Removing the file seems to be the correct solution.

    Joe...

  • LuckyDayLuckyDay USMember ✭✭✭

    @ahmedkhan glad I could help, but it's definitely not an issue with the latest build of XS. As I said before I had the problem and I'm not on the latest XS. My guess would be that apple changed a requirement that makes having that file a failure (maybe it was an ignored warning or something before, who knows).

  • LuckyDayLuckyDay USMember ✭✭✭
    edited May 2015

    FYI, noticed that some of the angle brackets for placeholders in the paths I gave got stripped out, edited my comment to make them visible :)

    Also, @JoeJupin is correct it's Product/Applications. I got my names mixed up from the error message and not double checking things before posting.

  • JoeJupinJoeJupin USMember

    I don't know if this is related - but it appears something else has happened in the submission process.

    (Maybe a new thread???)

    All the PreRelease builds for my app are gone. Usually, the old ones hang around with the latest and greatest the only active one.

    So far, the one updated with Jon's fix has not appeared. Usually, (for me) those builds appear right away - I normally can't add all the other info in for like 10 minutes - until it migrates from the uploaded stated, to the list of active pre-releases.

    Again, everything is gone.

    Anyone else experiencing this?

  • ahmedkhanahmedkhan USUniversity ✭✭

    @JonRuskin : yeah - I'm actually not seeing the build in iTunesConnect under prerelease builds -although Xcode says the build was uploaded successfully with the workaround -maybe there is something up with iTunesConnect

    wish that Testflight hadn't been acquired by Apple.. this whole new submission system is buggy - very, very frustrating for delivering release to my team

    @byrc : === Xamarin Studio ===

    Version 5.9 (build 431)
    Installation UUID: 589566f0-cbfa-4c95-9935-a084724b35dd
    Runtime:
    Mono 4.0.0 ((detached/d136b79)
    GTK+ 2.24.23 (Raleigh theme)

    Package version: 400000143
    

    === Apple Developer Tools ===

    Xcode 6.1 (6604)
    Build 6A1052d

    === Xamarin.Android ===

    Version: 5.1.0.115 (Enterprise Edition)
    Android SDK: /Users/ahmedkhan/Library/Developer/Xamarin/android-sdk-mac_x86
    Supported Android versions:
    2.3 (API level 10)
    4.0.3 (API level 15)
    4.2 (API level 17)
    4.3 (API level 18)
    4.4 (API level 19)
    Java SDK: /usr
    java version "1.6.0_65"
    Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
    Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

    === Xamarin Android Player ===

    Version: Unknown version
    Location: /Applications/Xamarin Android Player.app

    === Xamarin.Mac ===

    Not Installed

    === Xamarin.iOS ===

    Version: 8.10.0.267 (Enterprise Edition)
    Hash: 6481535
    Branch: master
    Build date: 2015-04-27 04:38:13-0400

    === Build Information ===

    Release ID: 509000431
    Git revision: 7560726734fc7267de2fa9abed2509968deefaa8
    Build date: 2015-04-17 19:25:48-04
    Xamarin addins: 2e772c734ab3148054eae7bf8949f340fdeb5e5e

    === Operating System ===

    Mac OS X 10.9.4
    Darwin ahmeds-mbp.corp.halliburton.com 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun 3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64

  • HipolytoObesoHipolytoObeso MXMember, University

    @JonRuskin , i`m having the problem on the lasted Xamarin Studio version.

    Any workaround on this version?

    Thanks

  • deckertron9000deckertron9000 USUniversity ✭✭✭

    @JoeJupin
    I'm also seeing this. All of my previously uploaded prerelease builds have disappeared. The newly uploaded build is not showing up either. It appears TestFlight invitations for the new build aren't being sent out either.

  • deckertron9000deckertron9000 USUniversity ✭✭✭

    I take that back. Just received TestFlight invitations for the uploaded build. So it worked! But there's still this new issue where we can't see our builds in iTunesConnect.

  • rschmidtrschmidt USMember ✭✭

    @byrc The publishing workflow you linked to can't be automated. We automate our builds with mdtool and have this issue. Building in Xamarin Studio and shipping the resulting archive is not an option. It has to be automated and reproducible.

  • CodyBCodyB USXamarin Team Xamurai

    @rschmidt

    I hear you. We are working on a solution for that workflow as well.

    Thanks!

  • JoeJupinJoeJupin USMember

    @deckertron9000

    Agreed - my devices received the Testflight notification - and I was able to install the newly updated builds.
    The build has not appeared in iTunes Connects - and the old builds are still missing as well.

    So, I guess it's good to do the hand-modifying method to get a build up to Connect - and to look for the new builds via Testflight notifications on your devices.

  • RenatoTodorovRenatoTodorov BRMember

    I managed to upload the binary according to the workaround on this post but so far the build is not showing up on iTunes connect.

    Did someone manage to push the build and see it on iTunes Connect? I mean, complete the whole flow and change the app status to "Waiting for review"?

    Thanks

  • SteveMaddoxSteveMaddox USMember

    Same issue here...Any ETA for a fix...I'm trying the work arounds, but not getting to Waiting For Review...Please don't make me explain to my board that this will be more than a day?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited May 2015

    I'll jump in quickly to confirm both JonRuskin's workaround and his analysis of the problem. This error when submitting is indeed the result of a new rule that Apple put in place to prevent users from hitting problems like Bug 29180. JonRuskin's manual resigning steps are indeed also the correct approach to solve the problem.

    Unfortunately the original fix to remove iTunesdMetadata.plist automatically for Bug 29180 (only shipped to Alpha so far) has now been found to be insufficient/incomplete/incorrect, so the fix is being re-worked as we speak. Hopefully the developers will have another update on allowing this process to work correctly directly from Xamarin Studio within the next day or so.

  • HipolytoObesoHipolytoObeso MXMember, University

    Hi guys
    Thanks @JonRuskin

    I finally upload the app, also not see the build on itunes, i hope i see on a minutes.

    From Xamarin Support:

    Hi Hipolyto,

    It seems that we need to include a few more fixes as I was able to reproduce this and the entitlements are empty. We are currently working on resolving this with a few quick changes to our workflow and MSBuild tasks. We should have a fix completed soon. I apologize for the inconvenience. For the time being, you will have to do a workaround similar to:

    http://forums.xamarin.com/discussion/comment/122047/#Comment_122047

    If this does not work on the current release, you may want to revert back to the last stable version as per our release thread found here:

    http://forums.xamarin.com/discussion/37278/stable-release-xamarin-ios-8-10-0-new-features-and-bug-fixes/p1

    Thanks!

  • deckertron9000deckertron9000 USUniversity ✭✭✭

    @RenatoTodorov
    If you uploaded it, view the app in itunesconnect. Go to the Versions tab. Scroll down to the "Build" section. Click the "+" and you should be able to select your uploaded build. Then you can save and submit for review.

This discussion has been closed.