Forum Visual Studio


The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Cannot build iOS solution in Xam Studio 5.9 STABLE

NealCulinerNealCuliner USBeta ✭✭✭

Just updated to stables and now I cannot get a good build of my iOS solution. The same source works fine on Xam Studio 5.8.3, it's something with the new stables today. The error is:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Error executing tool '/Applications/': Argument cannot be null.
Parameter name: unformatted (APDL.iOS)

Any suggestions?




  • NealCulinerNealCuliner USBeta ✭✭✭

    Another solution builds, older version builds, looks like something with a Storyboard I'm guessing.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    You might be able to get more information from the build log if you increase logging verbosity to "diagnostic":

  • NealCulinerNealCuliner USBeta ✭✭✭

    Thanks @jstedfast I did try that prior to my post, no difference. Any change in build or build tools from pre 5.9? Seems like it doesn't like a XIB or Storyboard. 5.8.3 compiles it fine.

  • @NealCuliner set the deployment target to 8.0 or higher.

    *Not a good solution if you're trying to support iPhone 4 or those who don't upgrade their iPhone 4s

  • AlexJacobAlexJacob USMember

    Just had the same problem. Worked around it by removing the "Use Size Classes" check from the storyboard. (not sure why this would cause the problem first place, but managed to get the simulator working again)

  • akrohnkeakrohnke JPMember

    Having the same issue just now after upgrade to 5.9. Changing target to 8.0 works, but is not a solution in my case.
    Upgrading Xcode 6.3.1 makes the build succeed but leaves me with the following:

    NSInvalidArgumentException Reason: Could not find a storyboard named 'MainStoryboard_iPhone' in bundle NSBundle

    Only real option seems to be downgrading both Xamarin and Xcode.

    Possibly related issues:

  • Hi,

    Have same problem after update, any suggestions?

    With storyboards everything is ok and executing tool is passed ok
    It fails on xib files
    Here is my build log where it fails:
    Tool /Applications/ execution started with arguments: --errors --warnings --notices --output-format xml1 --minimum-deployment-target 7.1 --target-device ipad --auto-activate-custom-fonts --sdk /Applications/ --compilation-directory /Users/dmytrochumachenko/Projects/AMS/iAMS/obj/iPhoneSimulator/Debug/ibtool /Users/dmytrochumachenko/Projects/AMS/iAMS/Views/AuditItemTableViewCell.xib
    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Error executing tool '/Applications/': Argument cannot be null.
    Parameter name: unformatted
    Task "IBTool" execution -- FAILED

    Thanks in advance

  • For me changing target to 8.0 doesn't work

  • AlexanderGulyaev.1063AlexanderGulyaev.1063 USMember
    edited April 2015

    Fixed constraints conflicts to avoid this issue.

  • MartinKuckertMartinKuckert USUniversity

    Had the same problem. Fixed it by opening my storyboard in Xcode and repair the mentioned problems. Ambiguous constraints and such things.

  • GlayzuGlayzu IEMember ✭✭

    I have just experienced the same issue, updating targets to 8.0 didn't work - and I had Use Size Classes turned off..

    Just reverting to 5.8.3 for now. From diagnostics it seemed like it wasn't picking up Storyboards anymore.

  • NealCulinerNealCuliner USBeta ✭✭✭

    My app's min version is 8.1, I opened all storyboards and they are all using the default xcode version, none have sizing classes checked. A few XIB files had the xcode version back at 4, I changed them to default, problem remains.

    Is there any way to get more diagnostic information from the IBTOOL's build?

  • NealCulinerNealCuliner USBeta ✭✭✭

    What I am finding strange is I have Xcode 6.3.1 installed. In the Storyboard the "opens in" shows Default (6.2) as if the IB doesn't recognize Xcode 6.3.x?

  • NealCulinerNealCuliner USBeta ✭✭✭

    Narrowed it down to a segue in a storyboard I'm actually not using any more so the fix was to delete the bad storyboard. Odd that this compiled in 5.8.3 but not in 5.9 - back to work...

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Xcode 6.3 changed the ibtool command needed to compile xibs and storyboards to use --compilation-directory instead of --compile and also now requires --target-device for each device listed in the Info.plist (iphone, ipad).

    This is used, I think, mostly for Size Classes in storyboards. If you downgrade back to Xcode 6.2 or earlier, the xbuild logic uses the old ibtool command.

    (FWIW, this logic all lives inside Xamarin.iOS and not Xamarin Studio)

  • DominicRobertsDominicRoberts USMember ✭✭

    I've been battling this for the last day, I have 3 Xamarin iOS projects which it is affecting, it looks like a storyboard issue, but even the smallest/simplist project doesn't build consistently without the error.

    It appears to be an issue with Xamarin.iOS 8.10, downgrading to 8.9.1 has resolved my issues, I'll keep an eye out for the next update but I've tried everything suggested here and more with little luck.

    From what I can tell, it doesn't matter if I'm using Xcode 6.2 or 6.3, I was using the latter before this issue arose and tried downgrading that too, but have since tried both with Xamarin.iOS 8.9.1 and its working fine.

  • PatrickLachatPatrickLachat CHMember, University
    edited May 2015

    So I had the same error after upgrading Xamarin Studio from 5.8.3 to 5.9:

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Error executing tool '/Applications/': Argument cannot be null. Parameter name: unformatted

    What worked for me to ged rid of above error was to update all my *.storyboard files (_by opening them in XCode Interface Builder, not in XS_) and set their property "Builds for" to "iOS 8.0 and Later". I also made sure that the checkbox "Use Size Classes" was unchecked.

    See on SO:

  • NealCulinerNealCuliner USBeta ✭✭✭

    Mine were already set as that (Default 6.2) with Xcode 6.3 - it is an issue supposedly with a change in Xcode 6.3 and the IBTOOL. Our case was something with a segue and as we didn't need that storyboard we removed it but that doesn't solve the underlying problem but we're back in action at least.

    Isn't the constantly changing technology great??? I don't want to ever update anything ever again! :) And my iOS devices would never slow down with the Apple "old device killer secret code" too :)

  • KevelopKevelop NLMember ✭✭

    What a mess. I cannot compile my projects anymore. Everything was fine before i upgraded Xamarin. Xcode is not upgraded and is stil 6.3. How can i downgrade Xamarin and Xamarin.iOS to make it work again?

    ps. the workarounds don't work. The storyboard files from my XS project won't even open in Xcode, it crashes right away!

  • KevelopKevelop NLMember ✭✭

    I tried downgrading everything, nothing works.

    I had to recreate the entire storyboard from scratch before it finally builds again :(

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    The storyboard files from my XS project won't even open in Xcode, it crashes right away!

    This is why your build was failing, most likely... something was terribly wrong with your storyboard making it so that ibtool was failing.

  • KevinAshleyKevinAshley USMember ✭✭
    edited May 2015

    **Serious issues with this release **

    • VS (PC) and Xamarin Studio (Mac) don't see physical iOS devices anymore
    • Xamarin Forms projects unable to build at all for iOS (Deploy item grayed out and disabled for iOS)

    UPDATE: Removing <CodesignEntitlements>Entitlements.plist</CodesignEntitlements> from iOS project immediately did it for me I can now see devices in Visual Studio dropdown

  • Hi guys, any news?

    I'm not sure if I can upgrade the Xamarin.iOS again to 8.10 as with 8.10 cannot build the projects.
    I have no time right now to check, sorry for asking.

    The Xamarin Studio and XCode is up to date. Xamarin.iOS is still downgraded (8.9.1)

  • MarianBrosteanMarianBrostean ROUniversity ✭✭
    edited May 2015


    I had the same issue with the ibtool.
    I am heavily using Size Classes and disabling it is not an option for multiple devs working on the same app.

    I tried running the build as it was with target: iPhone 4S, iOS 8.2 and it gave me this error at first:
    /Applications/': Argument cannot be null.
    Parameter name: unformatted (...)

    The I tried to run the same project using target iPhone 5... (I think any iOS version will do).
    The project started in the simulator.
    Then I reverted back to iPhone 4S, iOS 8.2 and it worked fine. It did not complain anymore.

    So, deactivating Size Classes does not seem to be necessary. Any thoughts?

    Here is my configuration:
    + Xamarin Studio Version 5.9 (build 431)
    + Xamarin.iOS Version: (Indie Edition)
    + Xcode 6.2 (6C131e)

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai
    edited May 2015

    @MarianBrostean the bug is already fixed and will be going out as part of Xamarin.iOS 8.10.1. The problem was with a logging call which passed null as the format string when ibtool spewed errors to the console.

  • RajeevSinghRajeevSingh INMember

    @jstedfast Could you please let me know when new update(Xamarin.iOS 8.10.1) is available for downloading ..... i am not able to complie my source code due to this issue.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    If you enable diagnostic logging, it will print the ibtool command it is using to compile each of the xibs/storyboards.

    Simply copy & paste the the command for the failing xib/storyboard into your Terminal window and see what errors ibtool is printing. Fix those, and then it will compile in XS just fine.

  • R.SuurlandR.Suurland NLMember

    Hello @jstedfast ,

    It would be nice to hear when the update will be released. On behave of the date we will decide if we going to infest time in this issue or wait for the update.

    Kind regarts

  • GavinGrantGavinGrant GBUniversity ✭✭✭

    I too am having this problem and NONE of the suggestions have worked. It is very important Xamarin keep us informed of when a fix for this will be in the stable channel. At the moment this downtime is costing me money in terms of lost productivity.

  • GavinGrantGavinGrant GBUniversity ✭✭✭

    @jstedfast. Can we please have an indication when the fix will be available for stable channel. This has caused my project to lose 1.5 days. The company I work for is a small startup who cannot afford to lose that much time. Xamarin needs to realise that companies are putting an awful lot of faith in them to not issue bad / poor updates.

  • sawingsawing FRMember

    I have the similar problem, and you iOS pkg doesn't work...

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    "doesn't work" how? I need more information than just "didn't work".

    What error are you getting? When? Where?

  • sawingsawing FRMember

    ok sorry about that.
    When I build my iOS project this is my log crash;
    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Error executing tool '/Applications/': Argument cannot be null. Parameter name: unformatted

  • sawingsawing FRMember

    ok, my problem come from my Storyboard. I can't open it in Xamarin studio but still in Xcode. How can I fixe my storyboard for Xamarin?

  • sawingsawing FRMember

    I update monotouch with your, now my project build without error but at the start I have this error: Object reference not set to an instance of an object. I have a break point in my appDelegate but crash before.

  • sawingsawing FRMember

    /Users/[email protected]/Documents/D-Realise_App/Radio_Scoop/RadioScoop.iOS/MainStoryboard_iPhone.storyboard: Warning: /Applications/ 2015-05-09 14:16:41.751 Interface Builder Cocoa Touch Tool[50483:828561] ***createStorageTaskManagerForPath:withIdentifier failed: Error Domain=NSCocoaErrorDomain Code=4099 "The operation couldn’t be completed. (Cocoa error 4099.)" (The connection to service named was invalidated.) UserInfo=0x7f8be2f28090 {NSDebugDescription=The connection to service named

  • sawingsawing FRMember

    /Users/[email protected]/Documents/D-Realise_App/Radio_Scoop/RadioScoop.iOS/MainStoryboard_iPhone.storyboard: Warning: /Applications/ nwi_state: registration failed (1000000) (RadioScoop.iOS)

  • AdamDimentAdamDiment GBMember ✭✭

    A different approach - Did you perhaps copy and paste an image view or other element from one view controller to another in designer view, which contained constraints? I did - and experienced this error. I deleted the copy of image view, then added a fresh one from the toolbox, and added fresh constraints. Then the build worked.

Sign In or Register to comment.