Forum Visual Studio

Stable release: XamarinVS 3.11.445, new features and bug fixes

BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
edited May 2015 in Visual Studio

Released versions:



Reason for release: New features and bug fixes.

Release notes:

Date published:

  • May 21, 2015: 3.11.458 hotfix published directly to the Stable updater channel
  • May 13, 2015: 3.11.446 published directly to the Stable updater channel to hotfix Bug 29570
  • April 29, 2015: 3.11.445 published to Stable updater channel
  • April 22, 2015: 3.11.445 published to Beta and Alpha updater channels
  • April 15, 2015: 3.11.431 published to Beta and Alpha updater channels
  • April 14, 2015: 3.11.428 published to Alpha updater channel
  • April 2, 2015: 3.11.271 published to Alpha updater channel

NOTE: This feature release includes a significant number of changes. There are several breaking changes as well as several known issues (see below) compared to the previous Stable versions. Many of the known issues have been addressed in the follow-up "service release" currently available on the Beta and Alpha channels.

Previous versions, downgrading

You can downgrade back to the previous Stable version by manually reinstalling each Stable package (see also the article about downgrading). The links to the previous Stable versions are:



Guidelines for this thread

  1. This first post will be updated regularly.

  2. Hopefully this thread will help answer "what might break if I update to this release?"

  3. If you find a new problem that is specific to this version, please file a bug report (if this link redirects to the top-level page the first time you click it, try clicking it once more).

  4. Please discuss older bugs that are unchanged in this release compared to the previous Stable version in Bugzilla instead.

  5. Of course for questions and discussions about topics other than bugs, feel free start new forum threads.

Android breaking changes

Important: Xamarin.Android 5.1 contains several breaking changes that will require corresponding code changes in your projects. These changes also alter the way unhandled exceptions behave in the debugger.

See the "Android breaking changes" section on the corresponding release announcement in the Android forums for some examples of how to work with these changes:

For more technical details see:

Fixes for common old known issues from previous releases

(Where not already documented in the release notes)

  • Non-public Bug 29100 - [iOS] "Could not find a storyboard named 'MainStoryboard' in bundle NSBundle" when using Xcode 6.3 with size classes and deploying to iOS 7

Remaining known issues from previous XamarinVS release threads

  • Bug 28027 - [XamarinVS] [iOS] Debugger sometimes fails to connect properly after the app launches

    We'd be interesting in the number of users seeing this issue. If you think you might be seeing this issue, feel free to check the questions on the bug report. If your answers match, please either add yourself on CC on the bug report or leave a note on this forum thread. Thanks!

New known issues compared to the previous stable versions, with more common or severe issues near the top

  • Bug 29133 - [XamarinVS] [iOS] [Android] Visual Studio hangs when debugging some iOS and Android applications that use multiple threads. Now fixed in the Alpha and Beta channels.

  • Bug 29628 - [XamarinVS] [iOS] Breakpoints in Portable Class Libraries do not work because the .mdb symbol files are not copied properly. Related warning in the "Output -> Debug" window: "Symbol file ... doesn't match image". Now fixed in the Beta and Alpha channels. (Old workaround: force the .mdb files to be copied properly:

  • Bug 29570 - [Android] Greater-than and less-than comparisons of decimal numbers do not work correctly. Now fixed in the latest Stable, Alpha, and Beta channels.

  • Bug 29680 - [XamarinVS] [iOS] [Android] Ignorable "ERROR: Not implemented (Exception from HRESULT: 0x80004001 (E_NOTIMPL))" message from the new Test Cloud integration. Now fixed in the Beta and Alpha channels. (Old partial workaround**: uninstall the Test Cloud integration:

  • Bug 29220 - [XamarinVS] [iOS] [Android] "ERROR: Value cannot be null. Parameter name: project" when opening and building projects. So far, this problem appears to be related to specifics of the system configuration. If anyone happens to notice one particular difference between a working project and a failing project (or a computer without the problem and a computer with the problem), be sure to let us know right away. Now fixed in the Beta and Alpha channels. (Old partial workaround: uninstall the Test Cloud integration:

  • Bug 28961 - [iOS] "error MT3001: Could not AOT the assembly", "error: invalid symbol redefinition". (This can also appear as "System.ArgumentOutOfRangeException: startIndex > this.length" in the "Output -> Xamarin Log" in VS.) One common cause of this error is the use of [MethodImplAttribute(MethodImplOptions.Synchronized)]. Workaround for projects that use [MethodImplAttribute(MethodImplOptions.Synchronized)]: remove [MethodImplAttribute(MethodImplOptions.Synchronized)] and manually synchronize the methods using lock statements instead (

  • Bug 29605 - [iOS] "Error executing tool '/Applications/': Argument cannot be null. Parameter name: unformatted". Now fixed in the Alpha and Beta channels.

  • Bug 29839 - [XamarinVS] [iOS] "Native linking error: warning: directory not found" when linking a static library into an iOS app using ${ProjectDir} in the "Additional mtouch arguments". Now fixed in the Beta and Alpha channels. (Old workaround: Replace ${ProjectDir} with ${TargetDir}/../../../. See for an example.)

  • Bug 28918 - [iOS] "Unexpected error ... Failed to resolve System.Security.Permissions.SecurityPermissionFlag". Now fixed in the Alpha and Beta channels. (Old workaround:

  • Bug 29568 - [Android] "No resource found that matches the given name", for AppCompat resources in the Android Support library. Now fixed in the Alpha and Beta channels.

  • Non-public Bug 29172 - [Android] "'...Resource' does not contain a definition for `Id'" (for example, when using the Scandit component). Now fixed in the Alpha and Beta channels.

  • Non-public Bug 28995 - [Android] On certain devices, certain apps crash frequently due to "System.ExecutionEngineException: SIGILL".

  • Bug 30171 - [Mono] [iOS] [Android] BinaryReader.ReadChar() returns incorrect result. Now fixed in the Beta and Alpha channels.

  • Bug 29730 - [Android] Event handlers subscribed to (some?) events that are bound to Java callbacks no longer work (for example ViewTreeObserver.GlobalLayout). Now fixed in the Alpha and Beta channels. (Old workaround: use the corresponding "Add/Remove...Listener" methods instead:

  • Bug 30318 - [Android] Windows only: Breakpoints in PCL projects do not work after cleaning solution, redeploying, and restarting debugging. Partial workaround: delete all the bin folders in the solution after cleaning.

  • Bug 30371 - [Visual Studio] [Android] Project Properties display incorrect default values for "BundleAssemblies" and "EmbedAssembliesIntoApk" if they are not explicitly specified. This means that these properties can "automatically" change to incorrect values when you update other properties under "Project Properties -> Android Options". The incorrect values can cause secondary symptoms like Bug 30334 where breakpoints are not hit in the Debug configuration.

  • Non-public Bug 30057 - [Android] Windows only: the debugger will not be able resolve breakpoints unless "Shared Runtime" is ON and the Linker is OFF (under "Project Properties -> Android Options" in Visual Studio or "Project Options -> Android Build" in Xamarin Studio).

  • Non-public Bug 30059 - [XamarinVS] [iOS] "Mono.Debugger.Soft.CommandException: Debuggee returned error code 200." when hitting breakpoints in PCLs in certain projects when running XamarinVS on certain computers.

  • Bug 29326 - [Android] String resources defined in NuGet packages overwrite sting resources defined in app project, causing the displayed app name to be incorrect for example. Workaround: avoid using the same string key that is used in the NuGet packages.

  • Bug 29211 - [iOS] Enabling linker with Profile 7 PCL that uses System.IO.Compression causes "Could not load file or assembly 'System.IO.Compression'" at run time. Workaround: add -linkskip=System.IO.Compression under "project options -> iOS Build -> Additional mtouch arguments".

  • Bug 30548 - [Android] Under certain conditions new threads take several seconds to start. This problem seems to be triggered by Xamarin.Insights 1.10. Partial workarounds: downgrade Xamarin.Insights to version 1.9, or remove it entirely.

  • Bug 30420 - [iOS] DequeueReusableCell(cellIdentifier) returns null if this.TableView is called in the TableView constructor. Workaround: perform all initialization operations for the TableView in the ViewDidLoad() or ViewWillAppear() methods rather than the constructor.

  • Bug 29745 - [iOS] Error due to duplicate symbols during native compilation for device: "duplicate symbol _monoeg_g_array_new" (and many similar messages). Workarounds: disable profiling under "Project Properties -> iOS Build", or if your app uses the -all_load linker flag (via either gcc_flags or LinkerFlags) try removing it.

  • Non-public Bug 29170 - [Android] Profiling via log:sample causes the app to crash at startup. Now fixed in the Alpha and Beta channels.

  • Non-public Bug 29538 - [Android] Profiling via the graphical Xamarin Profiler ("Run -> Start Profiling") causes the app to crash at startup.

  • Bug 29849 - [XamarinVS] [iOS] The "Visual C# -> Mobile Apps -> Blank App (Xamarin.Forms Portable)" template includes an iOS project that has a non-empty value for the <CodesignEntitlements> property for the iPhoneSimulator configurations, meaning that the iPhoneSimulator configuration will attempt to perform code signing. This is inconsistent with the other templates and also with the corresponding Xamarin Studio template on Mac. Workaround: open the .csproj file in a text editor and delete the <CodesignEntitlements> property from all of the iPhoneSimulator configurations.

  • Bug 29822 - [XamarinVS] [iOS] Setting "Build" number different from "Version" number causes IPA not to be copied to Windows, resulting in 0 KB .ipa file. Now fixed in the Alpha and Beta channels.

  • Bug 29703 - [XamarinVS] [iOS] "Show IPA File In Build Server" fails if "Build" number is different from "Version" number. Now fixed in the Stable, Beta, and Alpha channels.

  • Non-public Bug 28557 - [Android] In certain cases breakpoints will only pause program execution the first time they are hit. Now fixed in the Alpha and Beta channels.

  • Bug 29039 - [Mono] [iOS] [Android] CultureInfo.GetCultureInfo("ar-SA").DateTimeFormat throws a NullReferenceException for the ar-SA culture. Now fixed in the Alpha and Beta channels.

  • Bug 29731 - [Android] Android.Bluetooth.BluetoothAdapter.Enable is incorrectly marked as [Obsolete("deprecated")] for API level 20 and higher.

  • Bug 28210 - [XamarinVS] [Android] New projects created from templates show ignorable build warning: "@(Content) build action is not supported ... AndroidManifest.xml". Workaround: change the build action of "AndroidManifest.xml" to "none". Now fixed in the Alpha and Beta channels.

New known issues in new features

  • [Android] The AOT compiler does not prevent multithreaded apps from being targeted to the armeabi architecture. These apps will crash at runtime because the armeabi architecture does not support multiple threads.

  • [Android] Some AOT compilation scenarios fail by design but do not yet offer informative error messages.

  • Non-public Bug 28600 - [Android] Intermediate AOT LLVM build files are written to the base project directory rather than the obj/ folder.

  • Non-public Bug 28929 - [XamarinVS] [Android] The F# project template does not create a valid project in VS 2010.

Latest edits

EDIT May 19: Update the "fixed in" annotations to mention the new Beta channel release.
EDIT May 21: Increase severity ranking of Android Bug 28995 based on additional customer reports.
EDIT May 21: Add Mono Bug 30171, Android Bug 30057, iOS bug 29605, iOS Bug 30059.
EDIT May 21: Update versions for XamarinVS and iOS iTunesMetadata.plist hotfix (also fixes 29703). Delete some of the old EDIT history for simplicity. Add Android Bug 30318, Xamarin Studio Bug 30072.
EDIT May 27: Add XVS.Android Bug 30371. Beta channel now fixes 30171. Reset status of 29680 29220 29628 29839 because the "3.11.456" release notes were incorrect.
EDIT May 28: Add Android Bug 30548, iOS Bug 30420. Replace Android breaking changes text with link to Android release thread due to forum post character limit.



  • PhilipGruebelePhilipGruebele USMember ✭✭

    App runs great with this new release, but debugging PCL is broken:

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    PhilipGruebele, many thanks for the report! I was able to reproduce the bug, and I have increased its priority. I have also added the bug to the list of known issues in the first post in this thread.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    Can you please explain more in detail, what:

    App runs great with this new release

    exactly means?

    Are the some benefits, and - if yes - which?

    I think, that the "breaking-changes" to Android only (or mostly) are relevant for Android-projects (not for .forms-projects).
    => Correct?

  • PhilipGruebelePhilipGruebele USMember ✭✭

    My app is .forms with custom renderers. I did not have to deal with the breaking changes since 3.11 did not break my app. I also compiled XLabs with it without a problem.

    I can't say whether my app directly benefited from 3.11 because I am making a lot of changes to it.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Correct. The place where breaking changes in Android would affect user code for Xamarin.Forms apps would be custom renderers.

  • PhilipGruebelePhilipGruebele USMember ✭✭

    Hi Brendan. This bug is still a problem in 3.11.431:

    It can be quite a problem at times and it's not in your list of outstanding bugs so I though you should know. Otherwise it has been working perfectly all day.

  • PhilipGruebelePhilipGruebele USMember ✭✭

    This one is also not in your list but also is still a major problem:

    This one is a big deal because it really cripples debugging under visual studio - especially apps that make heavy use of await/async.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Many thanks for letting us know that the new versions have been working alright, Philip.

    For bug 26841 and bug 12606, both would fall under the category of "older bugs that are unchanged in this beta release" (guideline #4 from the first post in this thread). Including older bugs in the lists in these release announcements would make make the lists less focused on answering the specific question of "what might break if I update to this release?" Ideally, any information about "what will work better if I update?" will be mentioned in the release notes. That said, the release notes for XamarinVS 3.11 don't currently include much detailed information about what is better in 3.11. The developer and documentation teams will be striving toward more in-depth XamarinVS release notes in the future.

    Hopefully it sounds sensible to keep these release announcements focused mostly on new known issues (with occasional exceptions when there is an on-going issue that was first identified as a regression in a recent previous release thread). Otherwise it might be difficult to decide which unresolved bugs should not be included in the list.

  • MartinRothschinkMartinRothschink DEMember ✭✭

    Since I'm running Xamarin VS 3.11.445.0 and Android I see again Visual Studio locks after starting the debugger with a physical device. The app loads and then VS is stuck. You have to kill VS, that's really annoying!

    Is this a known issue?

  • valdeterovaldetero USInsider, University ✭✭

    I get this error in Visual Studio with version 3.11.445.0 in the Beta Channel:

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @MartinRothschink, I don't know of an existing bug that exactly matches those symptoms. I did find a similar problem that seemed only to affect the Xamarin Android Player in my tests. The fix for that issue will be included in the follow-up "service release" that will be published to the alpha/beta channels within a few weeks once the current beta version has been promoted to stable.

    To double-check if the fix for bug 29133 will also solve the problem you're seeing, I'll send you a rough draft development build that includes the fix for that bug.

  • MartinRothschinkMartinRothschink DEMember ✭✭

    @BrendanZagaeski I rolled back to stable in the meantime.
    Will try your fix tomorrow. Thanks.

  • MartinRothschinkMartinRothschink DEMember ✭✭

    @BrendanZagaeski I started with installing the latest beta build and yes, the problem appeared again. After starting my Android Forms App on a physical device, the last line in Debug log is D/OPenGLRenderer: Enabling debug mode 0. After that, Visual Studio does no longer react on mouse clicks or keyboard input.

    Then I installed your development build 451 and it's working again (tried it 3 times). So it seems that fixed the bug!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Excellent. Thanks for testing that!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2015

    The versions listed in the first post in the thread have now been released to the Stable channel. The first post has been updated accordingly.

    EDIT Apr 30: adjust wording to reduce ambiguity about which versions were released.

  • MartinRothschinkMartinRothschink DEMember ✭✭

    I'm a bit irritated. Have you released the original 3.11.445.0 with my issue? Or is this a fixed stable version?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2015

    The current Stable build is unchanged compared to the Beta version from April 23. Apologies for not re-emphasizing that this was the intended plan when I sent the draft development build. So far there have only been 2 reports of bug 29133 (yours and mine), so the developers' best estimate of the potential impact is currently too low to warrant adding another patch to 3.11.445. The concern would be that adding another patch might break parts of the build that the QA team had already tested. The ideal way to solve this would be to add the patch to 3.11.445, and then have the QA team do another full pass on the build, but that is usually not possible for a single patch late in the release cycle, unless the issue is both widespread and severe.

    As mentioned briefly in the updated first post in the thread, the scheduled release timeline for the follow-up "service release" is fairly soon (Alpha/Beta builds as soon possible, and Stable in at most a few weeks). This release will include the patch for 29133 as well as many of the other known issues, and will be run through the standard full set of tests by QA.

    All that said, if any other users who are reading this thread are hitting bug 29133 (VS freezes after launching the app for debugging on Android), please reply in a comment on this thread to let us know. If it turns out the issue is more widespread than originally estimated, then the timeline to release a fix for just bug 29133 can potentially be moved up.

  • MarianGieselerMarianGieseler USMember ✭✭

    *Nice Update

    how to fix that? re-install xamarin studio and visual studio?

  • MarianGieselerMarianGieseler USMember ✭✭


    Could not load file or assembly 'file:///C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\Extensions\Xamarin\Xamarin\\Xamarin.VisualStudio.IOS.dll' or one of its dependencies...

  • MarianGieselerMarianGieseler USMember ✭✭

    re-install xamarin fix this issue.

  • TeoTeo DKMember ✭✭
    edited April 2015

    I updated this morning for Visual studio, and I get this error:

    Value cannot be null.
    Parameter name: project

    I can still compile and run my projects, but the error is always there.

    When debugging for an Android project, VS hangs, and I need to kill the process and restart to get it running again.

    Finally, I get a new warning:

    @(Content) build action is not supported AndroidPrj\Content\note_icon.png

    All of this appeared when I updated Xamarin this morning.

  • MartinRothschinkMartinRothschink DEMember ✭✭

    @BrendanZagaeski thanks for clarification.

  • AnubhavRanjanAnubhavRanjan INXamarin Team Xamurai

    Hi @Teo. I am seeing the same error on one of my machine when using Visual Studio 2013.
    Version Information: Information.txt

    Can you share your version information so that we can try and figure out what can be the issue?
    1a: Mac: Open Xamarin Studio, Click Xamarin Studio > About Xamarin Studio > Show Details
    1b: Windows Visual Studio: Click Help > About Visual Studio
    1c: Windows Xamarin : Open Xamarin Studio > Help > About > Show Details

    Also, can you share a screenshot of the Xamarin Options:
    Tools -> Options -> Xamarin -> Android Settings

  • TeoTeo DKMember ✭✭
    edited April 2015

    Hey @AnubhavRanjan , I attached the two files that you asked for.

  • Adam.HillAdam.Hill USMember

    I have a iOS binding project that I recreated in VS. I get the following error when trying to build. No DLL is [produced. I have attached the solution.

    Warning 1   The "BTouch" task failed unexpectedly.
    System.ArgumentNullException: Value cannot be null.
    Parameter name: key
       at System.Collections.Generic.Dictionary`2.FindEntry(TKey key)
       at MonoTouch.Tools.Build.BuilderPool.Find(String sessionId, ILoggingHelper taskLog)
       at Xamarin.VisualStudio.Build.TaskRunner.Initialize(Task task) in c:\w\5061f921\XamarinVS\msbuild\Xamarin.VisualStudio.Build\TaskRunner.cs:line 46
       at Xamarin.VisualStudio.Build.TaskRunner.Run(Task task) in c:\w\5061f921\XamarinVS\msbuild\Xamarin.VisualStudio.Build\TaskRunner.cs:line 72
       at Xamarin.iOS.Tasks.BTouch.Execute() in c:\w\5061f921\XamarinVS\msbuild\Xamarin.iOS.Tasks\Tasks\BTouchTask.cs:line 33
       at Microsoft.Build.BackEnd.TaskExecutionHost.Microsoft.Build.BackEnd.ITaskExecutionHost.Execute()
       at Microsoft.Build.BackEnd.TaskBuilder.<ExecuteInstantiatedTask>d__20.MoveNext() ZebraLinkOsSDKUnified
  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    AdamHill.7944, thanks for the report. A couple little things to check:

    1. Do you have an iOS app project in the same solution? (Even just adding an empty template app will be helpful. Including an iOS app project makes it easier to ensure VS is connected to the build host, which is required when building binding projects.)

    2. Does the project build successfully in Xamarin Studio on Mac? Since bindings projects in VS are a new feature, it will be important to confirm that any project that fails in Visual Studio builds correctly in Xamarin Studio.

    In my quick tests, the following steps resulted in a successful build:

    1. Create a new "iOS -> Bindings Library" in Visual Studio.

    2. Add an "iOS -> iPhone -> Single View App" to the solution, and ensure VS is paired with the Mac build host.

    3. Copy the contents of ApiDefinition.cs and StructsAndEnums.cs from the original project into the corresponding files in the new project (omitting the namespace because there are typos in the namespace in the original project).

    4. Copy the libZSDK_API.a and libZSDK_API.linkwith.cs into the new project (no changes needed).

    5. Build the new project.

  • PhilLalondePhilLalonde USUniversity

    In my case, breakpoints set in a PCL for an iOS project are no longer hit. I'm running version 3.11.445. Breakpoints on the native side work.

    I'm able to set breakpoints in the PCL when using XS on Mac.

  • WesselOosthuizenWesselOosthuizen USMember ✭✭

    @BrendanZagaeski I am also experiencing bug 29133.


  • Xamarin-IanXamarin-Ian USMember, Xamarin Team Xamurai

    Hi Folks, we are continuing to investigate reported issues (bug 29133) and breakpoints not being hit with PCL projects. I am following up with each post on the thread to investigate further. If I haven't reached out to you yet and you believe you can provide a consistent repro of the issue you are facing with build 3.11.445 then please reach out to my via email and I'll follow up with you accordingly.


    Ian Ceicys :: Visual Studio QA Software Engineer @ Xamarin - title :: [email protected] - email :: (440)724-6721 -

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @PhilLalonde, many thanks for the report. I was able to reproduce the issue with breakpoints in PCL projects on iOS, and so I filed a new high-priority bug for it here: I have also added the bug to the list of "New known issues" in the first post in the thread.

  • PekkaNiskanenPekkaNiskanen USMember


    I have similar issues (bug 29133) with Visual Studio 2013 and Android with the latest version of Xamarin.

    When trying to debug in a virtual machine VS hangs and needs to be killed. The splash screen does appear in the VM but nothing happens after that and VS is unresponsive.

    Here is the strange bit:
    This happens if I do not have any break points in the App constructor or the constructor of the first page (PCL project).

    However when I have break points in the App constructor and the constructor of the first page (PCL project), they are hit and when I continue debugging (F5) the first page is loaded. The only threading related operation is setting the SynchronizationContext in the constructor of the first page.

    I have reproduced this behavior several times so it is consistent.

    Hopefully this helps.

  • Paul_RoyPaul_Roy FRMember ✭✭

    I am also experimenting bug 29133.

  • TrevorBalcomTrevorBalcom USMember ✭✭

    I am also experiencing bug 29133. I'm hoping for a fix soon.

  • TrevorBalcomTrevorBalcom USMember ✭✭

    I reached out to Xamarin support, and they provided me with a build 3.11.451 which appears to fix the issue.

  • Dan_JonkeDan_Jonke USMember

    I was also having this problem. I spoke with Xamarin, we tested 3.11.451 in my development environment and it did the trick. Sounds like it'll be available for public consumption in the Alpha update channel on Monday.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Thanks all for the additional reports of bug 29133 (Visual Studio hanging under certain circumstances after launching Android apps for debugging).

    If anyone would like to use the draft development build that includes the fix for this issue (3.11.451), feel free to send a forum message to @BrendanZagaeski or @Xamarin-Ian, and we will send you the link. I'll hold off on posting the link publicly (a) to minimize the possibility for confusion about which build is which, and (b) because the service release (that includes this fix) is due out very soon (next week).

    Similarly, I think the plan will be not to hotfix this issue directly in the Stable channel, but instead to wait for it to reach the Stable channel as part of the service release. That will again help keep the number of recently released versions to a minimum, and hopefully help to avoid some confusion (which is especially important right now because there are several other outstanding known issues).

  • KevinAshleyKevinAshley USMember ✭✭
    edited May 2015

    @BrendanZagaeski, guys this release broke iOS integration with VS 2013. After installing this update iOS physical devices disappeared from the Visual Studio 2013 menu. Also, the deploy target in Visual Studio for the iOS project is grayed out. VS is connected to Mac host bust cannot see iOS devices. After installing Xamarin Studio 5.9 to Mac, it also stopped seeing attached iPhones. Cannot build for iOS...

  • KevinAshleyKevinAshley USMember ✭✭

    @BrendanZagaeski after removing Entitlements tag from iOS project I can now see devices, but the project still fails to Debug on iPhone with Error 1 Not implemented (Exception from HRESULT: 0x80004001 (E_NOTIMPL)) 0 0

  • PekkaNiskanenPekkaNiskanen USMember

    The 3.11.451 build fixed the issue here as well.

    Just for reference we are using VS 2013 and building for Android / WP. Currently we do not have iOS apps.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @KevinAshley, thanks for the report. I found some simple steps to reproduce the "Not implemented ... HRESULT" error, so I filed a bug for it ( and updated the first post in the thread accordingly. The bug report includes a partial workaround.

    That said, since this error seems to be ignorable, it is likely that the debug failure is caused by something else. If you haven't yet checked them, the "Build host" logs from the Mac, the "Xamarin for Visual Studio" IDE logs, or the "Debug logs for Xamarin.Android and Xamarin.iOS apps" might contain additional clues about the cause of the failure. See: (if this link redirects to the top-level page the first time you click it, try clicking it once more).

This discussion has been closed.