Emulator never starts

saeidsaeid NLMember
edited October 2012 in Xamarin.Android

Hi all,

I have installed the latest version of mfa. I tried to launch emulator by debugging the default project in Visual Studio. after I press f5 the dialog to select device comes up and its empty, then I click on start emulator image and select one of the default images (any of them) and press ok, then I get back to select device dialog again and still running images list is empty. I even waited for 10 minutes but nothing at all happens even no error messsage or something.

I installed mfa in the default folders (I mean I didn't change anything). Could this be a path problem or something? How can I start an image manually to check if its work at all?

The sdk is installed here:

AVDs are here:

I googled a bit most people say because of space in path, but there is no space in my case. I also tried using MonoDevelope but same promblem exists there as well.

Later I tried to launch any emulator manually by going to android-sdk\tools folder and doing "emulator @emulatorname" but I get an error about "emulator-arm.exe has stopped working"

Later I tried the same command with "-avd" argument and now error is: PANIC: Could not open: C:\Users\Saeid.android/avd/@MyVirtualAndroid.ini


  • DsousaDsousa BRMember


    I has a similar problem. When I opened the emulator, it just flashed the screen and never started.
    The solution was uninstall android sdk using revo unninstaller to clear logs, restart the machine and install again.

  • saeidsaeid NLMember

    I tried deleting all logs and folders, in my case the emulator doesnt flash at all...it is just it is not doing anything at all... but thanks for reply :P

  • ChrisHardyChrisHardy GBForum Administrator, Xamarin Team Xamurai

    Hi Saeid,

    The "PANIC: Could not open: C:\Users\Saeid.android/avd/@MyVirtualAndroid.ini" error is very confusing, especially that it's using both forward-slash and back-slash in the path (which is not possible) so it does look like something is incorrectly configured in the Android SDK. I would recommend uninstalling the Android SDK completely (as Diego suggested) and manually installing it again (http://developer.android.com/sdk/installing/index.html) to see if you can at least load up an Android Emulator (without doing anything through the Mono for Android side).


  • saeidsaeid NLMember

    Hi Chris,

    I think it is not a problem of path anymore, now I try "emulator -avd MonoForAndroid_API_14" or other other APIs, but it seems it wants to start but I get "emulator-arm.exe has stopped working". Then I tried to make new images with less memory, different vga types but still no success. I am running win7 64

  • ChrisHardyChrisHardy GBForum Administrator, Xamarin Team Xamurai

    There seems to be various reasons listed on the following Stack Overflow question on why you might be getting that error - http://stackoverflow.com/questions/6855877/error-message-emulator-arm-exe-has-stopped-working although it seems like you might have tried that. Have you tried running the less processor intensive API Level 8 emulator (to see if you can get anything running)?

  • saeidsaeid NLMember

    It seems that this is a hardware related problem. I tested MFA on my desktio (Core i7, GTX 470 and win 7 64) and it works with no problem. But on my laptop (Core i3 280, integrated graphics and win 7 64) It does not work at all, all it does crashes on emulator-arm.exe

    I have tried to make different AVD's with gpu enable/disable and different amount of device memory but no success at all.

  • Charles.INCharles.IN INMember

    I am having the same issue in my laptop. I am using Windows 7, 64 bit.
    Then i uninstalled everything and reinstalled then it worked for few times. Then the problem returned once again. As you said it works fine in Desktop system but we face problems in laptop installation.

  • CheesebaronCheesebaron DKInsider, University mod

    I have a laptop with a Core 2 Duo, where it works just fine, however I am running Windows 8 Pro, 64-bit. Have you checked that you are running the newest version of the SDK along with the newest versions of the images? This can be done by looking in the SDK Manager.

  • saeidsaeid NLMember

    HI Tomasz, I think its more about the graphic chip rather than CPU. what is the graphic on your laptop? I generally think AVD has problem with intel's grapic chipsets

  • CheesebaronCheesebaron DKInsider, University mod

    It is a nVidia Quattro, don't know the specific model, but it is not fast at all.

  • saeidsaeid NLMember

    I am pretty sure this problem is linked with Intel graphic chips such as 3000 series

  • TheMoonTheMoon USMember

    Hello, I encountered the same issue and setting the environment variable ANDROID_SDK_HOME fixes the issue.

    source : http://stackoverflow.com/questions/8971227/monodevelop-cant-find-avd-or-it-dont-get-noticed-it-is-running

Sign In or Register to comment.