Xamarin iOS Error - Can't load any images to app without getting an error

When I try to upload new images to my app. Like icons, launch screens or just images in general. I get this error:

Error 3 Cannot copy /Users/cb/Library/Caches/Xamarin/mtbs/builds/AppiOS/42cde78f6f5021a1da612bc3e58f77b8/obj/iPhone/Debug/Icon.png to /Users/cb/Library/Caches/Xamarin/mtbs/builds/AppiOS/42cde78f6f5021a1da612bc3e58f77b8/bin/iPhone/Debug/AppiOS.app/Icon.png, as the source file doesn't exist. AppiOS

if I exclude the image it will build and run fine. Is this a bug or something I'm doing wrong.



  • RafaelMouraRafaelMoura BRInsider, University, Developer Group Leader ✭✭✭


    Maybe u need click with righ button on Image, acess Properties and set Copy Local with True or Build Action set as Content

    Try and send feedback :)

  • Craig.4350Craig.4350 USMember

    Tried still same error. Also I have some images that were I placed on a while ago with no problems and I've copied there properties and still doesnt work but If I make a copy of the old images it builds.

  • Craig.4350Craig.4350 USMember

    Seems like its a bug with Xamarin. Have logged it with them.

Sign In or Register to comment.