Forum Visual Studio

Storyboards in iOS library projects

QonstruktQonstrukt NLMember ✭✭
edited March 2015 in Visual Studio

For a project we're using a Storyboard in an iOS Library project, together with multiple iOS projects that share the same Storyboard. We're editing our Storyboards in Xcode, and this has always worked admirably in Studio 5.8 and earlier. After editing the Storyboard in Xcode we could always just return to Studio and Run our project, and the changes would immediately be visible.
But since 5.8.1 last week, it seems more of a trial and error process. Sometimes it helps to clean the iOS project, but often we have to clean and rebuild the whole solution manually to see any changes. But sometimes we even have to quit Studio, remove all bin and obj folders and rebuild before the changes are being picked up.

Anybody else in the same situation having the same problems? Is there perhaps a way to skip the new "faster" iOS build spoken of in the Release Notes?

Perhaps on a related note; when cleaning the library project and then trying to run the project, Studio sometimes throws this error at us without any build output:

  • The application has not been built

We have to manually build the library project in order to continue.

Reverting back to 5.8.0 has solved both issues for us.


  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    The faster iOS build is not the problem. All the "faster iOS build" means is that instead of parsing every file in ~/Library/MobileDevices/Provisioning Profiles/, now we have a cache of that information that the DetectSigningIdentity task uses. The only thing that task does is figure out which codesigning key & provisioning profile combo to use.

    It was also the only change made to the build system, so I have no idea why you are suddenly having this problem.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    FWIW, the build system is also not part of Xamarin Studio at all, it's part of Xamarin.iOS. If you use Xamarin Studio's updater, it will upgrade or downgrade both together.

    What happens if you only upgrade Xamarin Studio by downloading it from your account page on Can you reproduce the problem?

    Actually, I wonder if this is related to the "don't build if nothing has changed" logic that was added to Xamarin Studio. I just realized that made it into a recent release (I thought it was 5.8.2, but maybe it was 5.8.1?)

  • QonstruktQonstrukt NLMember ✭✭

    We downgraded by just installing the 5.8.0 build over the current 5.8.1 build using the installer from the Downloads page.
    If I recall the release notes correctly, it was "don't build if nothing has changed" that was changed in 5.8.1 and might be causing our troubles.

    I'm also having similar problems with Android solutions in 5.8.1. If I have an Android Library project and I clean it, my Android project referencing that library no longer runs. I have to manually build the library project first, or I get missing assembly errors. In 5.8.0 this is not the case, everything gets built automatically.

    It seems to me something is really broken in the build order of solutions in Studio 5.8.1.

  • QonstruktQonstrukt NLMember ✭✭

    This problem doesn't appear to be fixed in 5.8.3. Changing the Storyboard, still requires me to manually clear out all the obj and bin folders of the iOS (library) projects in my solution. A simple clean all doesn't even seem to help (enough).

    The problems I had with the error message in Android projects is resolved though. I'll see if I can file a more thorough bug report for my iOS Library project problem.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    If you were using Xcode to edit your storyboard, that bug was just fixed late last week. Hopefully in time for 5.9.0 final.

  • QonstruktQonstrukt NLMember ✭✭
    edited April 2015

    Great, that is indeed the case. Thanks for the heads-up!
    Have to say that the release notes for 5.9.0 look very promising, keep up the good work!

Sign In or Register to comment.