cannot run Xamarin Android Player due to "activate subscription" error.

mkamoskimkamoski ✭✭USMember ✭✭

Please help.

When I run the Xamarin Android Player, I get the following error...

A Xamarin.Android subscription is required to use this beta.

Please open Xamarin Studio, log into your Xamarin account to activate your Xamarin.Android subscription, then relaunch this app.

...but the fact is that I do have Xamarin open and I do have a subscription.

So how can I get this to work?

What am I doing wrong?

Please advise.

Thanks.

-- Mark.

Posts

  • mkamoskimkamoski ✭✭ USMember ✭✭

    I just figured this out. I went to > Tools, > Account, > Log in.

    The problem was that I thought my Xamarin Studio was logged in. I was wrong. As soon as I logged in, it started working.

  • MamadexMamadex USMember

    I have same problem.

    Even I am logged in, but doesn't work.

  • MamadexMamadex USMember

    Now error doesn't appear but emulator never starts.

    clicking on start button doesn't action.

  • lokesh_mlokesh_m USMember

    plz help my problem is not solve even login to my a/c...

  • PaulBechtelPaulBechtel USMember

    Any update on this. I'm having the same problem. Just want to try the product out and get a feel for it.

  • Theunis.9045Theunis.9045 USMember

    I am having the same problem. I've signed in on Xamarin Studio, and when I start an installed device in Xamarin Android Player, I get the message ".. subscription is required to use this beta."

    Should I be able to use Android Player with a trial version? This will be for production, so if we are happy with the product we will pay for a subscription.

    Please help.

  • Theunis.9045Theunis.9045 USMember

    Solved the problem thanks.

    It seems when you log in on Xamarin Studio the trial subscriptions is not yet "activated".

    I ended up creating a android project in Visual Studio, and apon creating a build the Xamarin plug-in asked me to activate. Once I did this the android player worked.

  • JohnPrattJohnPratt USMember

    Any other solution? How do I active an account? Or link my computer to an account? I am trying to use the Android Emulator (Beta).
    I don't see "Account" in the tools menu, and I don't know how to import visual studio code.

  • esoongusesoongus USMember

    To have the Android emulator listed next to the Debug field, I noticed I had to delete (NB: Not Remove) the AndroidManifest.xml file under the Properties folder. That is good but when I tried to run without debug, I get the same error about having to log in to my Xamarin account which I've already done so. I thought I would close the app and reopen it. But when I did that, the AndroidManifest.xml file somehow was recreated. Anybody out there ran into this problem?

  • esoongusesoongus USMember

    Please disregard my earlier post. Upon further research, I've determined that you do need the AndroidManifest.xml file. However, you need to select the version of the Android emulator you want to use. What you set in this field will populate the emulator field to the right of the Debug field below the tools bar. It looks like user of the free version of the Xamarin Designer can only use certain emulators for free. You can see a list of those in Tools-> Open Google Emulator Manager. Within this pop-up screen you can create new Android Virtual Devices only those with CPU/ABI system images already installed for the selected target. The ones listed by the Xamarin Android Player app are only available to paying customers. For that, you would seem like you will need to be logged in to your Xamarin account.

    You can now Run -> Run With (the emulator specified in the Minimum Android version inside of the AndroidManifest.xml file).

    Perhaps someone can reconfirm my findings.

  • RamonReyesRamonReyes USMember

    Hmmm... unfortunately, it looks like that's the case. I was logged in to Xamarin Studio, and I chose to

    • close the application
    • restart the computer
    • go back into the program

    When I tried to run the app again, I got the same "you need a Xamarin Android subscription" error. When I went to the Google Emulator Manager, I saw some other AVDs that I made, but not the Xamarin Android player.

    My suspicion was confirmed when I went to the actual Xamarin Android Player app, and tried to start up my KitKat emulator that I downloaded (so I could start it first and THEN run the app I made), but it gave me the same error.

    Oh well... back to AVDs (at least for now)...

  • NorbertMelzerNorbertMelzer USMember
    edited February 2015

    Any update on this?

    edit

    OK, found why it is not working for me! The subscription to "Xamarin.Android" needs to be a paid one, STARTER is not beeing enough!

    http://stackoverflow.com/questions/26319348/xamarin-android-player

  • Daniel.9388Daniel.9388 USMember

    Any update ?

    I started using Xamarin Studio for test purposes. I want to see if this product can be useful in our entreprise.

    But something confuses me, because nothing explicitly says that we need a paid account to use the Xamarin Android Player. That's a shame, since that's an important feature to be tested before paying for a subscription.

    Anyone has an idea ? Or at least a proof that we need this kind of account ?

  • Daniel.9388Daniel.9388 USMember

    Okay, I got my answer.

    If you look at the prices for each licence, you see that the Starter one has no subscription. So, no Xamarin Android Player for Starters...

  • ManInTheLoftManInTheLoft ✭✭ GBBeta, University ✭✭
    edited April 2015

    I am a subscriber but I still received the message

    'xamarin android player beta has expired please update'

    In the end I downloaded and reinstalled the latest version and it worked. My images are still there too.

    MITL

Sign In or Register to comment.