Forum Visual Studio

Why are my breakpoints not resolved aka "Should I break or should I go"?

Can someone tell why my breakpoints only randomly resolved. There is no logic why or why not.

Looks like only a output clean and rebuild would hit them. Are they compiled in code? ;-)

I'm working on a MacMini or MacBook Pro with the latest Xamarin release. But since 3 or 4 releases I have this strange behaviour.

Any idea?

Thanks in Advance..
Greetings, Jörg

Best Answer


  • mhutchmhutch USMember, Xamarin Team Xamurai

    Could you file a bug with a test case and full version information so we can investigate?

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    I mentioned this same issue a few days ago:
    I found that the new 8.2 simulator on iOS appeared to be working differently than previous versions. Restarting Xamarin after selecting a new version of iOS was enough to make it work again. Doing a clean before building was not.
    I'm sorry I don't have a simple repro case.

  • ParagraphDevsParagraphDevs ATMember ✭✭

    @mhutch The problem is the "not stoppin at breakpoint" is not stable reproducable. It happens at random time. @DavidDancy A restart did not solved the problem in my case.

  • mhutchmhutch USMember, Xamarin Team Xamurai

    There may be debugger log messages in the application output explaining why the breakpoint did not resolve.

    At any rate, I'd suggest filing a bug to track this issue, and include as much information as you can that might help us to reproduce and track down the problem.

  • mhutchmhutch USMember, Xamarin Team Xamurai
    edited March 2015

    I understand, but it's difficult to investigate bugs when we're not seeing them ourselves, so any information you provide to help track it down would be appreciated.

    I'd recommend filing a bug at so the issue can be be properly triaged and tracked.

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    @mhutch I noticed today's Xamarin Studio 5.8.2 update with a bug fix: "Fixed: Breakpoints cause iOS Simulator to freeze". I'll keep an eye on it, but is it possible that someone found the problem already and fixed it?

Sign In or Register to comment.