iOS app crashes after upgrading to Xamarin.Forms 1.3.1

MariusVisser.8791MariusVisser.8791 USMember
edited January 2015 in Xamarin.Forms

So I upgraded my iOS project to XF 1.3.1(without Unified Migration) and I was able to get it up and running, after some time struggling with the packages and references and doing the standard changes to the App class, AppDelegate and MainActivity.

After doing the Unified Migration my app would compile and deploy to the phone but there wouldn't be an app icon, font and images. The first times the app would start up to my home screen (without image and no text, because the font is missing) but now the app crashes on start up. I migrated my icons to the Asset Catalog but this didn't work, so I reverted that change.

Here are the packages for the iOS project
<package id="ExifLib.PCL" version="1.0.0" targetFramework="xamarinios10" /> <package id="Microsoft.Bcl" version="1.1.9" targetFramework="xamarinios10" /> <package id="Microsoft.Bcl.Build" version="1.0.21" targetFramework="xamarinios10" /> <package id="Xamarin.Forms" version="1.3.1.6296" targetFramework="xamarinios10" /> <package id="Xamarin.Forms.Labs" version="1.2.1-pre2" targetFramework="xamarinios10" /> <package id="Xamarin.Forms.Maps" version="1.3.1.6296" targetFramework="xamarinios10" />

I am not to sure where to go on from here to fix the issue, any input would be appreciated :) .

Posts

  • NMackayNMackay GBInsider, University mod
    edited January 2015

    After upgrading my iOS app crashes when setting the main page. I have a ticket open with Xamarin regarding this issue (they have reproduced this).

    If you catch the error the page does render but it causes an exception later on if you call PopToRootAsync.

    `

    protected override void OnStart()
    {
    base.OnStart();

            try
            {
                MainPage = new NavigationPage(new MainPage());
            }
            catch (Exception ex)
            {
                // Only happens in iOS
                Debug.WriteLine(ex);
            }
        }
    

    `

  • I'm having exactly the same problem in my project - wrapping in a try/catch block works, but then when you pop later it crashes. Has anyone found a solution to this?

Sign In or Register to comment.