Forum Xamarin.Forms

Forms.Maps can't be moved by

It's been fine before but now it will only move programatically. I can drag it and zoom it but it zips back to start location if after a second (even before releasing it). What could be doing this?? I disabled all my code that effects the map but still no good.


  • Update: I made a new Xamarin.Forms application and the map is reacting in the same way. Is there a setting that's kicked in when a packet was updated or something? I'm only building for android btw.

  • RobertEngzellRobertEngzell SEMember
    edited November 2014

    The map.PropertyChanging is being called twice. The first coordinates for the visibleregion is the starting location, and the second is the new position. After that it returns to the first coordinates.

  • I'm guessing it's a Google Play Services related problem. Unfortunately I haven't been able to downgrade it. Can anyone help me or at least confirm the error?
    I'm using a Samsung S4 - API19.

  • I tried downgrading GooglePlayService in the phone, Xamarin.Forms and Xamarin.Forms.Maps in my solution but it still doesn't work. I have earlier tried to reinstall my environment but to no avail.
    Now I'm stuck with having to use Forms and android pages. Can I even do that? What would be the best approach?

  • I'm having the exact same issues. On both Android 4.4 and Android 5.
    Even when I run this example:

    Does anyone has a solution for this?

  • Check out this thread. Many having the same problem.

  • FengTaoFengTao USMember, University

    Same issue. Any solution on it? I am using xamarin.forms 1.2.3 and 1.2.3. Do I need to update the references?

  • @FengTao Upgrade to latest forms and maps (stable versions) and the issue will be resolved.

Sign In or Register to comment.