Disable PushKit Warning

Does anyone know how to disable this warning in Xamarin Studio:

Warning MT0049: PushKit.framework is supported only if deployment target is 8.0 or later. PushKit features might not work correctly. (MT0049)

I do not use PushKit in my App. But i do want to have deployment target set to 7.0. This warning is a annoying because it shows up all the time. That way I'm starting to just ignore the warnings. However, this is not XCode, so it would be awesome if warnings only show up when they are relevant for me.

Best Answer

Answers

  • AntonVenemaAntonVenema CAUniversity ✭✭

    I get the same thing. Nothing changed except updating to the latest Xamarin toolset. Is this connected with use of HTTP web requests in the app?

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    Are you linking your apps (in the project's iOS Build options, what is "Linker Behavior" set to)?

  • AntonVenemaAntonVenema CAUniversity ✭✭

    It was set to "Don't link" for some configurations. Switched them all to "Link SDK assemblies only" and the warning went away!

  • DennisWeluDennisWelu USUniversity, Developer Group Leader ✭✭

    If you want the configuration to "Enable incremental builds" I believe the Linker behavior should be set to Don't Link otherwise the settings work against each other. So I'm thinking for developer builds the best compromise is to ignore that error knowing it won't be there when building for release.

  • Did anyone figure out how to get rid of this warning? I am also seeing it on my debug builds. I've been ignoring it for now, but it would be nice to get rid of it.

  • MohammadBraeiMohammadBraei DEUniversity

    I have it, too.

  • BBXBBX GBMember

    This warning has been there for ages (months) and is still in 8.4.0.47 in Debug with "Don't Link". When will it be fixed??

  • anveanve DEMember ✭✭✭
    edited January 2015

    I also get this warning after updating Xamarin.iOS to 8.6.0.51. Before I didn't had this warning. What should I do?

    Currently I tried that from Anton Venema and it seems to work. But why do I need that?

  • rschmidtrschmidt USMember ✭✭

    We have this after upgrading to 8.4.0.47 with linker behavior set to link all assemblies.

Sign In or Register to comment.