Error: No valid iPhone code signing keys found in keychain. when I update xamarin 5.7 HELP ME!!!!

I was working in a solution with iOS and everything was alright, then xamarin asked for update. After update the error appeared and I dont know what means :(
Error: No valid iPhone code signing keys found in keychain.
Sorry, english is not my main language.
Some light please!
D:

Best Answer

Answers

  • alecsiualecsiu USMember

    I'm seeing this too, using Xamarin 5.7 and trying the avTouch sample downloaded from the Xamarin website. I don't want to deploy to a device, I just want to try in the iOS simulator (I also don't have a development certificate since I'm just trying out the tools). The iOS simulator works in XCode.

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭

    Me too getting this error on the projects that were running fine. Besides I am also getting 'Could not connect to the debugger." error on projects with Xamarin.Forms 1.3.1.6296 (pre-release) for iOS project.

  • holaaseholaase USMember
    edited January 2015

    I downgrade my Xamarin Studio to 5.5.4 version and work fine again... But I still want a real solution :(
    https://store.xamarin.com/account/my/subscription/downloads

  • Yip, getting same error also. Cannot build anything. Tried a brand new sample application from the templates (Tabbed Application) and even that doesn't build (debug/simulator).

    No issues before updating today.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    This is a known issue: https://bugzilla.xamarin.com/show_bug.cgi?id=25841

    The patch will likely be going out with 5.7.1

  • Ok. So until 5.7.1 is released what is the workaround until then?

  • holaaseholaase USMember
    edited January 2015

    SamanthaRushforth downgrade Xamarin Studio 5.5.4 version

    Jeffrey Stedfast, thx for info

  • MigueldeIcazaMigueldeIcaza USXamarin Team Xamurai

    We are working on a hot fix.

    In the meantime, a workaround is to either use Unified projects, or to get a codesigning identity installed (you do that by creating an iPhone project on Xcode, and deploying to your iPhone).

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    One more option to work around the issue while waiting for the hot fix: switch the Classic API iOS project to use the MSBuild build engine. You can enable that using the checkbox under "Project Options -> Build -> General -> Build Engine -> Use MSBuild build engine (unsupported for this project type)". Although it is marked as "unsupported," this engine should build the majority of Classic API projects successfully.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    I forgot to mention that you may need to go into your Project Options -> iOS Bundle Signing settings and remove "Entitlements.plist" from the Custom Entitlements textbox (IOW just clear that textbox so there's nothing in it).

    Code signing should now only happen for iPhone Simulator builds if and only if custom Entitlements were specified.

  • AdrianMurphyAdrianMurphy USXamarin Team Xamurai

    An updated build to address this issue is available here: http://storage.bos.internalx.com/monodevelop-lion-monodevelop-5.7-branch/b4/b46fa13b30e60eb2318c06f2e320c76a5822b40c/XamarinStudio-5.7.1.4.dmg

    The above mentioned note by Jeff regarding removing Entitlements.plist still remains true for existing projects, but new projects will not need any modifications with this build.

  • StephenWinjeStephenWinje USMember

    Xamarin Team, thanks for getting a hot fix out so quickly to resolve this issue.

    I downloaded and installed XamarinStudio-5.7.1.4.dmg
    I created a New -> Solution -> Blank App (Xamarin.Forms Portable)
    Build Test.iOS and Run it on the iOS Simulator
    And it worked fine.

    Using XamarinStudio-5.7.1.4, I was also able to clear the Custom Entitlements on an existing project
    Build Existing.iOS and Run it on the iOS Simulator
    And it worked fine.

    Great work to all involved!

  • JaimeOokamiJaimeOokami USMember

    thx, great work :smiley:

  • KamalPantKamalPant USMember

    I am still getting No valid IOS code signing error when try to run ios app on Simulator from visual studio.
    I downloaded and installed XamarinStudio-5.7.1.4.dmg on my near by Mac machine and when try to build my ios app on visual studio 2013 I got this error. So is there any updated build for windows also that I need to install on my windows machine? Please help me to get this eror resolved.

  • KamalPantKamalPant USMember

    I even tried downgrading to xamarin 5.5.4 but this only downgrade Xamarin Studio not Xamarin.IOS.
    I want to switch back to Xamarin.IOS 8.4 (trial version) for both windows and Mac. Please suggest from where I can get that version?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @KamalPant‌, note that the fix for Xamarin Studio will not affect the code signing behavior within Visual Studio (also, see the item "When building a new Xamarin.iOS Unified Project" under "Known Issues" on the Xamarin for Visual Studio 3.9 release notes). For users on trial licenses, the easiest way to obtain older versions is to send an email to contact@xamarin.com requesting the versions you'd like (see also http://kb.xamarin.com/customer/portal/articles/1699777-downgrading).

  • tx, that worked.

  • JorgeFioranelliJorgeFioranelli USMember, University

    This fix works for C# projects, but for some reason it doesn't seem to work for F# projects.

  • JorgeFioranelliJorgeFioranelli USMember, University

    Sorry, ignore my previous comment, after re-installing it again, it worked with F# too.

  • CooperMarcusCooperMarcus USMember

    Thanks @AdrianMurphy‌ your build fixed my problem - much appreciated!

  • BruceHamilton.6835BruceHamilton.6835 USUniversity ✭✭

    The link Adrian Murphy posted above on January 14th did not work for me, and it prompted me to say Yes to go to an earlier version. It didn't work. I then upgraded back to the latest, 5.7 (build 661) and the issue remains. Thanks

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    The version of Xamarin Studio that includes the fix (version 5.7.1) has now been released to the Alpha and Beta updater channels.

    After you have updated, be sure to remove "Entitlements.plist" from the "Custom Entitlements" if it is set (http://forums.xamarin.com/discussion/comment/97021/#Comment_97021):

    You may need to go into your Project Options -> iOS Bundle Signing settings and remove "Entitlements.plist" from the Custom Entitlements textbox (IOW just clear that textbox so there's nothing in it).

    Code signing should now only happen for iPhone Simulator builds if and only if custom Entitlements were specified.

    image

  • EricSmithEricSmith CAMember

    I had exactly the same problem. Xamarin says, "Because of changes that Apple recently made to the way provisioning works, Xamarin Studio currently is unable to refresh changes or additions to iOS Provisioning profiles directly." So you have to go to Xcode to update your signing information. Instructions at http://developer.xamarin.com/guides/ios/getting_started/installation/device_provisioning/.

  • EricSmithEricSmith CAMember

    I had exactly the same problem. Xamarin says, "Because of changes that Apple recently made to the way provisioning works, Xamarin Studio currently is unable to refresh changes or additions to iOS Provisioning profiles directly." So you have to go to Xcode to update your signing information. Instructions at http://developer.xamarin.com/guides/ios/getting_started/installation/device_provisioning/.

  • DavidAllenDavidAllen USDeveloper Group Leader ✭✭

    @Brendan Zagaeski, this has broken again in the Xamarin Studio 5.9 update, even if Custom Entitlements is cleared. Please fix. It doesn't inspire confidence in the Xamarin when such fundamental bugs keep getting reintroduced time and time again.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @DavidAllen, I have not been able to reproduce the problem using the current beta channel versions. Can you reproduce the issue with a new from template test project? If the issue is triggered by some particular detail of your project, then the most direct way forward would be to submit your full project (or a trimmed down version of it that demonstrates the problem) in a bug report, along with other standard info like detailed version information (e.g., Xcode version, OS X version).

    See also: https://kb.xamarin.com/customer/portal/articles/1910343-when-and-how-should-i-file-a-bug-report-. (If this link redirects to the top-level kb.xamarin.com/ page the first time you click it, trying clicking it once more.)

    As mentioned on that article, if you have a Business or Enterprise license, feel free to get in touch with the support team for additional assistance filling in the appropriate details for the bug report.

    Thanks!

  • DavidAllenDavidAllen USDeveloper Group Leader ✭✭

    @Brendan Zagaeski, Thanks for the quick response.

    I tried a new forms solution created from XS, and that was OK. So it looks like the issue is associated with existing solutions. I always create solutions in VS (as I think it creates better structured solutions than XS and its adds in the WinPhone project), then move them to XS (and copy the solution file to a WinPhone only solution file so I can open the same solution in VS from virtualized Windows 8.1).

    I have the Indie license. $2K is far too much to pay! As you suggest, I'll submit a bug report In the meantime, how can I downgrade XS to a previous, working version?

    Thanks

    David

  • SturlaSturla USUniversity ✭✭
    edited May 2015

    I have been having this problem also. And I´m running everything from Visual Studio 2013. Just creating a blank PCL project and trying to run it does not work.

    But after seeing @DavidAllen answer I found out that if I unload the iOS project in the solution and remove the reference to the Entitlements.plist file (for the simulator) everything runs fine.

      <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Debug|iPhoneSimulator' ">
        <DebugSymbols>true</DebugSymbols>
        <DebugType>full</DebugType>
        <Optimize>false</Optimize>
        <OutputPath>bin\iPhoneSimulator\Debug</OutputPath>
        <DefineConstants>DEBUG</DefineConstants>
        <ErrorReport>prompt</ErrorReport>
        <WarningLevel>4</WarningLevel>
        <ConsolePause>false</ConsolePause>
        <MtouchArch>i386, x86_64</MtouchArch>
        <MtouchLink>None</MtouchLink>
        <MtouchDebug>true</MtouchDebug>
        <CodesignEntitlements></CodesignEntitlements>
      </PropertyGroup>
    

    So nothing in CodesignEntitlements.

    What gives?

  • BrandonFryeBrandonFrye USMember
    edited May 2015

    Thanks @sturlaorvaldsson and @davidallen.
    I have been fighting this for a day now. Within the visual studio UI you cannot set the entitlements for simulator builds (and they show as blank). After looking at the project (in a text editor) they were actually set. In addition the 'CodesignKey' tag had been set to a certificate (again, blank in the ui). After clearing out 'CodesignKey' and 'CodesignEntitlements' I am FINALLY able to build again.

  • Thanks @sturlaorvaldsson , your information has helped me solved my problem!

  • HenrikStrmbergHenrikStrmberg USMember

    I get the error Error: No valid iPhone code signing keys found in keychain when trying to build with the app distribution.
    If I create a dummy app in xCode and use the same bundleId and same provisionProfile it builds fine. But when using XS it fails to build.
    I´m using Xamarin StudioVersion 5.9.3 (build 1)

  • MaurilioFilhoMaurilioFilho BRMember

    For environments with the use of XS had to make a change in the properties of iOS project
    Project.iOS> Options> Build> iOS Signing Bundle the option which is described "Custom Entitlements" remove the content that is in the box and leave it blank, Now save the project and recompile all over again that everything worked !!
    Now for VS environments I not found one yet not solution because the VS do not have the ability to change the properties of iOS projects!

Sign In or Register to comment.