Web Preview: Xamarin.iOS 10.99 Preview 5 for iOS 11, tvOS 11, and watchOS 4 SDK bindings

BrendanZagaeskiBrendanZagaeski Brendan ZagaeskiUSForum Administrator, Xamarin Team Xamurai
edited August 18 in Xamarin.iOS

Please see https://releases.xamarin.com/preview-xcode-9-beta-5-ios-11-macos-10-13-support-preview-5/ for the details about this release, including links to the downloads and the release notes.

These are early preview builds to allow Xamarin developers to start trying the new features available from Apple in Xcode 9. Any bug reports about the new Xamarin bindings are much appreciated!

  • File a bug report against Xamarin.iOS 10.99 if you see any suspicious behavior in this preview Xamarin.iOS version that you wish to report.

  • Comment in this forum thread if for example:

    • You notice an error in the Release Blog post.
    • You have trouble downloading one of the installer packages.

EDIT July 27: Update title and Release Blog link for preview 2.
EDIT August 03: Update title and Release Blog link for preview 3.
EDIT August 11: Update title and Release Blog link for preview 4.
EDIT August 18: Update title and Release Blog link for preview 5.

Posts

  • AndriusKirilovasAndriusKirilovas Andrius Kirilovas LTMember ✭✭

    I updated VS for Mac, Mono and Xamarin.iOS but I don't see any of the iOS 11 simulators in the dropdown box. I also have Xcode Version 9.0 beta 3 (9M174d) installed along with iOS 11 simulators. I can successfully build and deploy swift iOS 11 project to iOS 11 simulator from Xcode.

    When I build in VS for Mac for generic simulator I get following error message:

    Error MT0091: This version of Xamarin.iOS requires the iOS 11.0 SDK (shipped with Xcode 9). Either upgrade Xcode to get the required header files or set the managed linker behaviour to Link Framework SDKs Only (to try to avoid the new APIs). (MT0091) (CoreML)

    I would like to be able to test some of the new iOS 11 API's in simulator. Maybe haven't configured something?

  • AndriusKirilovasAndriusKirilovas Andrius Kirilovas LTMember ✭✭
    edited July 22

    It seems that I solved my issue with an error message. Beta SDK needs to be manually changed in VS for Mac preferences, SDK locations section:

    But now I'm getting a different error:

    Error MT0116: Invalid architecture: i386. 32-bit architectures are not supported when deployment target is 11 or later. (MT0116)

    When I switch Supported architectures to x86_64 my project builds fine for generic simulator.

    But I still don't see any of the iOS 11 simulators.

  • AndriusKirilovasAndriusKirilovas Andrius Kirilovas LTMember ✭✭

    A few restarts later I can see all of the iOS 11 simulators in a dropdown box. So everything appears to be fine. I would file a bug report but it would be hard to reproduce the issue that I had.

  • LuqmanHussainLuqmanHussain Luqman Hussain USMember ✭✭

    Thanks for that @AndriusKirilovas I had the same issue where the simulators would not show until I changed preferences.

    This info should have been included in xamarin releases blog.

  • RogisterAlainRogisterAlain Rogister Alain BEBeta ✭✭

    I have the same problem with Visual Studio BETA 7.1.

    I do not see the simulators.

    I gave an ALPHA version of Visual Studio 7.1 (less recent than BETA) and I have the simulators.

    On my iMac or I also Visual Studio BETA 7.1, I see them correctly.

    I tried to put the BETA version back on my MacBook but still no simulators.

    What should I do ?

  • Minafawzy.0454Minafawzy.0454 Mina fawzy USMember ✭✭

    I have the same issue when I change the SDK to Xcode 9 beta its dosnt show simulators , you will need to restart your mac to show up

Sign In or Register to comment.