Firebase in ios

NinineaNininea USUniversity ✭✭✭

I'm trying to use firebase in xamarin ios, but bunch of problems are raised.

At first I can't download component

Error downloading component 1 is not a support code page

then I downloaded it from nuget and get 6 errors ,

Error: linker command failed with exit code 1 (use -v to see invocation)

Native linking failed, duplicate symbol: '__ZN8farmhash13Fingerprint64EPKcm'. (MT5212)

MTOUCH: Error MT5213: Duplicate symbol in: ....iPhoneSimulator/Release/mtouch-cache/GoogleMaps (Location related to previous error) (MT5213)

Error MT5213: Duplicate symbol in: /...iOS/obj/iPhoneSimulator/Release/mtouch-cache/FirebaseCore(farmhash_71acb1913cf19d99bd791946e66c66e2.o) (Location related to previous error) (MT5213)

error MT5209: Error: 3 duplicate symbols for architecture x86_64 Native linking

Native linking failed. Please review the build log. (MT5202)


  • prashantvcprashantvc USXamarin Team Xamurai

    Could you share verbose build log? I am not able to reproduce this issue locally

  • NinineaNininea USUniversity ✭✭✭

    the solution was to add following command in additional mtouch arguments : --registrar:static

  • DevologyDevology GBMember ✭✭✭

    @Nininea I'm curious to know how you discovered that mtouch argument. For example the iOS guide for integrating Google Firebase Analytics doesn't mention it at all, how on earth did you reach that non-obvious conclusion?

    Compilation has now worked for me too but I'd like to understand what that does and why it helped better, I've taken a brief look here (by searching for the mouch argument you mentioned) but I'm not sure of the impact overall on any other nuget packages I have installed; is it a low risk switch?

    A big thank you for your comment - I don't think I would have solved it without your comment

Sign In or Register to comment.