Are Xamarin.iOS UITests works?

It can't get work UITests even with blank single-view iOS application.
Default Xamarin.UITests version is 2.0.6 and it doesn't work.
I tried to update it to 2.0.9, which is current one, and it doesn't work either.
After that I tried to update Xamarin.TestCloud.Agent and it doesn't work either.
It says that it couldn't install DeviceAgent. I tried clean, rebuild, delete bin/obj, and all the Xamarin Woo-Doo, and nothing helps.
How to get it work? It's very frustrating.

Tagged:

Answers

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @AlexandrMoshkin

    I got the same error as you after creating a template Xamrin.iOS Single View app project with a UITest project. My first attempt to run the default test failed with the same error you got above, but after just updating Xamarin UITest to 2.0.9, my second attempt worked and the test passed. I did not have to update the Xamarin.TestCloud.Agent package. But as a further test, I did update that package and ran the test again, and again it ran fine and passed.

    One thing I did note that the first time I tried to deploy (got error noted above), I did not get asked to allow any connections or enter my admin password to allow debugging, but the second time I ran the test (after updating the UITest package) I got asked for my password and the got asked to allow incoming connections (to allow debugging) and then everything worked. Did you ever get those password and permissions pop-ups on your end?

    I tested this a couple of times and consistently got the same results.

  • AlexandrMoshkinAlexandrMoshkin USMember

    @JGoldberger
    Thank you for you reply, yes, indeed, I didn't get asked for password. What should I do to get this popup?

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    Not sure, I am going to move this thread to the Test CLoud forum.

  • Kent.GreenKent.Green USXamarin Team Xamurai

    I think the popup @JGoldberger refers to may occur based on some specific security or similar settings on certain systems, but might not apply to all systems. When I run UITests on the iOS simulator I get a warning window for the simulator to connect, but no password is required; and even so the tests execute successfully.

    For the error message itself, I know of at least a few different potential causes of the error you're seeing, usually it happens because something isn't configured correctly. Can you tell us the following?

    1. What version of Xcode is installed on your system?
    2. What iOS version & model are you targeting? Is it a physical device or a simulator?
    3. Are you initializing Calabash in your AppDelegate.cs as shown here? https://developer.xamarin.com/guides/testcloud/uitest/adding-uitest/#Initialize_the_Xamarin_Test_Cloud_Agent

    Typically this is wrapped up in a conditional compilation flag, because you need to start and run Calabash in a debug build in order for tests to run; but in a release build you want to ignore Calabash and let the linker remove it so that it's not included in the IPA you submit to the app store, because Calabash in the app will cause it to be rejected.

  • @Kent.Green
    1. Version 8.3.3 (8E3004b)
    2. Simulator, iPad 5th gen
    3. Of horse

    Well, I've made it work, but I'm not sure how. I have deleted all simulators, after that I've added it back, then I've installed DeviceAgent through terminal and it successfully started. But only for 9.7 iPad; 5th gen iPad still doesn't work.

  • Kent.GreenKent.Green USXamarin Team Xamurai
    1. What iOS versions are the iPad that works & the iPad that doesn't work?
    2. Are you able to install the IPA normally on each of them and launch your app / interact with it even without running the UITests?
    3. Did the error message change at all for the 5th gen iPad?
  • festevusfestevus USMember

    I get this error message every time when running tests with any version of Xcode 8+ with both the old Xamarin Studio and Visual Studio.

    As a workaround, you can download and connect Xcode 7.3 and the tests should work fine.

Sign In or Register to comment.