system.threading.thread

Hello
I am Developing a app in cross platform for Android and Windows with visual studio 2015 and xamarin forms.

When I build project i have no problems, however if i run the program in windows and i try to connect with database, i get the next exception:

"System.IO.FileNotFoundException" in System.Data.SqlClient.dll ("Could not load file or assembly 'System.Threading.Thread, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. System could not specific file.") System.IO.FileNotFoundException

I tried to install system.threading.thread with NuGet administrador, and i can show this message:

Error restoring package

The code of program is the next, I can use sqlconnection previously:

try
{
conn.Open();
DisplayAlert("estado", "estado: " + conn.State, "ok");
}
catch (System.IO.FileNotFoundException eo)
{
DisplayAlert("estado", "ERROR1!!!!!!!!!!!!!\n" + eo.Message, "ok");
}
catch (Exception ex)
{
DisplayAlert("estado", "ERROR!!!!!!!!!!!!!\n"+ ex.Message, "ok");
}

Someone could help me please?

Posts

  • thibautbellamythibautbellamy USMember

    Hello,

    I've same issue, do you have a solution ?

    please !

  • DaveMartinDaveMartin ✭✭ NLMember ✭✭

    I'm getting this as well:

    I'm creating a multiplatform app in Xamarin with VS2017, and Im getting this error from my UWP app.

    System.IO.FileNotFoundException: Could not load file or assembly 'System.Threading.Thread, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'. The system cannot find the file specified.
    File name: 'System.Threading.Thread, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'
    at System.Data.ProviderBase.DbConnectionFactory.TryGetConnection(DbConnection owningConnection, TaskCompletionSource1 retry, DbConnectionOptions userOptions, DbConnectionInternal oldConnection, DbConnectionInternal& connection) at System.Data.ProviderBase.DbConnectionInternal.TryOpenConnectionInternal(DbConnection outerConnection, DbConnectionFactory connectionFactory, TaskCompletionSource 1 retry, DbConnectionOptions userOptions) at System.Data.SqlClient.SqlConnection.TryOpen(TaskCompletionSource1 retry)
    at System.Data.SqlClient.SqlConnection.Open()
    at SS12.DataServices.SendScalar(String qString)
    at SS12.ItemsPage.CheckUserLogin(String User, String Pwd)
    at SS12.ItemsPage.d__3.MoveNext()

    Has anyone seen this before? What could be the cause? Any help gratefully received!

    Thanks!

  • Sir_PepSir_Pep Member

    At the moment UWP and Xamarin don't appear to support that library.

    I've had the same issues, and after checking around I found that packages that use the System.Threading.Thread library can't actually run because that dependency fails(Even when Microsoft says the package is perfectly compatible).

    Here are 2 articles on the subject (Remove the "a" right after https so the link works when copy pasting )

    httpsa://neosmart.net/blog/2017/system-threading-thread-universal-windows-platform-and-the-fragmentation-of-net-standard/

    httpsa://github.com/dotnet/corefx/issues/2576

Sign In or Register to comment.