How do I get visual studio 2017 to see android 7 or 8?

When I load my project I see in the output window

    [I:]:                     Found Xamarin.Android 7.3.0.13
    [I:sdk]:                  Runtime path: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\MSBuild\Xamarin\Android
    [I:sdk]:                  Framework path: C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\ReferenceAssemblies\Microsoft\Framework\MonoAndroid\v1.0
    [I:sdk]:                    Key HKCU\SOFTWARE\Xamarin\VisualStudio\15.0_21ab2c5b\Android\AndroidSdkDirectory found:
        Path contains adb in \platform-tools (C:\Program Files (x86)\Android\android-sdk).
    [I:sdk]:                    Key HKCU\SOFTWARE\Xamarin\VisualStudio\15.0_21ab2c5b\Android\AndroidNdkDirectory found:
        Path contains ndk-stack in \. (C:\ProgramData\Microsoft\AndroidNDK64\android-ndk-r13b).
    [I:sdk]:                    Key HKCU\SOFTWARE\Xamarin\VisualStudio\15.0_21ab2c5b\Android\JavaSdkDirectory found:
        Path contains jarsigner.exe in \bin (C:\Program Files\Java\jdk1.8.0_112).
    [I:]:                     Found Android SDK. API levels: 19, 21, 22, 23, 24, 25
    [I:]:                     Tracking android devices started
    [D:]:                     Tracking avd started
    [D:]:                     avd watcher *.ini path: 'C:\Users\dpslocal\.android\avd'
    [D:]:                     avd watcher: got device list from avd with 4 devices
    [W:]:                     Adb connection refused
    [I:]:                     Starting Adb server (adb start-server)
    [I:]:                     Adb start-server operation completed
    [D:]:                     TrackDeviceTask got: 42009f5efe36c337 unauthorized
    [I:]:                     Got new device list from adb with 1 devices

Yet when I come to choose the device on which to debug I do not see the latest version,
only four choices all like android-23_x86_phone (Android 6.0 - API 23)

When I run Android SDK Manager I see that many versions up to 26 (8.0) are installed.

Can someone please advise how to see the latest version?

Best Answer

Answers

  • batmacibatmaci DEMember ✭✭✭✭✭

    @RofiqSetiawan does this work only with x86 image or also with 64bit one as well? I am asking this because although my installation looks like as below. I dont get any CPI/ABI option for 7.1.

    On the other hand, I think that these custom emulators are not Hyper-V based like VS Emulators but they are HAXM based, is that correct?

  • RofiqSetiawanRofiqSetiawan USMember ✭✭✭

    @batmaci Yes it works for both.

    And yes, Google's emulator is intel haxm based, not hyper-v.

  • batmacibatmaci DEMember ✭✭✭✭✭

    @RofiqiSetiawan How did you create emulator? I need to use latest Android SDK Tools as said in the this article but then I get message below in VS 2017 Preview

  • RofiqSetiawanRofiqSetiawan USMember ✭✭✭

    @batmaci
    From Visual Studio > Tools > Android > Android Emulator Manager

    • Choose "Device Definitions" tab
    • Select your preferred device eg. "Nexus 9"
    • Click "Create AVD" and set your preferred "Target" (OS) and "CPU ABI"

    Note: Don't forget to install system image for your target OS via Android SDK Manager

  • JoPedJoPed Member

    I have the same problem.
    I would show you the images but I'm a new member and can't upload them yet.

    Anyway I have installed Google APIs Intel x86 Atom System image for android 8.0, and I can choose Android 8.0 when creating a new emulator, but it says I have no system image installed (which I have). Is it the wrong system image, or am I doing something else wrong?

  • bagalsoffbagalsoff Member

    I'm having the same issue JoPed. And I also can't upload the images to showcase the issue. I have the same SDKs installed as @RofiqSetiawan but it's still telling me that there are no system images installed for this target (8.0).

  • RofiqSetiawanRofiqSetiawan USMember ✭✭✭

    @bagalsoff @JoPed

    Via Android SDK Manager, make sure you already have the latest version:

    • All Android SDK Build-tools
    • Your preferred Android API: its SDK Platform & system image

    and then please check under:

    <your-android-sdk-path>/system-images/
    

    It should contain several folders like these (depending on what system images that you have installed)

    ├── android-19/
    |   └── google_apis/
    |       └── x86/
    ├── android-22/
    |   └──google_apis/
    |       └── x86_64/
    ├── android-23/
    |   └── google_apis/
    |       └── x86_64/
    ├── android-25/
    |   ├── google_apis/
    |   |   └── x86_64/
    |   └── google_apis_playstore/
    |       └── x86
    ├── android-26/
    |   └── google_apis/
    |       └── x86/
    └── android-27/
        └── google_apis/
            └── x86/
    

    If it doesn't,
    try re-installing your SDK Manager https://developer.android.com/studio/index.html#downloads

    If you all still got stuck with this problem, maybe you can try:

  • bagalsoffbagalsoff Member

    Thanks for the help @RofiqSetiawan! I installed all the Android SDK Build Tools, the SDK platform, and the system images. I've confirmed that the folders are in that structure as well. When creating the AVD, the available list of targets has expanded to include all of the API levels I've installed, but unfortunately each one still says it has no available system images for each target.

    I've seen Genymotion mentioned a few times, but is unfortunately not an option due to the price. The Xamarin Android Device Manager is what I'm using right now I believe, it seems to be included with the latest release of Xamarin in Visual Studio.

Sign In or Register to comment.