Forum Visual Studio

The type 'ContentPage' was not found. Verify that you are not missing an assembly reference...

Chris_KChris_K USMember

I've hit this several times now with a project I'm working on (including restarting from scratch and re-importing all code). I'll make a change and all of the sudden VS doesn't recognize base objects and intellisense does not work. I've tried a number of fixes found on the web and nothing seems to work. Anybody encountered this and found a fix?

Answers

  • N_BauaN_Baua INMember ✭✭✭✭✭

    @ChrisKrummell ,

    Hi,
    In absence of the VS version (and the system OS) you use it would be rather difficult for anyone to comment.
    Though I encountered this issue in very beginning, I am taking a liberty to assume certain things to help you out.

    I had a Windows 8.1 setup with VS 2015 community edition on a modest 8GB RAM on Intel 3450 board with Core i5 processors. in first phase I just installed (rather updated) VS 2017 community edition with Xamarin, which lead me to tons of issues. I just couldn't figured it in time at that moment, so just went little bold and formatted my PC [don't forget to back -up your stuff, I lost my MyDocuments and few goodies in rush :) ].

    After PC format, I installed the VS 2017 CE (With Xamarin of course) again and it went smooth, though I had to download so many things again(In GBs man ,oh that killed my 3 days) , however the performance was not optimum.

    So I got, myself a new Dell core i7 -6500/2.5Ghz CPU Laptop, with Windows 10 64 bit, with 16GB RAM, now things work fine, copied few things from old PC to new laptop like Android SDKs etc.

    Though Xamarin gives some shitty development errors now and then, however nothing annoying from the point of view of hardware or installation issues.

    In a nutshell: Just start with a clean slate, if you can, saves a lot of trouble ahead.
    Hope this helps.

    Regards,
    N Baua

  • Chris_KChris_K USMember

    VS Studio 2017 Community / Current Xamarin. It's running on an i7 / 16gb custom built computer. I've done tons of C# development and had no problems - reformatting would be.... interesting. I've uninstalled and reinstalled xamarin several times including deleting everything I could find under user/AppData.

    The problem is very consistent, but I haven't been able to figure out what triggers it. Unfortunately, once the project gets buggered, it's done and can't be fixed. It happens within the Xamarin xaml, but the windows universal app portion doesn't seem to be affected. It seems to have started when I was trying to incorporate a plug in (https://github.com/rotorgames/Rg.Plugins.Popup).

    I'll see if it goes away in a fresh VS + Xamarin install in a VM.

  • N_BauaN_Baua INMember ✭✭✭✭✭

    Oh That's weird,
    I had something on that lines too, I also believed that the plug-in was causing things, however when I trashed everything and started fresh it worked. Hopefully you can also solve the problem that way, saving your PC from reformating.

    This is totally unrelated yet just to give you glimpse of things which worked for me while I thought plug-in was not working and my project gone for toss. XF is fun and challenge too.

    Hope you too resolve your problem soon

    Regards,
    N Baua

  • Chris_KChris_K USMember

    Tried an install under a VM and the same problem pops up. I've also found that if I check a project in using Git, then clone it elsewhere, intellisense also doesn't work. Can't really seem to find much help online, so might look at other development environments.

  • fcaldasfcaldas Member

    I am having exactly the same error and it's 2020, It seems like they haven't fixed it yet.
    I am on a Mac 16GB i7.
    Everything was working just fine, no issues. Now, this is happening.
    And, most interesting, I can run the app in an iPhone 11 phone but I cannot run it on an iPhone XR!

Sign In or Register to comment.