Xamarin Inspector unusable

Hi,

Despite the idea of Xamarin Inspector is great, the implementation is terrible.

-It doesn't zoom the visual layers, a tiny crowded bunch of layers are in the middle of the editor. Impossible to see.
-The "select view" button makes a dotted rectangle to appear but it doesn't correspond to what is displayed in the screen.
-The menu "View" disappear randomly
-The text in the filter box is removed every time you select a view

Please test the products before releasing them.
Alvaro.

Posts

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    Hello Friend,

    Thank you for your feedback. Could you please share what version of Inspector you have installed, and what OS you are using? Also, what kind of app are you inspecting?

    It doesn't zoom the visual layers, a tiny crowded bunch of layers are in the middle of the editor. Impossible to see.

    Could you attach a screenshot to demonstrate this?

    To answer some of your questions:

    • The "select a view" button allows you to place your mouse over your actual app, and select the view you are hovering over. If this is not working, can you specify the type of app, and maybe even share your UI code so we can try to reproduce? For iOS/Android, what type of simulator or emulator are you using?
    • The "View" menu hides when in the REPL tab, and shows when in the View Inspector tab. It is only useful in the View Inspector tab.
    • Keeping the same text in the property grid filter box does seem like a nice idea. Please file a bug for this feature request.

    Have a lovely day!

  • AlvaroRivoirAlvaroRivoir USMember ✭✭

    Win 10, Xamarin Workbooks 1.2.2, simulating iOS

  • AlvaroRivoirAlvaroRivoir USMember ✭✭

    -The "View" menu hides when in the REPL tab, and shows when in the View Inspector tab. It is only useful in the View Inspector tab.

    This is not working as you describe, in the "View inspector" tab, the menu disappear and it is not related to the REPL tab.

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    The "View" menu hides when in the REPL tab, and shows when in the View Inspector tab. It is only useful in the View Inspector tab.

    This is not working as you describe, in the "View inspector" tab, the menu disappear and it is not related to the REPL tab.

    Interesting, I am on 1.2.2 as well and not seeing that behavior.

    Does the "View" menu return if you switch to the "REPL" tab and then back to "View Inspector"?

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    Thank you for filing a bug. We are looking at some other property grid changes so it is now being tracked.

Sign In or Register to comment.