iOS Simulator - "Application Terminated" when testing on older iOS versions

Hi, I'm trying to test a simple hello world application.

When I installed Xamarin, I only had iOS 7 installed, and after I ran and tested stuff, I installed iOS 6 and 6.1. I made another project after closing Xamarin so it would know i had new versions of the simulator installed, and tried running it.

The application runs perfect on "iPhone Retina 4-inch iOS 7" but when I test it on iOS 6.1 and 6.0

I can't seem to get it to work on anything other than iOS 7.

I've attached two screenshots, one is iOS 7 and how it works 100% and another one is iOS 6.0, where it won't even run the app, it just terminates it. No output or anything :(

Thanks

Posts

  • PEIJUNLUPEIJUNLU CNMember

    Change your SDK Link from No Link to Link SDK only. You can find it at "iOS Bundle" Tab.

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    If you're running OSX Mavericks then it's a known issue that is fixed in 7.0.4 (alpha channel for now).

    Like said before this is something you can workaround, most of the time, by enabling the linker on your project (it's off by default for simulator builds).

  • MattMutzMattMutz USMember, University
    edited November 2013

    I had the same problem, but found a different solution than mentioned above.

    My app would run fine in iOS 7, then if I dropped down to a lower device or simulator (6.1) it would start, then I'd just get "Application Terminated" in my output window.

    What worked for me was to first go to the iOS Build tab in project properties and change the SDK Version to 6.0 instead of Default. Next I went to the iOS Application tab and changed Deployment Target to 6.0. After these changes, I could run in iOS 6.* and 7.

    Screen shots for reference where to find these:

    iOS Build

    iOS Application

  • @MattMuts. Thanks for the solution. It worked fine for me!

    Even the default Master-Detail view wouldn't work after I started it for the second time without changes.

    Hope that it will keep working..

  • This problem came back in the iOS 8 release. Now the iOS 7 / 7.1 simulator is not working anymore unless I enable the linker in the project properties.

  • AlexWhiteAlexWhite GBMember ✭✭✭

    I have the same problem with the 7.1 simulator the linker must be on or the app loads and crashes straight away, works fine on all physical devices with and without the linker.

    All The Best

    alex

  • ericwu1991ericwu1991 BRMember

    Happening again at iOS 10.

    Not sure why I'm bumping this post anyway, seeing how much official attention has been drawn since 2014.

Sign In or Register to comment.