Disable parenthesis on completion

Hi. I can't seem to figure out how to disable parenthesis completion in VS Mac and it's driving me insane.

What I have:

Console.WriteL<TAB> = Console.WriteLine();

What I want:

Console.WriteL<TAB> = Console.WriteLine

is this fixable?

Best Answer

Answers

  • victoriavictoria SEMember ✭✭

    Perfect! That worked, thanks.

  • ZmasterZmaster USMember ✭✭

    On a related matter, how do you disable the automatic closing bracket when you open one?
    Ie. you type ( but () appears. Same for other types of brackets.

  • victoriavictoria SEMember ✭✭

    I would like to know this too actually. It's terribly annoying when you're not used to it. As I've already accepted an answer in this thread, I suggest you make new post about it!

  • mattwardmattward GBMember Xamurai

    For the automatic closing bracket generation you can disable that in preferences - Text Editor - Behavior - Insert matching brace.

  • ZmasterZmaster USMember ✭✭

    Oh. How did I miss that?
    That's exactly what I was looking for. Thank you Matt!

  • akamudakamud BRUniversity ✭✭
    edited October 19

    Apparently this option is gone from VS for Mac 7.2.

    Is this a bug? I can't see why you would do that.

  • mattwardmattward GBMember Xamurai

    @akamud - The option has not been removed. My only guess is that you are opening project options maybe? This is the global preferences which is available from the main Visual Studio menu.

  • akamudakamud BRUniversity ✭✭
    edited October 19

    I'm looking at the global preferences.

    My VS version:

  • mattwardmattward GBMember Xamurai

    You need to open Text Editor - Behaviour. In the screenshot you have opened Text Editor - Intellisense.

  • akamudakamud BRUniversity ✭✭
    edited October 19

    @mattward said:
    You need to open Text Editor - Behaviour. In the screenshot you have opened Text Editor - Intellisense.

    The accepted anwer tells me to open Intellisense options:

    @BytesGuy said:
    You should be able to change this by going to Visual Studio -> Preferences -> Text Editor -> Intellisense

    Look for the "Automatically insert parentheses after completion" option

    To be clear, I don't want to disable matching brace, I just want to disable parenthesis after completion. This was possible before.

  • mattwardmattward GBMember Xamurai

    @akamud - Sorry my misunderstanding. Looking at the code this option has been removed. So with Visual Studio for Mac 7.2 you can only enable/disable the Text Editor - Behaviour - Insert matching brace.

  • akamudakamud BRUniversity ✭✭
    edited October 20

    @mattward said:
    @akamud - Sorry my misunderstanding. Looking at the code this option has been removed. So with Visual Studio for Mac 7.2 you can only enable/disable the Text Editor - Behaviour - Insert matching brace.

    Why was that removed? It is really counterproductive for people not used to it. Is there anyway to reenable this? Is this feature coming back in future releases?

  • mattwardmattward GBMember Xamurai

    I believe this was removed because the feature is not available in another library (Roslyn) being used. There is no way to re-enable this in VS for Mac 7.2. It may come back in a future release if the library adds support for it.

Sign In or Register to comment.