Installation fails for Windows

fafasefafase FIMember

So I install on Windows10, I do have Visual Studio 2015 entreprise. I also have a 2017 community and the VS from Unity (maybe that is the problem...).

I can run the installer, it passes the Android fine but fails on Windows with the following log (I only took the final part maybe more is needed):

[Info] Property(S): SourcedirProduct = {E5F989DF-91EB-42F1-95F0-B44CF9958FBE} [Info] MSI (s) (2C:88) [17:25:13:352]: Windows Installer reconfigured the product. Product Name: Xamarin. Product Version: 4.5.0.476. Product Language: 1033. Manufacturer: Xamarin. Reconfiguration success or error status: 1603. [Info] === Logging stopped: 6/3/2017 17:25:13 === [2017-06-03 14:25:13.511] [Info] END >>>>>> msiexec log: '<USER_HOME>\Temp\tmp3B5.tmp' [2017-06-03 14:25:13.513] [Info] Status: failed. [2017-06-03 14:25:13.514] [Exception] Installation of software item 'Xamarin' failed with exception. [2017-06-03 14:25:13.514] [Exception] Xamarin.Web.Installer.InstallException: Installation of archive '<USER_HOME>\Temp\Xamarin\downloads\Xamarin.VisualStudio_4.5.0.476.msi' failed with exception. ---> System.InvalidOperationException: MSI execution failed. [2017-06-03 14:25:13.514] [Exception] at Xamarin.Web.Installer.Utilities.InstallMSI(String file, Boolean needsPrivileges, Action3 processCommandArguments)
[2017-06-03 14:25:13.514] [Exception] at Xamarin.Web.Installer.Installer.InstallationArchiveHandler.Install(String path, Boolean needsPrivileges)
[2017-06-03 14:25:13.514] [Exception] --- End of inner exception stack trace ---
[2017-06-03 14:25:13.514] [Exception] at Xamarin.Web.Installer.Installer.InstallationArchiveHandler.Install(String path, Boolean needsPrivileges)
[2017-06-03 14:25:13.514] [Exception] at Xamarin.Web.Installer.Installer.BaseSoftwareItem.InstallDownloadedItem(String url, InstallationArchiveHandler handler, DownloadServiceWorkItem download)
[2017-06-03 14:25:13.514] [Exception] at Xamarin.Web.Installer.Installer.BaseSoftwareItem.Install(UInt32 tryNumber)
[2017-06-03 14:25:13.514] [Exception] at Xamarin.Web.Installer.Installer.XamarinVSSoftwareItem.Install(UInt32 tryNumber)
[2017-06-03 14:25:13.514] [Exception] at WindowsInstaller.ProgressPage.InstallationWorker()
[2017-06-03 14:25:13.516] [Info] Status: failed.
[2017-06-03 14:25:13.518] [Debug] Showing manual installation window because of error
[2017-06-03 14:25:13.723] [Debug] Starting installation complete task.
[2017-06-03 14:25:13.727] [Info] Background installation worker completed.
[2017-06-03 14:25:13.731] [Info] Installation completed with failure
[2017-06-03 14:25:13.734] [Info] Status: failed.`

Before installation, it runs the needed components and mentions VS extension is missing but claims it will install it.

Any help?

Answers

  • kentuckerkentucker USMember ✭✭✭✭✭

    Did you try installing the windows 10 sdk at the same time or before you install xamarin

  • MicahPhillipsMicahPhillips USMember
    edited June 2017

    I'm having the same issue, though my big difference maybe is I didn't install VS2017. Everything else is the same though, and I know that I have Windows 10 SDK already. I don't think that has anything to do with it. I think the offending line is:

    Xamarin.Web.Installer.Installer.InstallationArchiveHandler.Install(String path, Boolean needsPrivileges)

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Bugzilla cross-reference

    The workaround is to run the Xamarin.VisualStudio .msi installer by hand (you will find it downloaded in "%LOCALAPPDATA%\Temp\Xamarin\downloads") or to use the checkbox for Xamarin in the Visual Studio 2015 installer (in Control Panel > Programs > Programs and Features > Change [button], under the Cross Platform Mobile Development section) rather than using the XamarinInstaller.exe installer.

  • jasonliang.0839jasonliang.0839 USMember

    I Installed Visual Studio 2017 from Xamarin website , then create app1 , then I clicked the layout/main.axmal and got very long message , I reinstalled /uninstalled Visual Studio 2017 from Xamarin for many times but it still is showing me:
    System.IO.IOException: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. ---> System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
    at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
    --- End of inner exception stack trace ---
    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
    at Xamarin.AndroidDesigner.Java.JavaCommunicationContext.ReadMessageLoop() in C:\d\lanes\4699\fec6f88f\source\xamarinvs\External\md-addins\MonoDevelop.MonoDroid\Xamarin.AndroidDesigner\Xamarin.AndroidDesigner.Java\JavaCommunicationContext.cs:line 227

    What should I do ?

  • fafasefafase FIMember

    Ok so I actually managed to install it in the end.

    Basically, I had VS2017 entreprise so I just added the package via the installer. Done.

    Maybe the external installation was conflicting somehow, dunno, maybe some experts will confirm.
    But using the installer, it went just fine on first attempt.

Sign In or Register to comment.