How to set Image property for UIImageView in Storyboard editor?

MarkoBrkovicMarkoBrkovic HRMember ✭✭

I've asked the same question in Xamarin in Visual Studio subforum with no answer...So please if anyone could help me with this.

I'm having trouble setting Image property of UIImageView in Storyboard editor in VS2017. I select UIImageView in Storyboard and in properties pane try to select Image but that triggers Open File Dialog and selecting an image there just adds it to the root of my project and does nothing with the my UIImageView.

Best Answer

Answers

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    @MarkoBrkovic

    Sounds like a bug I once filed: https://bugzilla.xamarin.com/show_bug.cgi?id=45088

    or a similar one:
    https://bugzilla.xamarin.com/show_bug.cgi?id=43226

    Perhaps try adding the image to your Resources folder first (or to an image set in your asset catalog if using asset catalogs for your images) and then opening the storyboard. IN the case of the first bug noted above, the issue was that the iOS Designer did not pick up images added while the storyboard was open, so you had to close and re-open the storyboard to pick up any new images.

  • MarkoBrkovicMarkoBrkovic HRMember ✭✭

    Well, I thought it might be the problem, but I have existing images in Resources folder and I opened and closed Storyboard a million times. I guess it is a bug then. It actually started acting out since the last Visual Studio/Xamarin update.

  • MarkoBrkovicMarkoBrkovic HRMember ✭✭
    Accepted Answer

    It just started to work with next update.

Sign In or Register to comment.