The "User7ZipPath" parameter is not supported

GVxGVx USMember ✭✭✭

I am getting this error a lot more lately.. It's another of those random things that sometimes does or not occur when doing an iOS build...

1>C:\Work\MCD\Mobile\packages\Xamarin.Build.Download.0.4.5\build\Xamarin.Build.Download.targets(55,4): error MSB4064: The "User7ZipPath" parameter is not supported by the "XamarinDownloadArchives" task. Verify the parameter exists on the task, and it is a settable public instance property.
1>C:\Work\MCD\Mobile\packages\Xamarin.Build.Download.0.4.5\build\Xamarin.Build.Download.targets(51,3): error MSB4063: The "XamarinDownloadArchives" task could not be initialized with its input parameters.

Suggestions on how to fix ?

Best Answer

Answers

  • ChrisBoehmChrisBoehm USUniversity ✭✭

    I'm getting this issue also at the moment. Have you resolved it yet?

  • GVxGVx USMember ✭✭✭

    Unfortunately not.... Xamarin is just full of bugs at the moment..... :neutral:

  • Very true

  • This resolves my problem:

    1. Delete packages folder
    2. Delete bin and obj folder
    3. Restart and Rebuild the project

    I hope this will help you

  • eubikeubik Member ✭✭

    @DeepakDY Thanks! That resolved both errors for me

  • RochaPiresRochaPires PTMember ✭✭

    My Xamarin.Build.Download package is already in the latest version in every project requiring it but I still get this error.

    My workaround is, whenever this error happens, I remove and add a random package to the project. I don't know what happens behind but I am able to run the project. I have to do this workaround every time I close and open Visual Studio. This is very annoying and time consuming.

  • ThamaraiThamarai Member ✭✭

    I am getting this error in Xamarin.Android. I have latest version for Xamarin.Build.Download too... But error remains still.

  • DeepakDYDeepakDY INMember ✭✭✭

    Hello @Thamarai

    Remove Xamarin.Build.Download package from only Android section.

  • GautamJainGautamJain INMember ✭✭✭

    Thanks @DeepakDY . That worked!

Sign In or Register to comment.