[VS4Mac] The ASP.NET extension is not installed

Since the latest update of visual studio for mac (7.0.1), I cannot load my asp.net projects anymore. There is a warning saying "The ASP.NET extension is not installed"!
Then in the extensions, the extension is installed but it requires MonoDevelop.AspNet v7.0.1 to run. Any ideas on how to solve that? This is pretty urgent, I cannot debug my apps anymore!


  • mattwardmattward GBMember Xamurai

    Is this a third party extension? The ASP.NET extension that is included with VS for Mac is the MonoDevelop.AspNet extension and that does not seem to have any error message that includes the text "ASP.NET extension is not installed". The MonoDevelop.AspNet extension is called "Web Project Support" in the extension manager. Is that disabled?

  • EmmanuelMathotEmmanuelMathot USMember ✭✭

    I migrated from Xamarin Studio to Visual Studio as recommended. Since then, all my ASP.NET projects have the same issues (see screenshots). How do I install the MonoDevelop.AspNet v7.0.1 that seems to be the missing module?

  • mattwardmattward GBMember Xamurai

    I would try removing the addin database to see if that fixes it. First close VS for Mac. Then find the addin database directory addin-db-002 which should be located here: ~/Library/Caches/VisualStudio/7.0/addin-db-002/

    If you rename the addin-db-002 directory to something else, such as addin-db-002-bak, then restart VS for Mac the database should be regenerated again and hopefully the ASP.NET addin will be available again.

  • EmmanuelMathotEmmanuelMathot USMember ✭✭

    I tried your fix but without success, I still have the same error. Any clue to debug or trace the usage of that module?

  • mattwardmattward GBMember Xamurai

    With VS for Mac 7.0.1 if I search for asp in the extension manager I see two extensions.

    • Web Project Support
    • Mono Soft Debugger Support for ASP.NET

    The Web Project Support is the ASP.NET extension. If I disable that in the extension manager and then open an ASP.NET project I see the same warning message in the Solution window saying that the ASP.NET extension is not installed.

    So I would first check the extension manager. Then I would look in the IDE log to see if there are any errors there (Help - Open Log Directory). My IDE log has an entry saying that the AspNet extension has been loaded: Add-in loaded: MonoDevelop.AspNet.

    Also when deleting the addin database VS for Mac should not be running. It looks like I just said restart VS for Mac after renaming the addin database.

  • EmmanuelMathotEmmanuelMathot USMember ✭✭
    edited July 2017

    In the ide.log, I found issues due to the case sensitive file system on my macbook.
    2 files required by ASPNet addins were not found by the IDE.

    ERROR: /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/MonoDevelop.AspNet.dll: The file '/Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/StyleSheetTemplate.css' referenced in the manifest could not be found.
    ERROR: /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/MonoDevelop.AspNet.dll: The file '/Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/AspNetCore/RazorTaghelper.xft.xml' referenced in the manifest could not be found.

    I therefore created symbolic link with the right filenames.

    StyleSheetTemplate.css -> StylesheetTemplate.css
    RazorTaghelper.xft.xml -> RazorTagHelper.xft.xml

    There is no more error in the log but the ASP.Net extension is still not loaded. In the ide.log, I see

    WARNING [2017-07-05 19:19:39Z]: Could not load ASP.NET Web Application project 'FeatureServer.csproj'. The ASP.NET extension is not installed.

    Could you please check if there is any other issues linked to case sensitivity

  • EmmanuelMathotEmmanuelMathot USMember ✭✭

    Deleting again the folder ~/Library/Caches/VisualStudio/7.0/addin-db-002/ after all solved the problem! Great!

    So please report the issue of the case sensitivity file dependencies in the manifest of the ASP.Net extension.
    Thank you!

  • mattwardmattward GBMember Xamurai

    The incorrect case for the imported files was fixed a little while ago in VS for Mac:


  • EmmanuelMathotEmmanuelMathot USMember ✭✭

    Perfect! I think it is not yet available in the stable channel.
    Anyway, problem solved!

  • mattwardmattward GBMember Xamurai

    Correct, the fix is not yet in stable. It will be in the VS Mac 7.1 release. Looking at the tags the fix should be in the version that is currently available from the beta channel.

  • MichaelThwaiteMichaelThwaite USMember ✭✭
    edited December 2017

    I believe that this error has resurfaced in Visual Studio for Mac 7.3 (build 797).

    My log is as follows - The files in the :
    ERROR: /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/MonoDevelop.AspNet.dll: The file '/Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/StylesheetTemplate.less' referenced in the manifest could not be found.
    ERROR: /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/MonoDevelop.AspNet.dll: The file '/Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/StylesheetTemplate.scss' referenced in the manifest could not be found.
    WARNING: The add-in 'MonoDevelop.Debugger.Soft.AspNet,7.3' could not be updated because some of its dependencies are missing or not compatible:
    missing: MonoDevelop.AspNet,7.3
    INFO [2017-12-05 07:31:53Z]: Add-in loaded: MonoDevelop.AspNetCore
    WARNING [2017-12-05 07:31:57Z]: Could not load ASP.NET Web Application project 'myFoodDays.csproj'. The ASP.NET extension is not installed.

    I too use case-sensitive file system. There is a reference to StylesheetTemplate.less and StylesheetTemplate.scss that have been incorrectly names in the application package.

    There are two fixes that work:
    First: Revert to VS 7.2.2 (build 11)

    1. Navigate to /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/ and duplicate the two files renaming them or probably just rename them which I confirmed appears to work.
    2. Delete ~/Library/Caches/VisualStudio/7.0/addin-db-002/ to remove the cached versions.
    3. Restart Visual Studio.

  • mattwardmattward GBMember Xamurai

    @MichaelThwaite Thanks for reporting this. Looks like the filenames were changed but not in the addin file that imports them.

  • MichaelThwaiteMichaelThwaite USMember ✭✭

    Just a reminder, this issue is still present/resurfaced in the current build. I wasn't clear if it'd been addressed and closed.

  • mattwardmattward GBMember Xamurai

    It should be fixed in Visual Studio for Mac currently available on the alpha/beta channel.

    It is not fixed in the current stable release Visual Studio for Mac

  • MichaelThwaiteMichaelThwaite USMember ✭✭

    OK, thanks, it's not a huge inconvenience to rename it in the current version anyway, just checking in.

  • EmmanuelMathotEmmanuelMathot USMember ✭✭

    The bug is still present in version :-(
    That becomes inconvenient to rename files at each update

  • EmmanuelMathotEmmanuelMathot USMember ✭✭
    edited February 7

    Actually, the same problem applies now on other files, actually also directories:

    1/ /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/docker/MonoDevelop.Docker/pt-BR/ --> /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/docker/MonoDevelop.Docker/pt-br/
    2/ /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/docker/MonoDevelop.Docker/zh-Hans --> /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/docker/MonoDevelop.Docker/zh-hans
    3/ /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/docker/MonoDevelop.Docker/zh-Hant --> /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/docker/MonoDevelop.Docker/zh-hant
    4/ /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/StylesheetTemplate.less --> /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/StyleSheetTemplate.less
    5/ /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/StylesheetTemplate.scss --> /Applications/Visual Studio.app/Contents/Resources/lib/monodevelop/AddIns/AspNet/Templates/StyleSheetTemplate.scss

  • MichaelThwaiteMichaelThwaite USMember ✭✭

    Oh dear, I wonder if there's a mechanism to alert all developers to the fact that case is sensitive?

    There are whole applications that won't run on case sensitive file systems and I'd hate this to become one, especially if Linux is a target and, if Apple follows through with its original plan to make APFS case sensitive by default.

Sign In or Register to comment.