"The application could not be profiled. Please ensure that is has been build successfully and [...]

Ron.SijmRon.Sijm USMember ✭✭

I'm using visual studio 2017 enterprice, the latest preview version on a windows machine and I'm trying to profile an iOS application.

On my mac I have the latest version from the alpha channel, and I can actually build and run my application.

However, when I try to run the profiler, I get the error message "The application could not be profiled. Please ensure that is has been build successfully and try again"

So in fact my application does build, I've tried both debug and release, and I keep getting the same error. Any way around this?

Answers

  • RodrigoMoyaRodrigoMoya ESXamarin Team Xamurai

    This usually happens when the app is not built with profiling support (yes, bad wording on that dialog :smile: ), so can you go to the project options of your iOS project and check 'enable development instrumentation' is enabled? Then, rebuild and profiling should work, I hope.

  • Ron.SijmRon.Sijm USMember ✭✭

    You mean this one, right?

    Yea I have that enabled. If I have it disabled, then the 'Tools -> Xamarin Profiler' menu option is disabled as well.

  • RodrigoMoyaRodrigoMoya ESXamarin Team Xamurai

    Yes, that one. This reminds me of a bug in XVS that was recently fixed, so can you check if you're up-to-date and, if not, upgrade to the latest?

  • Ron.SijmRon.Sijm USMember ✭✭

    Yea, I'm guess I'm up to date

    I'm not entirely sure which channel I'm on, since in visual studio you guys removed the 'Tools -> Options -> Xamarin -> Other -> Updates' menu that easily allows people to switch channels.

    But I have the 'Xanarin Updater' extention installed, and my 'Xamarin for Visual Studio' extention is marked [Experimental] - so I'd guess I'm on the alpha channel as well

  • JordanMaxJordanMax USMember ✭✭

    Any updates? I'm appearing to have the same issue.

  • Ron.SijmRon.Sijm USMember ✭✭

    As a workaround I could get the profiler to work on an iphone simulator, still not on actual phones though...

  • AlexanderOsokinAlexanderOsokin USMember ✭✭

    Any updates?

  • AntonShabanovAntonShabanov USMember
    edited June 14

    Same here. Any updates? Or how can I help investigate?

    Update:
    After I try to launch profiler from VS I gey the following error (replaced app name with XXX):

    Deploying 'XXX' into the device 'freeeeon'...
    Deploy failed. The app 'XXX' could not be deployed to the device 'freeeeon'. Error: error MT1001: Could not find an application at the specified directory: /Users/shabanov/Library/Caches/Xamarin/mtbs/builds/XXX/a662d49a3b030cb669a6c719b14f0a6d/bin/iPhone/Debug/XXX.app
    . Please check the logs for more details.
    
  • PatrickLongPatrickLong USMember ✭✭

    Having just spent the money to get an Enterprise license (just so i can get access to Xamarin Profiler) I too am getting this error. I am using VS2015 Update 3. Enable Profiling is ticked.

    Xamarin Build 4.5.0.476
    Xamarin.iOS 10.10.0.35

    The app itself is built. I assume we build it under the Debug configuration? How do i get around this? I am a lot less happy to just make do with issues now that I have upgraded to Enterprise

Sign In or Register to comment.