"The application could not be profiled. Please ensure that is has been build successfully and [...]

Ron.SijmRon.Sijm Ron SijmUSMember ✭✭

I'm using visual studio 2017 enterprice, the latest preview version on a windows machine and I'm trying to profile an iOS application.

On my mac I have the latest version from the alpha channel, and I can actually build and run my application.

However, when I try to run the profiler, I get the error message "The application could not be profiled. Please ensure that is has been build successfully and try again"

So in fact my application does build, I've tried both debug and release, and I keep getting the same error. Any way around this?

Answers

  • RodrigoMoyaRodrigoMoya Rodrigo Moya ESXamarin Team Xamurai

    This usually happens when the app is not built with profiling support (yes, bad wording on that dialog :smile: ), so can you go to the project options of your iOS project and check 'enable development instrumentation' is enabled? Then, rebuild and profiling should work, I hope.

  • Ron.SijmRon.Sijm Ron Sijm USMember ✭✭

    You mean this one, right?

    Yea I have that enabled. If I have it disabled, then the 'Tools -> Xamarin Profiler' menu option is disabled as well.

  • RodrigoMoyaRodrigoMoya Rodrigo Moya ESXamarin Team Xamurai

    Yes, that one. This reminds me of a bug in XVS that was recently fixed, so can you check if you're up-to-date and, if not, upgrade to the latest?

  • Ron.SijmRon.Sijm Ron Sijm USMember ✭✭

    Yea, I'm guess I'm up to date

    I'm not entirely sure which channel I'm on, since in visual studio you guys removed the 'Tools -> Options -> Xamarin -> Other -> Updates' menu that easily allows people to switch channels.

    But I have the 'Xanarin Updater' extention installed, and my 'Xamarin for Visual Studio' extention is marked [Experimental] - so I'd guess I'm on the alpha channel as well

Sign In or Register to comment.