which ports are needed for Live Player?

LesCandleLesCandle USMember ✭✭
edited May 14 in Xamarin Live Player

I've been able to get Live Player to work with the Color Control demo program on two phones inside my network by opening up port 8090 tcp outbound. It connects to 52.225.130.190:8090 which is obviously outside my internal 172.16.0.x network.

  1. Are any other ports needed?

  2. Would it be possible to have VS 2017 look for a phone Outside my network? I'd love to be able to have a client run a quick test on his phone!!! I haven't been able to get that to work. As VS 2017 is talking to an ip outside on the internet during normal use of Live Player (even when VS 2017 and the iPhone are both on an internal network), hopefully this is possible?

  3. Is there a way to remove the name of the iPhone's setup from the VS 2017 Live Player devices? I've changed my test phone names to match the color of their cases to make them easier to identify.

Answers

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    No ports need to be opened as everything talks over local WiFi. There is no support or plans to do anything outside of the local network at all.

    You can remove the device and re-add it after you change your device name. There is no management of device names at this time.

  • LesCandleLesCandle USMember ✭✭
    edited May 15

    I don't believe you are correct. Until I unblocked that port (setup an access rule) I couldn't get it to work with any of my phones which were connected to my local network. Xamarin is talking to an outside ip thru 8090 - or it doesn't work - at least on my network. I could watch the requests fail until I opened that port up.

    To clarify, VS 2017 is behind a proxy server firewall and talks to the outside world thru the proxy port 8080. The iPhone is also setup to use the proxy port 8080 to get outside. Everything inside my network is locked down as far as outside access other than http, etc. The request for 52.225.130.190:8090 came from VS 2017, not the iPhone.

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Ah, then yes that is the case if you have everything locked down like that. I will validate the port and document it, but both devices do need to be connected to the same network with internet access.

    Essentially what happens here is a handshake to exchange local ip information so the devices can communicate. Once the exchange the information then they disconnect and don't need to communicate. No other data is transmitted across though as everything then goes directly device to device.

  • LesCandleLesCandle USMember ✭✭
    edited May 15

    Since there is access outside the local network, will it be possible (at some future point) for VS 2017 to pair with an iPhone out on the Internet? This would be very useful for clients - and for potential clients!!!

    Also, is there a way to kill off the the live player named paired phone connections by some means? Deleting a registry entry or something more elegant?

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    On corporate networks the requirement for both device and computer to be on WiFi is a complete non-starter. We need port details so we can configure firewall/proxy rules to allow connections between WiFi and LAN.

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai
    edited May 19

    The port is 8090. Your computer does NOT need to be on WiFi, just the same network. They just exchange and talk via local IPs on the network. They only talk very shortly to a server to exchange this information, which is over port 8090, nothing else leaves the network.

  • AnvithaSAAnvithaSA USMember
    edited May 24

    @JamesMontemagno I have installed Visual Studio 2017 15.3 Preview with the Xamarin Updater and the port 8090 TCP outbound is open too. But the app still isn't able to connect to visual studio. The app just displays Connecting to visual studio and doesn't give any errors either. Both LAN and WiFi are on the same network. I ran a connection test on the app. It says WiFi : On , IP : Valid but Access Server : not reachable. What else needs to be done?

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    This means that your device can not reach the remote server so it would not work. Is your phone on VPN of some sort?

  • AnvithaSAAnvithaSA USMember

    No it isn't connected to any VPN.

  • YuriShteinmanYuriShteinman CAUniversity ✭✭
    edited June 6

    @JamesMontemagno What the problem can be if I successfully paired device and VS (I see green message on android phone and name of the device in Manage devices and in Debug drop-down list) but when I try to debug or use Live View I get errors described in my post here: https://forums.xamarin.com/discussion/97044/what-ports-are-required-for-xamarin-live-player/ if it is not firewall. BTW, I tested connection from another computer on the same network to mine and they connect. So, it doesn't look like a firewall problem in my case (or different problem?). You said "They only talk very shortly to a server to exchange this information, which is over port 8090". Is the same port used afterwards for debugging?

  • YuriShteinmanYuriShteinman CAUniversity ✭✭
    edited June 6

    I give up.
    My device says: WiFi : On , IP : Valid Access Server : reachable
    I did tracing with WireShark. There is no problem with firewall. My PC and phone talking to each other but as soon as I start Live View or debugging the Live Player the phone sends reset connection.

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    @YuriShteinman
    Is this on your Android device? It may be reporting the wrong IP address perhaps. What do you see in the settings? I have a new release with some fixes. I could add you to the Alpha

  • YuriShteinmanYuriShteinman CAUniversity ✭✭
    edited June 6

    @JamesMontemagno
    Yes, it is Android. I tried one of iPhone6 and one iPad but installer says in both cases that those devices are not supported. I don't have any more Apple devices :-(
    My PC address is 172.23.1.141, my phone address 172.23.1.133. They talk to each other as I can scan the code and my device name shows in VS. Alternatively if I don't scan but type the code from player in VS and click Connect they connect.
    What do you want me to check in Settings?
    Sure I can try alpha. Where to take it from?

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    Inside the settings section on the Android phone you should see the IP address that is used to communicate. That is interesting about the QR code not syncing it as they do the same thing...

    Once they are paired have you tried out the sample apps I listed in the forum to see if they run?

    iPhone 6 should work fine as the app works on iPhone 5+ running iOS 9+

  • YuriShteinmanYuriShteinman CAUniversity ✭✭
    edited June 8

    @JamesMontemagno The address is 172.23.1.133 which is on my network. What sample app? Can you show the link? I don't see in this thread any apps mentioned and all I could find is IOS sample and I need Android. My iPhone is apparently iPhone5 with lates iOS 10.3.2 and installer denies to install

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai
  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    You may want to try the "Live Run Current View" or run without the debugger to see if the debugger is causing the issue.

  • YuriShteinmanYuriShteinman CAUniversity ✭✭
    edited June 13

    @JamesMontemagno when I do "Live Run Current View" with your project I get on device log: Expression of type 'System.Object' cannot be used for parameter of type 'NInterpret.InterpretedObject of method 'System.Object InterpretDelegate(NInterpret.InterpretedObject, System.String,System.Type[],System.Object[]) (Argument Exception). The player text becomes red with "Visualisation Error".

  • YuriShteinmanYuriShteinman CAUniversity ✭✭

    @JamesMontemagno when I use debugger I get in Visual Studio "Unable to get MonoDroidStartInfo for project" and sometimes on device log: "Connection reset by peer (SocketException)"

  • YuriShteinmanYuriShteinman CAUniversity ✭✭

    @JamesMontemagno I guess you gave up too?

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    @YuriShteinman sign up for our alpha program if you can so I can get you a new build: https://forums.xamarin.com/discussion/98529

  • YuriShteinmanYuriShteinman CAUniversity ✭✭

    @JamesMontemagno done, it says I have to wait a week.

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    @YuriShteinman I am going to go through the first batch tomorrow.

  • YuriShteinmanYuriShteinman CAUniversity ✭✭

    @JamesMontemagno Is it going to work with 2017 Preview? I wouldn't like to install it to stable 2017 where I need to do actual work :smile:

  • JamesMontemagnoJamesMontemagno USForum Administrator, Xamarin Team, Developer Group Leader Xamurai

    It only works with VS 2017 15.3 Preview and VS for Mac Alpha

  • YuriShteinmanYuriShteinman CAUniversity ✭✭

    What is the time frame for an update of the player?

  • DanielMyersDanielMyers USMember

    Going back to the original subject of this thread. I see the port is 8090, but what server address are the device and Visual Studio trying to hit?
    My network guys want to know to correctly modify the firewall rules.

  • DanielMyersDanielMyers USMember

    Yes, I saw that. It doesn't mention IPs or server names.
    I see from the original post and my own use of TCPView that IP 52.225.130.190 port 8090 appears to be what we need to make a firewall rule for.
    HOWEVER, I just wanted to get confirmation that IP is indeed correct and there are no other IPs we'll need to worry about.

    Thank you

Sign In or Register to comment.