How do I create a cocoapod binding for a pre-release version

astjohnastjohn CAMember ✭✭

I'm trying to create a bindings for a pre-release version of a cocoapod. When specifying the pod name during pod init the error states that I should explicitly specify the version in order to install a pre-release version. How can I go about doing so? Is this possible?

Thanks!

Tagged:

Best Answer

Answers

  • ChrisLamont.3643ChrisLamont.3643 USUniversity ✭✭

    I have the same issue... I documented my failures here:

    https://stackoverflow.com/q/44268425/328397

  • ChrisLamont.3643ChrisLamont.3643 USUniversity ✭✭

    Looks like we need to edit a PodFile, as described below, but I need assistance in figuring out what needs editing

  • astjohnastjohn CAMember ✭✭

    @JGoldberger said:
    @ChrisLamont.3643

    I would think that you just open the Podfile, which should be in the root of your XCode project folder, and add the version number(s) you need?

    Yup. This is exactly what I had to do after the first attempt failed.

  • ChrisLamont.3643ChrisLamont.3643 USUniversity ✭✭

    When it comes to using CoccoaPods and Xamarin, I'm not sure why Xcode is needed. (please help)

    In my case I don't have an XCode project, rather I'm obtaining the CocoaPod from here

    To add another bump in this road, the podfile uses a custom source

    source 'https://github.com/cocoapods/specs'
    source 'https://github.com/twilio/cocoapod-specs'
    
    target 'TARGET_NAME' do
      use_frameworks!
    
      pod 'TwilioVoice', '=2.0.0-beta9'
    end
    

    What am I missing?

  • astjohnastjohn CAMember ✭✭

    Hi Chris,

    From there I believe I ran pod install and then sharpie pod bind. Try that and let me know how it goes.

Sign In or Register to comment.