Forum Xamarin.iOS

iOS 5 and 6 Simulator not working

Since I updated to Mavericks and the new version of Xcode, iOS 5 and 6 simulators have not been working. Anyone know why?

Posts

  • DeanCleaverDeanCleaver USMember ✭✭✭

    You updated to the latest Xcode? I've updated to Mavericks, and all simulators are working so it's not a global issue - seems to be more an individual issue.

  • oxozleoxozle RUMember

    You should select in
    Project Options > iOS Buils > Linker Options > Link SDK Assemblies only

  • SebastienPouliotSebastienPouliot CAXamarin Team Xamurai

    Mavericks has trouble loading GameController and MediaAccessibility iOS frameworks (even with weak references).

    Using "Link SDK assemblies" will (in most cases) remove any references to the bad frameworks, so the older simulator will be able to load the applications.

    The default simlauncher that ships with 7.0.3 (in alpha) channel does not link with those frameworks (since they are not often needed, even less in a simulator).

  • "Link SDK assemblies" worked. Thanks.

  • KizmarKizmar USMember

    This solution worked for me as well! Thanks!

  • "Link SDK assemblies" worked perfectly. Thank you very very much.

  • RonTaylor.2570RonTaylor.2570 USMember, University

    Thanks! "Link SDK assemblies" worked for me.

Sign In or Register to comment.