Forum Xamarin.iOS

Admob mediation failing in iOS 7 / Debugging an iOS binding

KenPespisaKenPespisa USBeta, University ✭✭

Until recently, I have been using the GoogleAdMobAds binding found on Github for several months with no issues. I'm using Admob mediation with iAd, so I made one small change to the binding to include the iAd mediation adapter. This has been running fine in an iOS 7 version of my app currently in the AppStore.

Within the past couple of weeks, however, I started noticing a problem during development. When using the iOS 7 simulator, the ads stop loading after the first iAd appears. Depending on the rotation, occasionally I'll see one or more Admob ads as expected, but as soon as an iAd appears, there are no more requests for ads and the ad banner eventually disappears.

If I run the exact same code in the iOS 6 simulator, it works fine. If I run the code on my iOS 7 device (or iOS 7 simulator), it fails.

That's about as far as I've been able to narrow down the problem. It seems like there is an error being swallowed somewhere. The app runs fine otherwise so I have no idea where or why the ad requests stop firing in iOS 7.

Does anyone have advice on how you can debug a binding?

Sign In or Register to comment.