Forum Xamarin.iOS

How to add a new device to provisioning profile

SmeSme USMember ✭✭✭

I originally set up my provisioning profile, and only had one device. However I am wanting to add a new device. I went to the iTunes Developer Account website, and edited the provisioning profile, and added the new device. However, after downloading the new profile and restarting visual studio, I am still unable to test on the new device.

I also recently updated XCode to 10.3, and i notice that when you click Xcode > Preferences, there is no longer a 'view details' button.

Answers

  • Richy_GeorgeRichy_George INMember ✭✭✭

    Please check your device is detecting and can be deployed in an Xcode sample project; just create a sample blank project and check Xcode is detecting your device.

  • SmeSme USMember ✭✭✭
    edited April 2017

    It can be deployed from XCode, but I managed to 'solve' the problem.

    In visual studio, I actually have two provisioning profiles, one is iOS Team Provisioning Profile: *, and the other is iOS Team Provisioning Profile: my.package.name. For some reason, the old device can only be deployed to if the second profile is selected, and the new device can only be deployed to if the first profile is selected. I'm not sure how I created it this way, but I guess my problem is 'solved'; I Just need to change the provisioning profile between the devices...

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai
    edited April 2017

    It could be an issue of the profile that you edited to add your new device did not get downloaded and installed correctly, or that when doing this both the old unedited profile and the new profile both end up on your Mac.

    What I might recommend is deleting all of the profiles from your Mac (delete the contents of:
    ~/Library/MobileDevice/Provisioning Profiles) and then re-download your profiles from Apple's developer portal to ensure that what you see in the portal is the same as what you have on your Mac.

    @Sme said:
    I also recently updated XCode to 10.3, and i notice that when you click Xcode > Preferences, there is no longer a 'view details' button.

    Yes, this is unfortunate, but Xamarin Studio added this functionality, but you have to install fastlane. See:

    https://developer.xamarin.com/guides/cross-platform/macios/apple-account-management/

    The above guide should help you get signed in to your Apple developer account in Xamarin Studio, then you will get the "View Details" like Xcode had in Xamarin Studio -> Preferences -> Publishing->Apple Developer Account.
    Note if you have 2 factor auth set up on your Apple developer account, you won't be able to sign in from Xamarin Studio. Disable 2FA for your developer apple id at this link if need be.

    And some more info on using fastlane for certificate and profile management:
    https://developer.xamarin.com/guides/ios/deployment,_testing,_and_metrics/provisioning/fastlane/

Sign In or Register to comment.