Xamarin Studio Debugger not working

LizticDevLizticDev USMember ✭✭

I have an Issue with the Xamarin Studio Debugger.
It is not working on Android as well as on iOS (not hitting breakpoints and Exceptions).
I used the standard Xamarin Forms App to test, and made sure that all settings are correct (Debug mode etc.).
For the same app opened in Visual Studio it is working.

UPDATE:
Breakpoint are being hit in the iOS native project but not in PCL and Android

Version Infos:

=== Xamarin Studio Community ===

Version 6.3 (build 863)
Installation UUID: 4b98e859-14c8-4a05-8f6f-7dd34ae3ad57
Runtime:
Mono 5.0.0.48 (2017-02/851b6c7) (64-bit)
GTK+ 2.24.23 (Raleigh theme)

Package version: 500000048

=== Apple Developer Tools ===

Xcode 8.3.2 (12175)
Build 8E2002

=== Xamarin Inspector ===

Version: 1.2.1
Hash: 0ea0a12
Branch: d15-1
Build date: Thu, 06 Apr 2017 20:24:44 GMT

=== Xamarin.iOS ===

Version: 10.8.0.175 (Xamarin Studio Community)
Hash: a04678c2
Branch: d15-1
Build date: 2017-03-28 14:05:38-0400

=== Xamarin.Mac ===

Version: 3.2.0.175 (Xamarin Studio Community)

=== Xamarin.Android ===

Version: 7.2.0.7 (Xamarin Studio Community)
Android SDK: */Library/Developer/Xamarin/android-sdk-macosx
Unterstützte Android-Versionen:
4.4 (API-Ebene 19)
5.1 (API-Ebene 22)
6.0 (API-Ebene 23)
7.1 (API-Ebene 25)

Version der SDK-Tools: 25.1.3
Version der SDK-Plattformtools: 24.0.0
Version der SDK-Buildtools: 23.0.2

Java SDK: /usr
java version "1.8.0_77"
Java(TM) SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot(TM) 64-Bit Server VM (build 25.77-b03, mixed mode)

Android Designer EPL-Code ist hier verfügbar:
https://github.com/xamarin/AndroidDesigner.EPL

=== Build Information ===

Release ID: 603000863
Git revision: a2163670efe259c85cd8f335d95b175068fbbe2a
Build date: 2017-04-03 14:33:15-04
Xamarin addins: 2045d688ea1420e0381b473360ca62a763eb7d04
Build lane: monodevelop-lion-d15-1

=== Operating System ===

Mac OS X 10.12.0
Darwin *.local 16.0.0 Darwin Kernel Version 16.0.0
Mon Aug 29 17:56:20 PDT 2016
root:xnu-3789.1.32~3/RELEASE_X86_64 x86_64

=== Enabled user installed addins ===

NuGet Package Management Extensions 0.12

IDE LOG (iOS launch):

WARNING [2017-04-20 10:02:39Z]: Project has no solution. Using project directory as base directory for NuGet. Project: '/DBT/iOS/DBT.iOS.csproj'
WARNING [2017-04-20 10:02:39Z]: Subversion addin could not load libsvn_client, so it will be disabled.
INFO [2017-04-20 10:02:40Z]: Add-in loaded: MonoDevelop.HexEditor
INFO [2017-04-20 10:02:41Z]: Add-in loaded: MonoDevelop.Debugger.Soft.AspNet
ERROR [2017-04-20 10:02:54Z]: Inspector is supported only for the iPhoneSimulator target platform
INFO [2017-04-20 10:02:59Z]: Launching app on device: /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mlaunch -sdkroot "/Applications/Xcode.app/Contents/Developer" --killdev "com.liztic.rt.dbt" --launchdev "
/DBT/iOS/bin/iPhone/Debug/device-builds/iphone9.3-10.3.1/DBT.iOS.app" --devname "iSYNTaX" --argument=-monodevelop-port --argument=10000 --setenv=XAMARIN_DEBUG_PORT=10000 --argument=-connection-mode --argument=usb
ERROR [2017-04-20 10:03:21Z]: Inspector is supported only for the iPhoneSimulator target platform
INFO [2017-04-20 10:03:23Z]: Launching app on device: /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mlaunch -sdkroot "/Applications/Xcode.app/Contents/Developer" --killdev "com.liztic.rt.dbt" --launchdev "*/DBT/iOS/bin/iPhone/Debug/device-builds/iphone9.3-10.3.1/DBT.iOS.app" --devname "iSYNTaX" --argument=-monodevelop-port --argument=10000 --setenv=XAMARIN_DEBUG_PORT=10000 --argument=-connection-mode --argument=usb
INFO [2017-04-20 10:04:16Z]: Add-in loaded: MonoDevelop.ILAsmBinding

Any Ideas?

Answers

  • LizticDevLizticDev USMember ✭✭

    Same on Visual Studio for Mac (Preview)

  • FullEnglishFullEnglish GBMember ✭✭

    Same here.

  • snotyaksnotyak USMember ✭✭

    It also isn't working for me. When this was a preview build a few days ago, I was able to hit breakpoints just fine when using mono 4.8.1, but it doesn't seem to be working with that for me.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    For users who have not yet updated to Visual Studio for Mac, the first recommended step to try to resolve this issue would be to update to Visual Studio for Mac for compatibility with the new portable PDB debugging format that is used starting in Xamarin's "15.2 Release".

    As announced at the Microsoft Build conference, Visual Studio for Mac is now generally available. It is the recommended environment for Xamarin developers on Mac moving forward. Visual Studio for Mac has all the features of Xamarin Studio, adds cloud and web development, and contains improvements for cross-platform mobile development.

    To get started with Visual Studio on Mac, download and run the Visual Studio for Mac installer.

    A new version of Xamarin Studio was also published to the Stable channel that will show a dialog that recommends the update to Visual Studio for Mac. See the Xamarin 15.2 release blog post for some other information about moving to Visual Studio for Mac.

  • snotyaksnotyak USMember ✭✭

    For me, the fix was to uncheck "Enable Optimizations" in my Android .csproj

  • Vaka.GopiNadhReddyVaka.GopiNadhReddy USMember ✭✭✭

    i change my mono 5 to mono 4.8.1, then it works fine with me

  • EricBrunnerEricBrunner USMember ✭✭
    @Vaka.GopiNadhReddy Can you explain me where I can change the mono runtime to 4.8.1 in VS 2015?
  • GerritOehlmannGerritOehlmann USMember

    Hi,

    I hope that this is the right context and not the wrong place for this, but:

    Last weeks were Xamarin hell. Didn't sleep well. Customer is running out of patience. Tried to get help on Sourceforge: https://stackoverflow.com/questions/44305127/xamarin-debugger-wont-attach-due-dll

    It's now in a complete random state ... sometimes I can debug, sometimes not, sometimes the whole IDE crashes.

    Best Gerrit

  • EricBrunnerEricBrunner USMember ✭✭
    @GerritOehlmann Please see my SO post and answer to that xamaron issue: https://stackoverflow.com/a/44152364/6638950

    Today a new f. . update was release and the Debugger is working only for Xamarin.Forms Android specific project in VS2015. iOS is still not debuggable in VS2015 :-( .

    Those xamarin guys are a pain in the ass.
    Hope it helps
    Best Eric
  • GerritOehlmannGerritOehlmann USMember

    Nope, doesn't help at all. I'm (trying to) developing on Mac with Xamarin IDE or VS2017. Sometimes it's possible to debug, sometimes not at all. To clarify this ... debugger randomly attaches to device!
    ... and I'm trying to develop a Xamarin.Forms project with iOS and Android and at the moment iOS project in solution is not even loaded.
    Best Gerrit

  • PeterMillsPeterMills GBMember ✭✭

    I'm getting this problem too, I can debug in the iOS app, but nothing in the shared classes - pretty upset considering all the time I've lost so far.

  • TestXamarin.2906TestXamarin.2906 USMember ✭✭

    Same here...very difficult to work

  • EricBrunnerEricBrunner USMember ✭✭
    Try the workaround described here and let me know if it works https://bugzilla.xamarin.com/show_bug.cgi?id=56893
  • WasimuWasimu CAMember
    edited August 7

    No luck the workaround doesn't work for me. Back to debugging with Console.Writeline, at least this works

  • PetarRaykovPetarRaykov USMember
    edited August 30

    In my case I had to set all projects:
    under PropertyGroup Debug|AnyCPU
    Optimize element to false

Sign In or Register to comment.