Forum Xamarin.iOS

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Xamarian deploying to device

AnamuUenishiAnamuUenishi USMember ✭✭

Hello,
I have never deployed an app for texting in a real ios device. Have only done it on a Iphone 7 plus Simulator. Watching some tutorials and how to do it this is what i have done so far. I have made a IOS Development Certificate, i have made an App id , I have connected a Device and entered the UDID then created a new device and at last i have made a Provisiong Profile with the Iphone 7 Device conected, The ios development Certificate Connected and the App ID Connected. After i have done all of that, i continue to watch all the tutorials but there seems to be a chnage which i can't figure out.

![](https://us.v-cdn.net/5019960/uploads/editor/fh/alqfps2kwj05.png "")

As you can see, in this picture there is a view detail button which you click then download your Provisiong Profile to your xcode but for me there is not View Detail button and instead it looks something like this.

![](https://us.v-cdn.net/5019960/uploads/editor/dw/3n84617k52jf.png "")

So unforutnetly i don't know what to do, i have watched other tutorials on how to Download the Provisiong Profile on Xcode and this is what i have done next, i went to Xcode > Window > Devices then right clicked on my Device then it looks something like this.

![](https://us.v-cdn.net/5019960/uploads/editor/7w/8p5gcipwocmi.png "")

So i click Show Provisiong Profiles press add then add my Provisiong Profile. I though this will work and then continued my steps

The next thing i did was go back to Xamarian went to info.plist double clicked it and then entered my Bundle Indentifer, The next thing i did was

![](https://us.v-cdn.net/5019960/uploads/editor/9j/uvm8lerv0dud.png "")

Right clicked the 2 Calculator file, went down to Options and then

![](https://us.v-cdn.net/5019960/uploads/editor/8s/nmt2ec3rn2j2.png "")

Set everything up, as you could see in the picture, Then i press run but it doesn't seem to work and this error message comes up

![](https://us.v-cdn.net/5019960/uploads/editor/p7/71za4z1nhtxl.png "")

I am pretty sure i have done everything right but there seems to still be an error. The only possible bit i think i could of got wrong is when there wasn't the view detail button so i did it a another way, maybe the promblem is i downloaded the Provisiong Profile on the IOS Device but no in the Xcode mac or something??. I don't have a clue what i did wrong and did everything about 5 times but still didn't work. It will be great if someone could help.

![](https://us.v-cdn.net/5019960/uploads/editor/we/mnfzon8ctj2q.png "")
![](https://us.v-cdn.net/5019960/uploads/editor/zy/cto9igmrrv3h.png "")
![](https://us.v-cdn.net/5019960/uploads/editor/3r/9t1dj3yr9xc7.png "")
![](https://us.v-cdn.net/5019960/uploads/editor/ve/pdxzz74aaiar.png "")

These are all the Certificate and stuff i did in the aPP development section.

Tagged:
Sign In or Register to comment.