Forum Xamarin Test Cloud (Read Only)

XTR injecting calabash crashing iOS app

Hey guys,

We created an .ipa in Xcode which when is installed from iTunes, runs very well(everything in the app is working on 100%). But when this exactly same .ipa is provided to XTR app, it crashes on the button segue. We think that the injecting process [ Injecting app with Test Cloud Agent (calabash server)... ] is reason why our app is crashing. When the app is installed via XTR, the app is working just fine until buttons which have defined segues in the press action are tapped. Yet XTR is able to catch all of the tap/swipe gestures on the background view and taps on the other buttons which are not segueing anywhere.

When we unchecked(turned off) In Preferences in General tab the "Automatically inject Calabash into iOS apps" the XTR event logging didn't work with app but after it installed the app the buttons with segue was working correctly.

So we also tried to link Calabash framework into our app so we could keep this injecting out of our app. We did it with help of this tutorial:

Yet it didn't help us. Now even when this option is turned off, the app is crashing after tapping on the buttons with segue. Strange is that the XTR is still saying that it is injecting our app :/

Some additional info which may be important:

We tried also to include Calabash-Server pod which didn't help.
We also tried to install this pod with and without Calabash framework present in the app.
Strange thing is that XTR is not registering system popups(allowing notifications, camera access..) decision(allow/deny) at all.
We checked on the app startup in Xcode that the calabash server is there -- via Xcode console output on the start up of the app.
After button with segue is tapped, the XTR most of the time(90%) is not catching this event, yet sometimes it catches the event and shows in the app, so we know that he can find the identifier for it(of course the app still crashes).
We tried to turn off/on UIAutomation with no results in change.
We have everything updated to latest version (Xcode, iOS, macOS, XTR(tried also dev build), calabash, ruby, all the gems).

Strange thing is, that when we discard all the controllers in the app hierarchy, and put new ones, the buttons segues are working for the new controllers in the view hierarchy(not the same controllers so maybe is it just a coincidence?)
Also we noticed that when there are in the NavigationBar multiple items(buttons) only most left and most right is working(segueing new controller) and all others are also crashing(segueing new controllers) .. they are made in code and the code for them is exactly same (this is even crashing after whole hierarchy is discarded and we create a new one).

Any help is very much appreciated.


Sign In or Register to comment.