Forum Xamarin.iOS

TestFlight Build Crashing at Startup - Without Generating any Crash Reports

ChrisLarkinChrisLarkin USUniversity ✭✭

I have been using TestFlight for several months now to distribute new builds to our beta testers and for the most part I haven't had any problems. As of today however, the app is crashing immediately after launch on all devices - without generating any crash reports, so I have no idea what the problem is.

The app runs fine in the simulator, and runs fine on our test devices if installed directly through Xamarin Studio (both debug and release versions are working). These crashes are only occurring installing the app through TestFlight. Can anyone offer any suggestions as to how I can track this problem down?



  • yvrezyvrez BEMember ✭✭

    I have the exact same issue. Have you found a workaround ? I have tried to rebuild the app and redeploy. The app is running fine when deployed from Xamarin to the device but is crashing instantly (without crash report) on the device.

  • ChrisLarkinChrisLarkin USUniversity ✭✭

    No I haven't yet. I have tried rebuilding and deploying several times now with various code segments removed but I still can't isolate the problem.

  • MartinLeistMartinLeist USMember ✭✭

    I am having the same issues. Even without update on the device my testflight app stopped working. Changing settings, updating everything on the development computers and changes to the Info.plist file did not help. I am using Visual Studio 2015 and 2017 with a connected mac-mini. What I found out is that I cannot deploy the app directly when the testflight-version is installed. I have to delete the app to deploy it directly. The direct deployed version works without problems then.

  • Dev.AlexDev.Alex USMember

    Have the same issue.

  • MartinLeistMartinLeist USMember ✭✭
    edited April 2017

    My app works again. The problem seems to be IPv6. My App was communicating with a webserver, that only had an IPv4 address. After changing the webserver configuration the app works again over testflight. Maybe this helps you too.

    EDIT: I've just heard that our server isn't changed to IPv6 yet. Seems that was not the problem. It just happened to start working again it seems, because there was no update of the app.

  • AndreRoelkeAndreRoelke DEMember

    We have the same issue, did anyone find a solution?
    Is it possible to publish the app anyway in the app store, or will it crash there too?

  • MartinLeistMartinLeist USMember ✭✭

    Our app now finally works. It seems that it was the location of your sqlite database. It was in the parentfolder to the app and now we changed it to the app folder itself. This seems to have done the trick for us. Maybe that information helps.

  • AndreRoelkeAndreRoelke DEMember

    It seems to be Xamarin.Forms version that causes the problem. When revert back to Xamarin.Forms version it works. Can anyone confirm this?

    We did not change the location of the database, we use MobileServiceSQLiteStore with the default location. We provide only the name of the database.

  • ChrisLarkinChrisLarkin USUniversity ✭✭

    Sorry I went MIA there for a while, but it looks like a couple people found some potential solutions so that's good.

    I was able to finally resolve the problem by revoking my signing credentials and generating new ones.

  • simonevalenzianosimonevalenziano ITMember

    same problem, it works in debug/release not in testflight.
    i tried with 2.3.3, 2.3.4 and 2.3.5 pre but it didnt work in any case...what if i try send it directly to approval process?

  • olivierbutlerolivierbutler USMember

    Hi to All,

    same issue.
    1) Build ( with debug config ) run ok when deployed in the device thru the cable.
    2) Build ( with release config with arch ARM7+ARM64 ) crash at start when deployed in the device thru the cable or thru TestFlight.

    If I disable "enable device-specifics build", this Build ( with release config with arch ARM7+ARM64) run ok.
    In that case, the IPA seems weirdly too small and Application Loader ends with this :
    ERROR ITMS-90502: "Invalid Bundle. Apps that only contain the arm64 slice must also have 'arm64' in the list of UIRequiredDeviceCapabilities in Info.plist."

    any hint ?

  • olivierbutlerolivierbutler USMember

    Resolved by doing : Solution Clean...

    so simple

  • SynteXSynteX NLMember ✭✭

    @olivierbutler said:
    Resolved by doing : Solution Clean...

    so simple

    i am facing the same issue, trying this now swell hopefully it wil work :neutral:

  • SynteXSynteX NLMember ✭✭

    Yep I can confirm that cleaning the solutions fixes this issue!!!!

  • KarstenBoehlerKarstenBoehler USMember

    We just found the solution for this problem:

    We use a custom font for our app and changed the font of the navigation bar in the AppDelegate.FinishedLaunching method by using UINavigationBar.Appearance.SetTitleTextAttributes.

    This caused the iOS version of our app to crash when distributing via TestFlight. We removed the the code to change the font and now we can publish the app again.

  • AndreiMisiukevich_AndreiMisiukevich_ USMember ✭✭✭✭✭

    @olivierbutler said:
    Resolved by doing : Solution Clean...

    so simple

    It helped me too)
    thanks a lot

  • HaiNguyen.6340HaiNguyen.6340 USMember ✭✭
    edited January 2019

    I learned a good lesson today, submitted my app to appstore without TestFlight, today I found myself scrambled after updated newly released version of my app. It crashed on every device.

    My case:
    I checked "Enabled device -specific builds" that was why it didn't crash on development, but crashed on TestFlight. Now, other than that I switch a few things such as ARM7s+ARM7+ARM64 and it started working on TestFlight, I am not entirely sure what caused this

  • alwydlalwydl Member ✭✭

    What solved for me was to Recreate the certificates, as my distribution one was going to expire in a month.

Sign In or Register to comment.