Inspector not showing

JonasRembrattJonasRembratt SEUniversity ✭✭
edited April 3 in Workbooks & Inspector

I'd like to look at the Inspector but I can't get it to show up.
Running VS2017 Enterprise I start my iOS app in the simulator and then click the Inspector icon in the toolbar. The result is the below output but no Inspector window show up anywhere. I should add that when I tried this the first time it did show up with a recommendation to upgrade to the latest version (Ithink it was 1.2 and from stable channel).

==== OUTPUT ====
InspectorDebugSession(3): Starting client... (breaking on Xamarin.InspectorSupport.BreakdanceStep and Xamarin.InspectorSupport.AgentStarted
Resolved pending breakpoint for 'Xamarin.InspectorSupport.BreakdanceStep()' to /Users/builder/data/lanes/4262/cdc01b9f/source/inspector/Agents/Xamarin.Interactive/InspectorSupport.cs:46 [0x00000].
Resolved pending breakpoint for 'Xamarin.InspectorSupport.AgentStarted(string)' to /Users/builder/data/lanes/4262/cdc01b9f/source/inspector/Agents/Xamarin.Interactive/InspectorSupport.cs:53 [0x00000].
InspectorDebugSession(3): HandleTargetEvent: TargetHitBreakpoint
InspectorDebugSession(3): StateChange: BreakdanceStarted -> StartAgentInvoking
Thread started: #7
InspectorDebugSession(3): HandleTargetEvent: ThreadStarted
InspectorDebugSession(3): HandleTargetEvent: TargetHitBreakpoint
InspectorDebugSession(3): Agent is inspectable with identity: xamarin-interactive://127.0.0.1:61001/v1?agentType=iOS&sessionKind=LiveInspection
InspectorDebugSession(3): StateChange: StartAgentInvoking -> AgentStarted
Thread started: #8
InspectorDebugSession(3): HandleTargetEvent: ThreadStarted
2017-04-03 10:16:21.962 Spike.CICDiOS[27102:1274391] [Info][00:00:00.1354800] iOSAgent (Start): iOS 'Spike.CICD' is available for interaction: xamarin-interactive://127.0.0.1:61001/v1?agentType=iOS&sessionKind=LiveInspection @ /Users/builder/data/lanes/4262/cdc01b9f/source/inspector/Agents/Xamarin.Interactive/Core/Agent.cs:233

Best Answers

Answers

  • JonasRembrattJonasRembratt SEUniversity ✭✭
    edited April 3

    When I manually started "Xamarin Workbooks" it seems the installation had been stalled. When finished I could indeed start the inspector from VS2017. The problem now is that it always gives an "Unable to connect" error. When I flip over to "View Inspector" I'm presented with a black rectangle and I also cannot "select a view". Clicking "Reconnect" results in that button disappearing but there's still no information presented in "View Inspector".

    You still need that log?

  • JonasRembrattJonasRembratt SEUniversity ✭✭

    I should mention that the iOS emulator is running in Windows 10 (not on the Mac). Do I still need to have the same Inspector version on the Mac? Also, is there a way to choose whether to run the iOS emulator on the PC or Mac?

  • JonasRembrattJonasRembratt SEUniversity ✭✭

    I upgraded Xamarin Workbooks on the Mac and now everything works as expected. Thanks!

  • SandyArmstrongSandyArmstrong USXamarin Team, Insider Xamurai

    Woo!

Sign In or Register to comment.