Cant Deploy After the iOS 10.3 update

csampaio01csampaio01 PTMember ✭✭✭

Hi, Im trying to debug in a real device my app, but after I updated the device to the iOS 10.3 it gives me this error:

error MT0010: Could not parse the command line arguments: System.AggregateException: One or more errors occurred. ---> Xamarin.Launcher.LauncherException: Unknown command line argument: '-install-progress'
--- End of inner exception stack trace ---
at Xamarin.Launcher.Driver.Main2 (System.String[] args) [0x0085b] in :0
---> (Inner Exception #0) error MT0018: Unknown command line argument: '-install-progress'<---

I updated the Visual Studio and Xamarin also.

Answers

  • bjhbjh CNMember

    me too!

  • fabiuz84fabiuz84 USMember ✭✭

    I get the same behavior on Visual Studio for MAC, but if I use Xamarin Studio ( on Mac) or VS 2017 (on Windows) I have no problem to deploy app on iPhone.

  • BrianKillenBrianKillen USMember ✭✭

    same here on Visual Studio for mac

  • NMackayNMackay GBInsider, University mod
    edited April 2017

    You probably need to update your Mac to XCode 8.3 and get the latest Cycle9 Xamarin patches.

  • BrianKillenBrianKillen USMember ✭✭

    I have the latest Xcode 8.3 and updated Xamarin.

  • BrianKillenBrianKillen USMember ✭✭

    same here on Visual Studio for Mac


    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mlaunch -sdkroot "/Applications/Xcode.app/Contents/Developer" -installdev "/Users/briankillen/dev/projects/Concierge/Concierge/Concierge.iOS/bin/iPhone/Debug/device-builds/iphone9.4-10.3/Concierge.iOS.app" --device ios "--devname=Brian's iPhone" -install-progress
    error MT0010: Could not parse the command line arguments: System.AggregateException: One or more errors occurred. ---> Xamarin.Launcher.LauncherException: Unknown command line argument: '-install-progress'
    --- End of inner exception stack trace ---
    at Xamarin.Launcher.Driver.Main2 (System.String[] args) [0x0085b] in :0
    ---> (Inner Exception #0) error MT0018: Unknown command line argument: '-install-progress'<---

    Application could not be uploaded to the device.

  • BrianKillenBrianKillen USMember ✭✭

    same here on Visual Studio for Mac


    /Library/Frameworks/Xamarin.iOS.framework/Versions/Current/bin/mlaunch -sdkroot "/Applications/Xcode.app/Contents/Developer" -installdev "/Users/briankillen/dev/projects/Concierge/Concierge/Concierge.iOS/bin/iPhone/Debug/device-builds/iphone9.4-10.3/Concierge.iOS.app" --device ios "--devname=Brian's iPhone" -install-progress
    error MT0010: Could not parse the command line arguments: System.AggregateException: One or more errors occurred. ---> Xamarin.Launcher.LauncherException: Unknown command line argument: '-install-progress'
    --- End of inner exception stack trace ---
    at Xamarin.Launcher.Driver.Main2 (System.String[] args) [0x0085b] in :0
    ---> (Inner Exception #0) error MT0018: Unknown command line argument: '-install-progress'<---

    Application could not be uploaded to the device.

  • HassanJawedHassanJawed USUniversity ✭✭

    Any updates on this? I am still facing this issue on Visual Studio for Mac

  • csampaio01csampaio01 PTMember ✭✭✭

    @HassanJawed try to uninstall and install again. And check for updates. Its working now on my mac.

Sign In or Register to comment.