Visual Studio doesn't generate the iOS “ipa” executable with Xamarin

I am trying to generate the ipa file in order to publish it to the Apple Store but Visual Studio (2015 Community Edition) doesn't create it.

I followed the steps from the official Xamarin docs but it doesn't work, I tried selecting "AdHoc", "Release" and "AppStore" (with iPhone platform selected), I have the last Xamarin updates in my Windows and Mac build hosts, the build process ends succesfully but the ipa file doesn't appear in the **Bin > iPhone > Ad Hoc (or Release) folder.

I am using the distribution profile.

I would really appreciate any help.

Best Answer

Answers

  • SebastianKruseSebastianKruse USMember ✭✭✭

    In the Ad Hoc folder should be a folder with a datetime in the name. This folder contains the *.ipa file if you build it that way. But I would recommand to use the Visual Studio for Mac or Xamarin Studio and use Build / Archive for publishing and upload the archive file with the XCode / Windows / Organizer (it will show up there if the build was successful).

  • JakovljevicIgorJakovljevicIgor USMember ✭✭✭

    Hi @AlbertoMndez did you check this thing ?

  • AlbertoMndezAlbertoMndez USMember

    @SebastianKruse It doesn't create any "AdHoc" folder, I only have "debug" and "release"

    @JohnMiller I will try it

    @JakovljevicIgor I tried checking it and didn't work, but I will try again

    I let you know when I can try your suggestions, Thank you all

  • JakovljevicIgorJakovljevicIgor USMember ✭✭✭

    @AlbertoMndez Did you create the AdHoc Distribution package ?

  • JakovljevicIgorJakovljevicIgor USMember ✭✭✭

    @AlbertoMndez Yaap you need that. Otherwise you cannot create a AdHoc deployment with the ipa :) Have fun

  • AlbertoMndezAlbertoMndez USMember

    @JakovljevicIgor I 'm new publishing to the Apple Store, I think I don't need the AdHoc, I only want to generate the ipa file in order to release it to the store, i said AdHoc because I saw it in the Xamarin docs and gave it a try but I only want to create the ipa file to release it

  • AlbertoMndezAlbertoMndez USMember

    @JohnMiller @JakovljevicIgor If I enable the "Build ad-hoc/enterprise package (IPA)" I get an "The RemoveDir task failed unexpectedly..." error and I can't clean or build the project

  • JakovljevicIgorJakovljevicIgor USMember ✭✭✭

    @AlbertoMndez Hi, whenever I face that problem I clean the solution, delete the data on my mac host, restart my dev and host laptop and try again. For me this is not an uncommon problem and this procedure sounds stupid but it works :)

  • AlbertoMndezAlbertoMndez USMember

    @JakovljevicIgor Which data do you delete in the Mac build host? The Xamarin folder placed in the Caches path?

  • JakovljevicIgorJakovljevicIgor USMember ✭✭✭

    @AlbertoMndez I currently do not have my mac with me to give you the full path, but It is the folder where the app build goes. Where you are supposed to find the Ad-Hoc Folder.

  • AlbertoMndezAlbertoMndez USMember

    @JakovljevicIgor Ok, I think I can find it, thank you, I will let you know

  • shubbyshubby USMember

    I am trying to run my solution on Xamarin test cloud. but Adhoc folder doesnot show any .ipa file

  • CornevanderWaltCornevanderWalt USMember
    edited November 2017

    I am using Visual studio 2017 on my Windows laptop to connect to a MacBook Pro (Mac build hosts) to build my Xamarin Forms application. I have also followed the steps as explained in the documentation and as post in the original post:

    I tried many combinations, but for my Xamarin forms project (Portable) I am compiling it as Release and my iOS as Ad-Hoc and using a Distribution profile.

    In the iOS project settings I have checked the "Build iTune Package Archive (IPA)" under the iOS IPA Options configuration settings.

    But after compiling the solution keeps writing to the DEBUG folder in the bin (without any IPA file) and the Ad hoc/ AppStore folders stay empty.

    I also tried to see if the IPA file may be created on the Mac build host and looked in the ~/Library/Xamarin/mtbs/build folder but could not find there any folder apart from the debug folder (and again no IPA file)

    Would appreciate some help on this please.

  • DanNordquistDanNordquist USMember ✭✭

    I'm in the same situation as CornervanderWalt. I have done everything documented but I cannot get an IPA file to generate anywhere...

    Anyone who can help us?

Sign In or Register to comment.