Android manifest and Device Compatibility

HelgeKeckHelgeKeck DEMember ✭✭
edited March 2017 in Xamarin.Android

Hi,

just pblished my first Android APP to the Play Store. The APP Targets Android 5.0 and i want to deploy the APP to all Devices with min. Android 5.0.

The Google Play Store tells me that my APP isnt compatible to any of my Devices, all of my devices have min. Android 5.0. Regarding to the Store my APP is compatible to only 4828 Devices and incompatile to 10292 Devices.

I dont understand why my APP isnt compatible to this wide range of Devices.

this is my APPManifest.xml, i hope someone can clarify it:

<?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" xmlns:tools="http://schemas.android.com/tools" package="com.helgekeck.wifitool" android:versionCode="3" android:versionName="1.0.2" android:installLocation="auto"> <uses-sdk android:minSdkVersion="21" android:targetSdkVersion="21" /> <uses-feature android:name="android.hardware.wifi" /> <uses-permission android:name="android.permission.PACKAGE_USAGE_STATS" tools:ignore="ProtectedPermissions" /> <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" /> <uses-permission android:name="android.permission.ACCESS_WIFI_STATE" /> <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" /> <uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" /> <uses-permission android:name="android.permission.CHANGE_WIFI_STATE" /> <uses-permission android:name="android.permission.UPDATE_DEVICE_STATS" /> <uses-permission android:name="android.permission.WAKE_LOCK" /> <uses-permission android:name="android.permission.INTERNET" /> <application android:label="WiFiTool" android:theme="@style/DarkTheme" android:icon="@drawable/Icon"></application> </manifest>

Thanks in advance

Helge Magnus Keck

Best Answer

  • HelgeKeckHelgeKeck DE ✭✭
    Accepted Answer

    it seems that only Android 7 users ae downloading the APP. The Store page says min. Android 5 required. Dont have any Special components in it.

    Any ideas?

Answers

  • HelgeKeckHelgeKeck DEMember ✭✭
    Accepted Answer

    it seems that only Android 7 users ae downloading the APP. The Store page says min. Android 5 required. Dont have any Special components in it.

    Any ideas?

Sign In or Register to comment.