Can't connect to mac

KrisAertsKrisAerts USMember

Hi,

The past day I've been trying to connect to a new Mac Mini from VS2015SP3 (Win10Ent x64) without success.
Things that I have done:
- Installed XCode and accepted the license (8.3 8E162)
- Installed Xamarin Studio for Mac even though it shouldn't be needed
- Switched to the alpha branch of Xamarin on both devices
- Connected to the Mac using Putty (SSH) from the Windows PC with success
- Tried connecting using the IP address
- I don't have OzCode or Resharper installed
- Deleted the contents from %localappdata%\Xamarin\MonoTouch.
- ...

I've attached the Xamarin Logs, hopefully they will be of any use to figure out this problem.

Any insight/suggestions are really appreciated.

Answers

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    @KrisAerts,

    I am not sure this is related yet or not. Please take a look at the latest tech bulletin for Xcode 8.3 support: https://releases.xamarin.com/technical-bulletin-xcode-8-3-support-for-vs-2017/

    You may need to use these versions of the tooling instead of the Alpha channel. Once you install the extensions for 8.3 support, change your Mac back to the Stable channel.

  • KrisAertsKrisAerts USMember

    John,

    Thx for the reply.
    Due to the switch to the alpha channel I already have newer tools available in VS2015 and I am given the message "This extension is already installed to all applicable products." unless these tools are only applicable to VS2017?

    Version of Xamarin.VisualStudio in the article is 4.3.0.795 while I already have 4.4.0.31 installed.

  • JohnMillerJohnMiller USForum Administrator, Xamarin Team Xamurai

    Hi KrisAerts,

    Sorry for the confusion. Yes, that is for 2017 only. Would you be able to try the Stable channel and let me know if you have the same issue? In the meantime, I am reviewing the logs you sent.

  • KrisAertsKrisAerts USMember
    edited April 2017

    Hi John,

    We have decided to upgrade to VS2017. This has solved our connection problem. I'm still puzzled why it's not working from VS2015 though.

    Thx for your time.

Sign In or Register to comment.