"System.ServiceModel requires Business edition", but System.ServiceModel is not referenced.

Hi. I have a solution consisting of

  1. a portable class library (.NET4.5 + WP8 + Windows store apps), Profile78
  2. an Android application that references the portable library.

Neither project references System.ServiceModel.dll!
But when I try to build the solution, Xamarin Studio stops with error message:

Error XA9003: Assembly 'System.ServiceModel, Version=2.0.5.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' requiresВ BusinessВ (or higher) License. (XA9003) (Application)

What can I do about it? My software versions:

  • Xamarin Studio Version 4.0.13 (build 38),
  • Xamarin.Android Version: 4.8.3 (Indie Edition)

Posts

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    This appears to be this bug. In short, since the Profile78 PCL profile references a facade assembly for System.ServiceModel, the library project looks like it's referencing System.ServiceModel even though it isn't. For the moment, one workaround would be to switch to a PCL profile that does not include support for any types from System.ServiceModel (for example .NET 4.0, Silverlight 5, WP8, Windows Store Apps). This bug will likely get cleaned up before the full stable release of PCL support.

  • Thank you Brendan! I can't use .NET 4.0-based PCL profile because I use TAP (async/await) which needs .NET 4.5 classes.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    While waiting on a bug fix for the facade assemblies, you could try out the portable Microsoft.Bcl.Async NuGet package. Depending on what you need, this might be an acceptable workaround, at least temporarily. Admittedly there is at least one tricky spot there too.

  • WilliamGrandWilliamGrand USMember

    I am having the same problem. Xamarin.Android 4.10.0 (Indie Edition)

  • lvlosslvloss USMember

    Same here :( How do I get around this?

  • ErikFAndersenErikFAndersen DKMember ✭✭

    I thought that the licensing prevented us from using Microsoft.Bcl.Async in Xamarin?

  • ErikFAndersenErikFAndersen DKMember ✭✭

    any new takes on the licensing issues now that Xamarin has partnered with MIcrosoft?

    it seems they are very focused on PCL's.

  • I'm having the same problem, and I have to publish my application this month. How to solve it?

  • zacgzacg CAMember

    I am also having this problem, any update?

  • I am getting this error in Jan 15, 2014 also. Is this fixed or not? Because I used the latest edition of Xamarin studio and Xamarin ios/android runtime. And I own a indie edition. Please let me know if this bug is fixed or not?
    I was actually trying to run a sample downloaded from Windows Azure Mobile Services ...Please let me know if any work around or should I drop using Windows azure mobile services ?

  • RichardHardingRichardHarding GBMember
    edited January 2014

    I'm in the same situation I'm also using the azure mobile services component and an Indie subscriber - I switched to the beta channel, updated and still get this issue, I also tried the alpha channel and that doesn't seem to have that fix either - [this jira issue]
    implies its fixed how do I get that build
    (xamarin android 4.12.0-1) to test?
    (https://bugzilla.xamarin.com/show_bug.cgi?id=13370)

  • Hi @RichardHarding, Did you get any clue on this issue? or you are still stuck like me on this issue? Please let me know if in case you found work around for this?

  • no so I raised a bug - https://bugzilla.xamarin.com/show_bug.cgi?id=17247 - it may be somthing to do with a later version of the - feel free to add to this bug

  • NeilWhitlowNeilWhitlow USUniversity ✭✭

    Bugzilla updated with steps to reproduce: same issue.

  • melankemelanke BRMember ✭✭

    I was not having this bug until some new XS update.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Hi! I tested this out a little in the latest beta version of Xamarin.Android (version 4.12.0, just promoted to the beta channel last week) and compared to the stable version (4.10.2). I think the problem with the Azure Mobile Services component is indeed the same old bug 13370. This bug has been fixed in version 4.12.0 (see also the release notes).

    If you still see problems after updating to Xamarin.Android 4.12.0, let us know!

  • leobragattileobragatti BRMember ✭✭
    edited March 2014

    Hello @BrendanZagaeski‌, i'm using the Xamarin 4.2.3 build 60, with Xamarin.iOS 7.2.0.2 and still having this problem. With Xamarin.Android 4.12.1 it works fine

  • DirkWeltzDirkWeltz DEMember ✭✭✭

    Hello,

    the same here. Also using XS 4.2.3 build 60 and Xamarin.iOS 7.2.0.2 Indee Edition.

    Compiling OsmSharp iOS Sample (https://github.com/OsmSharp/OsmSharp) I get the same error (System.ServiceModel needs Business Edition). Using the same project (most of it is PCL) on Xamarin.Android, I have no problems.

    It would be nice to have an solution for this problem.

    Thank you very much for your help.

    Best regards
    Dirk

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Thanks for getting in touch about the problem on iOS @LeonardoBragatti and @DirkWeltz! And apologies for the delayed reply. By luck, another user reported the problem here: https://bugzilla.xamarin.com/show_bug.cgi?id=18664, and a fix for the problem has been committed but not yet released. I've confirmed that the fix also repairs the issue for OsmSharp.

    Interestingly, one "workaround" for the problem in the iOS case is to switch the portable class libraries to .NET 4.5 PCL profiles (the opposite of the old Android problem). Unfortunately, for OsmSharp it's not quite as simple as just switching the profiles because the libraries use some features that vary between .NET 4.0 PCLs and .NET 4.5 PCLs. It would take some work to fix things up. For simpler projects, switching the profiles will probably work fine. This strategy might be helpful while waiting for the fixed version of Xamarin.iOS to be released.

  • DirkWeltzDirkWeltz DEMember ✭✭✭

    Thank you, Brendan, for comming back to this thread.

    So I will wait for the update. Do you know, with which version it will come?

    Best regards
    Dirk

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    I think there's a good chance it will be in the next beta version after Xamarin.iOS 7.2.1 moves to stable (likely numbered 7.2.2). But there's always a chance it will need to be pushed back a little, in case there's a hot fix release for 7.2.1 or similar.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Hi, just a little update on the iOS side of things:

    Unfortunately, the fix didn't make it into 7.2.2.2 or 7.2.3.35. As it turned out, both of those were indeed special releases that didn't follow the normal release progression. They were essentially incremental updates for Xamarin VS compatibility based on 7.2.1.

    My updated guess is that the fix will be in the next beta release after 7.2.3.35 moves to stable (soon).

  • MaackITApSMaackITApS DKMember
    edited October 2014

    Hey,
    I am now having this issue in October 2014 when trying to build an iOS project.

    It complains about:

    System.Servicemodel.ExceptionDetail

    System.Servicemodel.EndPointAddress10

    System.Servicemodel.EndPointAddress

    System.Servicemodel.EndPointIdentity

    I am pretty sure that I am not using that assembly.

    It is a cross platform project where I already have a functional Android app and a shared library. The iOS and Android projects in the solution both reference the exact same things. Android works, iOS gives this problem.

    Any fix?

  • LuisHerradaLuisHerrada MXMember

    I'm having this issue again in 2015 with the 5.7 version. This is very upsetting

  • QuintonCoetzeeQuintonCoetzee GBMember
    edited January 2015

    I'm also seeing this in 5.7, Xamarin.Android 4.20.0 (Indie Edition)

  • Bump - Also getting this, concerning this thread is 2 years old, Brendan can we have an update please.

    Thanks, Ed

  • TamilSelvanRTamilSelvanR USMember ✭✭

    I faced this same issue now. Very disappointing..

Sign In or Register to comment.