XamarinShellPackage package failed to load correctly

Hello All,
I have tried installing xamarin with VS 2015 community and even with VS 2013 but i still get XamarinShellPackage package failed to load correctly, XamarinAndroidPackage package failed to load and XamarinIOSPackage package failed to load.
I cant access Tools-->Options-->Xamarin-->Android/IOS/Other

I have tried clearing the ComponentModelCache , ran devenv.exe /setup /updateconfiguration. I still havent gotten to use Xamarin to create a project.
Here is an excerpt from the ActivityLog.xml:

1) Exception of type 'System.Exception' was thrown.

Resulting in: An exception occurred while trying to create an instance of type 'Xamarin.VisualStudio.Activation.ActivationManagerExporter'.

Resulting in: Cannot activate part 'Xamarin.VisualStudio.Activation.ActivationManagerExporter'.
Element: Xamarin.VisualStudio.Activation.ActivationManagerExporter --> Xamarin.VisualStudio.Activation.ActivationManagerExporter --> ComponentCatalog (Types='Clide.ClideSettings, Clide.ErrorsManager, ...').

Resulting in: Cannot get export 'Xamarin.VisualStudio.Activation.ActivationManagerExporter.ActivationManager (ContractName="Xamarin.VisualStudio.IActivationManager")' from part 'Xamarin.VisualStudio.Activation.ActivationManagerExporter'.
Element: Xamarin.VisualStudio.Activation.ActivationManagerExporter.ActivationManager (ContractName="Xamarin.VisualStudio.IActivationManager") --> Xamarin.VisualStudio.Activation.ActivationManagerExporter --> ComponentCatalog (Types='Clide.ClideSettings, Clide.ErrorsManager, ...').

Resulting in: Cannot set import 'Xamarin.VisualStudio.Android.Commands.LaunchMonoAndroidProfilerCommand..ctor (Parameter="activation", ContractName="Xamarin.VisualStudio.IActivationManager")' on part 'Xamarin.VisualStudio.Android.Commands.LaunchMonoAndroidProfilerCommand'.
Element: Xamarin.VisualStudio.Android.Commands.LaunchMonoAndroidProfilerCommand..ctor (Parameter="activation", ContractName="Xamarin.VisualStudio.IActivationManager") --> Xamarin.VisualStudio.Android.Commands.LaunchMonoAndroidProfilerCommand --> ComponentCatalog (Types='Clide.ClideSettings, Clide.ErrorsManager, ...').

Resulting in: Cannot get export 'Xamarin.VisualStudio.Android.Commands.LaunchMonoAndroidProfilerCommand (ContractName="Clide.Commands.ICommandExtension")' from part 'Xamarin.VisualStudio.Android.Commands.LaunchMonoAndroidProfilerCommand'.
Element: Xamarin.VisualStudio.Android.Commands.LaunchMonoAndroidProfilerCommand (ContractName="Clide.Commands.ICommandExtension") --> Xamarin.VisualStudio.Android.Commands.LaunchMonoAndroidProfilerCommand --> ComponentCatalog (Types='Clide.ClideSettings, Clide.ErrorsManager, ...').

Someone help me out!

Answers

  • JohnMillerJohnMiller John Miller US Xamurai

    @olagg,

    Try deleting the ComponentModelCache again. Then, run devenv.exe /ResetSkipPkgs from the command line.

  • olaggolagg ola gg US
    Heyy @JohnMiller,
    Tried that, it didn't work,still showing the error, I expected Xamarin to have dealt with the error totally..
  • JohnMillerJohnMiller John Miller US Xamurai

    @olagg,

    It's possible you are running into the issue described here: https://bugzilla.xamarin.com/show_bug.cgi?id=53042

    Make sure that you have .NET 4.6.2 installed. https://www.microsoft.com/en-us/download/details.aspx?id=53345

  • olaggolagg ola gg US
    I have installed .Net 4.6.2
    ..im still.having the error @JohnMiller
  • JohnMillerJohnMiller John Miller US Xamurai

    @olagg,

    Thanks for installing that! Did you re-install xamarin afterwards? If not, please run the installer again.

  • olaggolagg ola gg US
    Yes I re-installed xamarin amd even repaired xamarin after that still getting the error
  • JohnMillerJohnMiller John Miller US Xamurai

    @olagg,

    Hm, ok. Perhaps it's something different. Would you file an issue with the following information so that I can confirm?

    • Version information from the Help -> About Visual Studio
    • Screenshot of the Extensions and Updates menu showing which version of the Merq extension is installed
    • The ActivityLog.xml that the dialog mentions
    • The IDE log file from the Help -> Xamarin -> Open Logs menu after you launch VS.
  • olaggolagg ola gg US
    edited March 22

    ok, I'll do that
    but i cant find any Merq extension installed on my VS

  • olaggolagg ola gg US
    edited March 22

    @JohnMiller said:

    It's possible you are running into the issue described here: https://bugzilla.xamarin.com/show_bug.cgi?id=53042

    So i Installed the Merq Extension even though I could not see it in Extensions and Update. by extracting the XamarinInstaller as mentioned in the above link..

    msiexec /i "%USERPROFILE%\Downloads\Xamarin.VisualStudio_4.3.0.784.msi" /l*vx "%USERPROFILE%\Desktop\Xamarin.log"

    and now it seems to have worked
    I can now go to tools-->Options-->Xamarin--->Android...

    I hope it works for my VS 2015

    Thanks John

Sign In or Register to comment.