Subscription Page > Xamarin Installer for Windows not working (403 on InstallationSizes.xml)

EmmanuelHuna.6198EmmanuelHuna.6198 USMember ✭✭
edited March 2017 in Xamarin.Forms

We are using Visual Studio 2015 and a new developer joined our team and after downloading the Xamarin Installer for Windows from https://store.xamarin.com/account/my/subscription/downloads and running the Installer, he gets an error that he must install everything manually.

Looking at the Logs, we see:

[2017-03-15 18:25:41.935] [Exception] Failed to retrieve response for URL 'https://www.xamarin.com/installer_assets/v3/Windows/Universal/InstallationSizes.xml'
[2017-03-15 18:25:41.935] [Exception] System.Net.WebException: The remote server returned an error: (403) Forbidden.

If I point my browser to https://www.xamarin.com/installer_assets/v3/Windows/Universal/InstallationSizes.xml , I get -

<Error>
<Code>AccessDenied</Code>
<Message>Access Denied</Message>
<RequestId>74A6E8E4E83ECABA</RequestId>
<HostId>
Dw1RxymxXquuWLvanl+g/YnuGbfm+N8/xnscOXxTa+W2Rsec9UtaI17scyotmK8z/uWUKEBaHPM=
</HostId>
</Error>

Xamarin folks: can you please fix this?

I posted this also on https://forums.xamarin.com/discussion/89988/xamarin-4-3-0-784-install-manually-ok-but-will-not-install-from-the-xamarin-website - sorry for the double posting, but I felt this deserved its own thread instead of being buried under an 'Android' thread.

The post above mentions that installing VS 2017 is a possible solution - but for us Visual Studio 2015 users, having to install Visual Studio 2017 to solve this error is not a solution.

Answers

  • AshleyGazichAshleyGazich USMember, Xamarin Team Xamurai

    Hi Emmanuel, was your developer able to get set up by running the installer by hand? In case this is still an issue, here are the manual installation guides for Xamarin.iOS and Xamarin.Android for Windows.

  • EmmanuelHuna.6198EmmanuelHuna.6198 USMember ✭✭

    Hi Ashley - yes a couple of developers have now downloaded, installed, and configured each of the packages and features manually - and that works.

    I see https://static.xamarin.com/installer_assets/v3/Windows/Universal/InstallationSizes.xml is still not working - now there are SSL and 404 errors.

    Bummer, I used to love to tell developers that the "Xamarin Universal Installer rocks" and that it literally installs and configures everything you need.

    Any chance you could get the Universal Installer working again?

  • AshleyGazichAshleyGazich USMember, Xamarin Team Xamurai

    Excellent, I'm glad they were able to get up and running! The team is aware of of an installation issue, and is working to remedy it--apologies for the bumpy experience! We look forward to getting things running smoothly again soon. :smile:

Sign In or Register to comment.