NuGet install errors in new PCL for Android and iOS

Hello,

I created a new PCL and want to install SQLite-Net-PCL and SQLiteNetExtensions.

I keep getting these errors installing SQLite-Net-PCL, trying everything from various articles...

Could not install package 'sqlite-net-pcl 1.3.1'. You are trying to install this package into a project that targets '.NETPortable,Version=v4.0,Profile=Profile136'
Could not install package 'System.Runtime.InteropServices.RuntimeInformation 4.0.0'. You are trying to install this package into a project that targets '.NETPortable,Version=v4.5,Profile=Profile111'

Questions:

What Profile should I be using to be able to install these packages??
Any caveats to the profile? i.e.: include/exclude any target frameworks?

I'm using latest Xamarin Studio, all Android and Xcode up to date. On a Mac.

Thx

Tagged:

Answers

  • mattwardmattward GBMember Xamurai

    I would install the older 1.2.1 version of SQLite-Net-PCL which should avoid this install error. The older versions do not have any .NETStandard dependencies. SQLite-Net-PCL 1.2.1 installs into a Portable Class Library project that targets profile 111.

  • Thank you Matt.

    Do you know of limitations? differences between the two?
    Also looking to install SQLiteNetExtensions (which might need the v1.3.1 SQLite-Net-PCL).

    I will try it all though.

    Any other suggestions on what to do to actually get 1.3.1 installed would be welcome.

    Thx!

  • mattwardmattward GBMember Xamurai

    I do not know what the differences are with the different versions of SQLite-Net-PCL. You would have to look at the source code.

    To install the SQLite-Net-PCL 1.3.1 version you can install NETStandard.Library 1.6.1 first before installing it. That will prevent the error about System.Runtime.InteropServices.RuntimeInformation. However it will add a lot of NuGet packages (30+) to your packages.config file.

Sign In or Register to comment.