Android SDK is too old even though I've already updated it

Hi there. I've been using Xamarin on Visual Studio 2015 update 2 for a couple of projects and yesterday I upgraded it to update 3. I tried to create a new project, Android blank app and when I opened the layout it says my SDK is too old. Here's the screenshot:
The weird thing is, I don't think my SDK's version is old, I've already updated that too:
I don't know, is there something missing? I've completed all the requirements(SDK, JDK, NDK)

Sign In or Register to comment.